NetBSD and NE2000 compatible adaptors.

NetBSD and NE2000 compatible adaptors.

Post by SysOp no Centro de Operacoes de Red » Wed, 24 Apr 1996 04:00:00



  Hi there!
  I have a 486 PC with two Compex (NE2000 compatible) network
adapters.
  I have installed NetBSD 1.1 in my PC, I have configured my
network adapters with ifconfig, and everything OK:

        ifconfig ed0 xxx.yyy.zzz.252
        ifconfig ed2 xxx.yyy.zzz.253

  but when I try to ping to a machine in my network, I get:

        ping xxx.yyy.zzz.10
        ed0: device timeout

  Any sugestions anyone ?

        Thanks in advance!


 
 
 

NetBSD and NE2000 compatible adaptors.

Post by Manuel Bouy » Wed, 24 Apr 1996 04:00:00



Quote:>   Hi there!
>   I have a 486 PC with two Compex (NE2000 compatible) network
> adapters.
>    [...]
>   but when I try to ping to a machine in my network, I get:

>    ping xxx.yyy.zzz.10
>    ed0: device timeout

>   Any sugestions anyone ?

Sounds like you misconfigured the interrups. With a generic kernel,
ed0 should be at irq 9 and ed2 at irq 10.

--
Manuel Bouyer, Ecole Nationale Superieure de Techniques Avancees, Paris

--

 
 
 

NetBSD and NE2000 compatible adaptors.

Post by Christoph Rim » Thu, 25 Apr 1996 04:00:00


Hello


>   I have installed NetBSD 1.1 in my PC, I have configured my
> network adapters with ifconfig, and everything OK:

>     ifconfig ed0 xxx.yyy.zzz.252
>     ifconfig ed2 xxx.yyy.zzz.253

>   but when I try to ping to a machine in my network, I get:

>     ping xxx.yyy.zzz.10
>     ed0: device timeout

>   Any sugestions anyone ?

Maybe a conflict for the router? Two interfaces on the same subnet may
not work; you have to split your part of the network into subnets and
tell your router and the interfaces an appropriate netmask.
Every network interface (ethernet card) has to reside on a different
network (subnet, ...).

-cr

--