netbsd1.2 amiga

netbsd1.2 amiga

Post by J Wuns » Fri, 17 Jan 1997 04:00:00




> I can't boot in multi-user, my spwd.db (sp) is 'not of the appropriate
> format'.

pwd_mkdb [-p] /etc/master.passwd

--
J"org Wunsch                                              Unix support engineer

 
 
 

netbsd1.2 amiga

Post by Fabien Wernl » Fri, 17 Jan 1997 04:00:00


Hi!

I can't boot in multi-user, my spwd.db (sp) is 'not of the appropriate
format'.

And vipw doesn't work :(

it says vi/ex not found or something.

 
 
 

netbsd1.2 amiga

Post by Michael Pars » Fri, 17 Jan 1997 04:00:00




Quote:>Hi!

>I can't boot in multi-user, my spwd.db (sp) is 'not of the appropriate
>format'.

>And vipw doesn't work :(

>it says vi/ex not found or something.

While in single-usermode:

# fsck -p

Never mount an unchecked partition.....

# mount -a -t nonfs

This will remount all of your local partitions (if you don't have any
nfs mounts in /etc/fstab, then you don't need the -t nonfs option).

Now you should be able to run vipw.

--
Michael Parson                     //        Illuminati Online  

 
 
 

netbsd1.2 amiga

Post by Bernd Ernest » Sat, 18 Jan 1997 04:00:00



Quote:>Hi!
>I can't boot in multi-user, my spwd.db (sp) is 'not of the appropriate
>format'.
>And vipw doesn't work :(
>it says vi/ex not found or something.

export TERM=vt220

and you need to mount /usr to get the termcap entriy for vt220.

Bernd

 
 
 

netbsd1.2 amiga

Post by Bruce Beck » Tue, 21 Jan 1997 04:00:00




|
|And vipw doesn't work :(
|
|it says vi/ex not found or something.

        It needs "EDITOR=vi" in the global shell environment

--
  ,u,    Bruce Becker           Toronto, Ontario        1 416 699 1868

 `\o\-e  "The wages of sin is depth"
 _< /_                                       - Lao Tse Tutu

 
 
 

1. NetBSD1.0A (amiga) gas & 68040

Being something of a masochist, I'm using gcc 2.6.3 (configured to generate 040-only code)
to compile my kernel and system (and now X11R6p11).  Unforutuately, the gas that comes w/
NetBSD does not properly support the 040 (some of the opcodes are wrong and some just
aren't there).  I have fixed most of the symptoms, but was wondering if anybody had gotten
binutils-2.5.2 to work or what to do w/ these fixes to get them incorporated into the
-current source tree.

(Come to think of it, I've hacked myself a EURO72-like screen mode and fixed some stuff
in newfs also... any takers?)

--

2. FAT32 problems

3. NetBSD1.1 Amiga install problem

4. Redhat backward compatibility

5. Cross-Compiler for m68k-{mac,amiga}-netbsd1.1a

6. Patch DNS server

7. amiga installation of netbsd1.1

8. Weird behaviour of bootpd ??

9. NetBSD1.2 on amiga

10. netbsd1.2 on amiga

11. Amiga NetBSD1.3.2 and MC68060/50 doesn't work!!??

12. Amiga announces Linux kernel is new Amiga kernal - Opinions?

13. NetBSD1.1 - need HELP with 4 problems