LX164 serial performance degradation

LX164 serial performance degradation

Post by Roger Betha » Wed, 31 Mar 1999 04:00:00



Help!

I recently upgraded my home system from a Linux/Intel platform to a
Linux/Alpha platform.  Everything works great except for the serial port
with which I dial in (ppp).  I'm seeing a 3x performance degradation in my
ftp transfers, and displaying back to my system from a remote compute server
is excruciatingly slow (unusable).  The Linux/Alpha system is running stock
RedHat 5.2 (kernel 2.0.35).  I've checked all the FAQs and docs that I can find,
and I see no reference to this problem.  I've contacted both Microway and
Redhat but have not come up with a resolution.  Any hackers out there
who recognize this failure pattern?

Thanks in advance,
Roger Bethard

Here's a comparison of the two systems:

OS              Linux/Intel 2.0.27              Linux/Alpha 2.0.35 (RH 5.2)
HW              66 MHz i486 DX/4                533 MHz EV56 EB164/LX164
MEMORY          28 MB                           288 MB
DISK             1 GB                            25 GB
BOGOMIPS        37.4 :-(                        530.6 :-)

ttyS0 speed     57600 crtscts                   57600 crtscts
CONNECT         24000 (LAPM)                    24000 (LAPM)
COMPRESSION     none                            none
ftp  7kb file   2.5 kb/sec                      0.8 kb/sec              
ftp 24kb file   2.6 kb/sec                      0.9 kb/sec              
ping pppserver  200 ms (min)                    350 ms (min)
                210 ms (avg)                    375 ms (avg)

 
 
 

LX164 serial performance degradation

Post by Matt Grossma » Wed, 31 Mar 1999 04:00:00



> Help!

> I recently upgraded my home system from a Linux/Intel platform to a
> Linux/Alpha platform.  Everything works great except for the serial
> port with which I dial in (ppp).  I'm seeing a 3x performance
> degradation in my ftp transfers, and displaying back to my system
> from a remote compute server is excruciatingly slow (unusable).  The
> Linux/Alpha system is running stock RedHat 5.2 (kernel 2.0.35).
> I've checked all the FAQs and docs that I can find, and I see no
> reference to this problem.  I've contacted both Microway and Redhat
> but have not come up with a resolution.  Any hackers out there who
> recognize this failure pattern?

Just a thought, but did you "setserial /dev/cua<whatever> spd_vhi"?
My LX, at least, doesn't have this set by default.  IIRC it is
necessary to achieve good serial performance.

Quote:> OS         Linux/Intel 2.0.27              Linux/Alpha 2.0.35 (RH 5.2)
> HW         66 MHz i486 DX/4                533 MHz EV56 EB164/LX164
> MEMORY             28 MB                           288 MB
> DISK                1 GB                            25 GB
> BOGOMIPS   37.4 :-(                        530.6 :-)

> ttyS0 speed        57600 crtscts                   57600 crtscts

This should by 115200, I think.

Matt Grossman

http://www.oz.net/~mattg

 
 
 

LX164 serial performance degradation

Post by Roger Betha » Thu, 01 Apr 1999 04:00:00


: Just a thought, but did you "setserial /dev/cua<whatever> spd_vhi"?
: My LX, at least, doesn't have this set by default.  IIRC it is
: necessary to achieve good serial performance.

Yup, that did the trick (thanks to Michal Jaegermann for his input yesterday).
I read the setserial man page and blew it off because I wasn't looking to
"lower" my baud rate to 33K.

I've been noticing more postings re: ppp connections that disconnect
immediately.  I suffered through that problem too (using RH5.2 stock pppd)
until I crammed an "at&d0" into my modem init string to ignore DTR.

Roger

 
 
 

1. Performance degradation after enabling routed daemon?

Hello, can anyone offer valid numbers regarding the performance hit if we
configure our H50 as a router? We currently have 3 NIC's with 3 different
networks, building a routed ntwk end eventually only keeping one active NIC.
During this transition period, we thought about using the H50 to route
traffic between two networks. We have heard that "You don't want to bog down
your H50 doing routing" and we would like to what to expect.
Thanks for any assistance.

- peter steele

2. RedHat Install Catch-22! Still no success :-{

3. degradation of 2d performance

4. netatalk net not in net-range???

5. IDE performance degradation on -ac tree

6. Unable to SSH or ping

7. ppp performance degradation?

8. Keyboard on Compaq doesn't work

9. performance degradation in large directories

10. SYSTEM ACTIVITY REPORT suggests performance degradation

11. performance degradation from 2.4.17 to 2.4.21-pre5aa2

12. performance degradation in large directories

13. Performance degradation with many msem_* in mmap'd memory