HELP with MILO for XL 300 ?

HELP with MILO for XL 300 ?

Post by int_8 » Fri, 21 Feb 2003 01:04:21



I have an alpha xl 300 on which I am trying to install linux.  I have
tried MILO built from the 2.2.18 kernel, 2.2.17 kernel, and the
2.0.XXc7 kernel.

The 2.2.X versions lock up after printing a message similar to
"Swapping PALcode at 0xB0000". Then the machine hangs.

The 2.0.x version does boot MILO.  The problem with that is at the
MILO prompt I type "boot fd0:" and get "boot: " then type "linux" I
get all kinds of ext2 CRC read errors.  Then it asks me to press any
key to reboot.

I have tried creating the floppy images from different drives and have
swapped the drive on the alpha machine.  None of which worked.

The box does not have a cdrom drive in it so I was trying to boot the
generic floppy, then the ramdisk floppy, then the network floppy.

I read somewhere that the reason the 2.2.X versions of MILO hang is
due to the video card.  It is a Matrox card.  I'm not sure about the
specific version.  I could find out if someone needed to know.

Thank you for taking the time to read this posting.  Any help would be
MUCH appreciated.

int

 
 
 

HELP with MILO for XL 300 ?

Post by Harm Damsm » Fri, 21 Feb 2003 03:54:19


Hi,


Quote:> I have an alpha xl 300 on which I am trying to install linux.  I have
> tried MILO built from the 2.2.18 kernel, 2.2.17 kernel, and the
> 2.0.XXc7 kernel.

> The 2.2.X versions lock up after printing a message similar to
> "Swapping PALcode at 0xB0000". Then the machine hangs.

> The 2.0.x version does boot MILO.  The problem with that is at the
> MILO prompt I type "boot fd0:" and get "boot: " then type "linux" I
> get all kinds of ext2 CRC read errors.  Then it asks me to press any
> key to reboot.

> I have tried creating the floppy images from different drives and have
> swapped the drive on the alpha machine.  None of which worked.

> The box does not have a cdrom drive in it so I was trying to boot the
> generic floppy, then the ramdisk floppy, then the network floppy.

> I read somewhere that the reason the 2.2.X versions of MILO hang is
> due to the video card.  It is a Matrox card.  I'm not sure about the
> specific version.  I could find out if someone needed to know.

> Thank you for taking the time to read this posting.  Any help would be
> MUCH appreciated.

> int

take the milo_xlt.bin from
http://www.xs4all.nl/~hhfragma/Loads/debian%20alpha
it works on my XLT-300 box.

have install floppies ready:

milo> boot fd0:exactnameofyourkernelfile root=/dev/fd0 load_ramdisk=1

Debian where: exactnameofyourkernelfile = linux.gz on install-floppy
Redhat probably something as "vmlinuz..."

-H

 
 
 

HELP with MILO for XL 300 ?

Post by int_80 » Fri, 21 Feb 2003 07:58:24




> Hi,



>> I have an alpha xl 300 on which I am trying to install linux.  I have
>> tried MILO built from the 2.2.18 kernel, 2.2.17 kernel, and the
>> 2.0.XXc7 kernel.

>> The 2.2.X versions lock up after printing a message similar to
>> "Swapping PALcode at 0xB0000". Then the machine hangs.

>> The 2.0.x version does boot MILO.  The problem with that is at the
>> MILO prompt I type "boot fd0:" and get "boot: " then type "linux" I
>> get all kinds of ext2 CRC read errors.  Then it asks me to press any
>> key to reboot.

>> I have tried creating the floppy images from different drives and have
>> swapped the drive on the alpha machine.  None of which worked.

>> The box does not have a cdrom drive in it so I was trying to boot the
>> generic floppy, then the ramdisk floppy, then the network floppy.

>> I read somewhere that the reason the 2.2.X versions of MILO hang is
>> due to the video card.  It is a Matrox card.  I'm not sure about the
>> specific version.  I could find out if someone needed to know.

>> Thank you for taking the time to read this posting.  Any help would be
>> MUCH appreciated.

>> int

> take the milo_xlt.bin from
> http://www.xs4all.nl/~hhfragma/Loads/debian%20alpha
> it works on my XLT-300 box.

> have install floppies ready:

> milo> boot fd0:exactnameofyourkernelfile root=/dev/fd0 load_ramdisk=1

> Debian where: exactnameofyourkernelfile = linux.gz on install-floppy
> Redhat probably something as "vmlinuz..."

> -H

Tried that and here is what I got:
booted MILO fine.  I typed "boot fd0:vmlinux.gz root=/dev/fd0
load_ramdisk=1"

Output:
a bunch of '#'s then
"floppy0: data CRC error: track 16, head 1, sector 8, size 2
end request: I/O error, dev 02:00 (floppy), sector 601
block_read: read failed (after 0 bytes)
ext2_bread: read error"

This is pretty much the same thing I was getting with the 2.0.X version
of MILO.  I used the generic.img images from the RH 7.1 (Seawolf) and
Compaq's Redhat 7.2 version.

int

 
 
 

HELP with MILO for XL 300 ?

Post by int_80 » Fri, 21 Feb 2003 13:22:00


It was the floppy disk.  It never occured to me to try another floppy
because I had formatted it several times and ran checkdisk on it several
times too.  I changed to another floppy and I can get to the installation
process now.
I like that version of MILO a lot.  It is very verbose.
Thanks for all your help.



> Hi,



>> I have an alpha xl 300 on which I am trying to install linux.  I have
>> tried MILO built from the 2.2.18 kernel, 2.2.17 kernel, and the
>> 2.0.XXc7 kernel.

>> The 2.2.X versions lock up after printing a message similar to
>> "Swapping PALcode at 0xB0000". Then the machine hangs.

>> The 2.0.x version does boot MILO.  The problem with that is at the
>> MILO prompt I type "boot fd0:" and get "boot: " then type "linux" I
>> get all kinds of ext2 CRC read errors.  Then it asks me to press any
>> key to reboot.

>> I have tried creating the floppy images from different drives and have
>> swapped the drive on the alpha machine.  None of which worked.

>> The box does not have a cdrom drive in it so I was trying to boot the
>> generic floppy, then the ramdisk floppy, then the network floppy.

>> I read somewhere that the reason the 2.2.X versions of MILO hang is
>> due to the video card.  It is a Matrox card.  I'm not sure about the
>> specific version.  I could find out if someone needed to know.

>> Thank you for taking the time to read this posting.  Any help would be
>> MUCH appreciated.

>> int

> take the milo_xlt.bin from
> http://www.xs4all.nl/~hhfragma/Loads/debian%20alpha
> it works on my XLT-300 box.

> have install floppies ready:

> milo> boot fd0:exactnameofyourkernelfile root=/dev/fd0 load_ramdisk=1

> Debian where: exactnameofyourkernelfile = linux.gz on install-floppy
> Redhat probably something as "vmlinuz..."

> -H

 
 
 

1. boot error with MILO on Alpha XL-300

I have an Alpha XL-300, with 3 non formated hard disk (sda, sdb & sdc)
and 1 CD-ROM (sr0).

I create a milo disk with a blank FAT floppy.  I copy on it linload.exe
and a copy of milo for XL-300.  I can start milo.  But when I try to
boot linux with my CD (RedHat 6.1 for Alpha), I receive an error.

My command:

boot -t iso9660 sr0:kernels/generic.gz root=/dev/sr0
After linux found cd-rom, it start to read generic.gz an it said:
        ##This is not a zip file.##################
It print a lot of ## on screen (more than 20 lines) and at the end:
        #Bad filehdr magic number 0x5f74 should be 0x183
        MILO: Failed to load the kernel

I try with /milo/images/xlt.gz file:
boot -t iso9660 sr0:milo/images/xlt.gz root=/dev/sr0
but it do same think.

If I try

boot fd0:vmlinux.gz root=/dev/fd0

with generic.img floppy into floppy drive, linux start to load,
decompressed vmlinux.gz and ask to insert a root floppy ?

What is the root floppy and where can I find it (on CD or on net) ?

What's wrong with my iso9660 cd boot ?

Thank at advance for your help

--
" L'intuition, c'est l'intelligence qui commet un excs de vitesse."

 H. Bernstein

http://www.christophe.courtois.org (Citations, lois de Murphy...)
____________________________________________________________________
Carl Provencher
Programmeur/Analyste
Service d'Informatique et
des Tlcommunications
Pavillon Casault
Cit Universitaire
Sainte-Foy, (Sainte-Foy)
Tl.: (418) 656-2131 poste: 8719
Fax.: (418) 656-7305

2. How to log bytes sent over TCP port?

3. Help! RH5.1 on Alpha XL 300

4. Help: Microsoft VPN (PPTP) thru NATD

5. HELP! RH5.1 on Alpha XL 300 Install

6. Disable proportional mouse movement in Red Hat 7.2?

7. Help! XL 300 and SuSE 6.3

8. swap -s output not match with config.

9. HELP! RH5.1 on Alpha XL 300 installation

10. XLT 300+IDE+milo = 8-(

11. Milo and AlphaServer 300

12. super dec alpha xl 300

13. Alpha XL 300