Debian 3.0r1 on Digital Server 5305

Debian 3.0r1 on Digital Server 5305

Post by A » Sat, 05 Jul 2003 02:22:08



I want to install Debian Linux 3.0r1 on a Digital Server 5305 with a
Symbios C810 SCSI adapter.  I don't know which method to install
Linux.  I've read the documentation (Alpha how-to and also the Milo
how-to).  Not sure if I need to use milo...looks like I can't b/c
there isn't a milo image for RAWHIDE (which is what Linux h/w this is
considered).  I tried booting from the CD-ROM using the AlphaBIOS and
entering in the boot path, but had no luck in doing that.  I read
something about maybe using the SRM console...not sure what it is and
how to use it to start the install procedure though.  I've installed
Linux before, but it was on x86 WINTEL machines...a bit more
simplified.

Thanks in advance,

AJ

 
 
 

Debian 3.0r1 on Digital Server 5305

Post by Rob Thysse » Sat, 05 Jul 2003 18:11:45



> I want to install Debian Linux 3.0r1 on a Digital Server 5305 with a
> Symbios C810 SCSI adapter.  I don't know which method to install
> Linux.  I've read the documentation (Alpha how-to and also the Milo
> how-to).  Not sure if I need to use milo...looks like I can't b/c
> there isn't a milo image for RAWHIDE (which is what Linux h/w this is
> considered).  I tried booting from the CD-ROM using the AlphaBIOS and
> entering in the boot path, but had no luck in doing that.  I read
> something about maybe using the SRM console...not sure what it is and
> how to use it to start the install procedure though.  I've installed
> Linux before, but it was on x86 WINTEL machines...a bit more
> simplified.

Debian Alpha runs very nicely on the digital server 5305. My setup is:
Two processors, one 500MHz and one 433MHz, 2GB RAM
Seven SCSI on the same Symbios SCSI card
Millenium II Graphics Card
Debian "Testing" with KDM and KDE 3.1.2 from "unstable"

First of all, if your machine boots into AlphaBios you'll need to change it
to SRM. There's a setting under the advanced options (from memory I think
it involves pushing F2 or F6 from the AlphaBios Menu, it should say along
the bottom of the screen). Save settings and reboot. SRM boots into a blue
screen. Typing "sh dev" at the SRM prompt will tell you the names of all
your drives. Pop Debian Woody CD1 into the drive and type "boot DKA500" if
your cdrom drive shows up as DKA500 (If its a SCSI drive it'll probably be
DKA0, DKA400 or DKA500). The machine will restart and boot the debian
installer.

When fdisk runs to partition the drives, make sure that you use the bsd
disklabel option. I think the installer puts fdisk in this mode by default
but if it doesn't, press 'b' to do it manually. There needs to be a c:
partition which occupies the entire disk but contains no filesystem use a:
b: d: etc.. as you like.

I generally decline to install anything with the woody package manager and
dselect because as soon as I can bootstrap the system under debian i edit
sources.list and run "apt-get dist-upgrade" which gets its packages from
testing rather than the woody cd. But that's a matter of preference.

Anyway, there's enough there to get you started I should think. Let me know
if you run into any snags.

/rob

 
 
 

1. debian 4.0r1, netatalk, pam

Hello,

I've set up a small file server using debian 4.0r1, so far it served
only via smb. Now in addition the Macs shall be served via afp instead
of smb, so I installed netatalk. The users shall simply mount their home
directories.

Well, but if they try to with Mac OS X 10.4, then auth.log shows a 'pam
authentification error'.

Anything special I need to do, similar to smbpasswd for cifs?

Thanks,
Michael

2. CD-ROM Problems

3. Orinoco 8460 802.11A/B combocard with Debian 3.0R1

4. Linux Equivalent Of lpstat?

5. Debian 3.0r1 with Xircom 10/100 + modem card

6. Adding a 3Com NIC to Solaris 9 x86 9/04

7. problem with webmin sendmail M4 module on debian 3.0r1

8. XFree86 not starting

9. problems with digital de500 e'net card on digital server ...

10. Digital Cameras & Debian Linux

11. COMMERCIAL: APE Integrated Development Environment 2.0R1 Now available

12. Digital LCD monitor and digital video card

13. Hoontech Digital (YMF754)'s AC3 on SPDIF: amplifier says "Unknown Digital"