3.0 patch 019 - doesn't compile

3.0 patch 019 - doesn't compile

Post by Rainer Duffn » Thu, 25 Apr 2002 18:59:30



Hi,

I can't get the 019-patch compiled.
This is the end-result:

cc -O2   -DKRB4 -I/usr/include/kerberosIV -DAFS -DKRB5
-I/usr/include/kerberosV -I/usr/src/usr.bin/ssh/lib/..   -c
/usr/src/usr.bin/ssh/lib/../packet.c -o packet.o
/usr/src/usr.bin/ssh/lib/../packet.c: In function `packet_get_bignum':
/usr/src/usr.bin/ssh/lib/../packet.c:990: void value not ignored as it
ought to be
/usr/src/usr.bin/ssh/lib/../packet.c: In function
`packet_get_bignum2':
/usr/src/usr.bin/ssh/lib/../packet.c:996: void value not ignored as it
ought to be

Any ideas ?

cheers,
Rainer

 
 
 

3.0 patch 019 - doesn't compile

Post by Gilbert Fernand » Fri, 26 Apr 2002 00:59:29


Quote:> I can't get the 019-patch compiled.

What did you type, from where (pwd) to get that patch
applied ?

 
 
 

3.0 patch 019 - doesn't compile

Post by Ted » Fri, 26 Apr 2002 01:53:23



Quote:> Hi,

> I can't get the 019-patch compiled.
> This is the end-result:

The patch only applies against OpenSSH version 3.1, not 3.0.2.  Use cvs to
download the latest version of the ssh directory.  Had the same problem.

--
If you ever would give them a helping hand,
You can be sure they'll chop off the arm.
Never, ever, never trust a Klingon; you will always regret it.

 
 
 

3.0 patch 019 - doesn't compile

Post by Rainer Duffn » Fri, 26 Apr 2002 20:32:04




> > Hi,

> > I can't get the 019-patch compiled.
> > This is the end-result:

> The patch only applies against OpenSSH version 3.1, not 3.0.2.  Use cvs to
> download the latest version of the ssh directory.  Had the same problem.

Thanks a lot.
Unfortunately, I don't have CVS access at work (yet).
I'll do it at home.

cheers,
Rainer

 
 
 

3.0 patch 019 - doesn't compile

Post by nobod » Fri, 26 Apr 2002 22:36:45


Interestingly, I applied the equivalent OBSD 2.9 patch (patch 24)
against my (updated) OSSH3.1 installation, and one of the hunks was
rejected.  At the time I just figured the patch was designed to cover an
older version of OSSH, but now ...  Anyone know what is up?



> > > Hi,

> > > I can't get the 019-patch compiled.
> > > This is the end-result:

> > The patch only applies against OpenSSH version 3.1, not 3.0.2.  Use cvs to
> > download the latest version of the ssh directory.  Had the same problem.

> Thanks a lot.
> Unfortunately, I don't have CVS access at work (yet).
> I'll do it at home.

> cheers,
> Rainer

 
 
 

1. S-Ware 3.0, compiling kernel 1.2.xx or 1.3.xx doesn't happen

I just purchased the Slackware 3.0 with ELF.  I installed most of the packages
on the disk including gcc(2.6.3) and g++.  

If copy an 1.2.xx kernel from the kernel disk and setup the /usr/include links  
and try to compile the kernel I get many undefined references.  So I make the
changes to /linux/arch/i386/Makefile as the README says to do.  Now if I try
to 'MAKE DEP' I get a:
        gcc installation error: cannot exec cpp
OK, so I set /usr/bin/cpp -> g++
        Now it completes the depend part with many warnings about not using
the link file as linking was not performed.  However when I try to compile it
says that it cannot execute cc1 and bombs out very soon.

If I try to compile a 1.3.xx kernel I just get a bunch of undefined refernce
error and it fails to compile.  What am I doing wrong?  I have looked at sever
README files and it looks like I did everything right.

Thanks in advance.

Wayne P Cuddy
Q.E.D. Systems Inc.

2. softupdate

3. REPOST patch 19/38: CLIENT: lease time in 'struct nfs_fsinfo'

4. burning cd's - does it work - reliably ?

5. [PATCH 2.5-ac] Doesn't boot when compile for i386, i486

6. Processor specific build

7. Vector Patch module doesn't compile for 1.3.42

8. Inode problem?

9. : Emacs-19.19 can't find term file

10. nice 19 doesn't slow down jobs

11. Help can't compile InterViews with gcc patches and Linux patches

12. Compiling emacs-19.34 and xcd won't see X

13. Can't compile emacs-19.34b (gcc2.7.2.1 and libc5.4.17)