How to build ...

How to build ...

Post by Nospa » Mon, 14 Feb 2000 04:00:00



I've read the notes in /usr/src/Makefile, looked through the FAQ, and
scanned dejanews to no avail, so perhaps someone can explictly spell
this out once and for all -- it can't be an uncommon problem.  I want to
update by building and installing from the current source code for one
architecture only (i386). (Not because I'm *ic, I need the ipf
ftp-proxy working, and an install of snapshot yields some complaints on
start-up which, for all I know, may already be fixed).  I didn't get any
further than "make obj" before my attempt at building from source failed
(on the Amiga src, which I don't even need).  A step by step, "Building
for Dummies" guide would be really useful.  Thanks!
 
 
 

How to build ...

Post by Marc Esp » Mon, 14 Feb 2000 04:00:00


Give us a real email address, and maybe you'll get some answer.
--
        Marc Espie              
|anime, sf, juggling, unicycle, acrobatics, comics...
|AmigaOS, OpenBSD, C++, perl, Icon, PostScript...
| `real programmers don't die, they just get out of beta'

 
 
 

1. gcc 4.1.1 build under Intel Solaris 10 does not build gcc

This is strange. gcc compiled fine (i did it yesterday on Sparc, and
today on Intel).

While a call to "g++ -v" tells me that 4.1.1 is invoked (using the
standard prefix /usr/local/bin)
the "gcc" executable is not installed. It is still the 3.3 that i
installed as a package from sunfreeware.com

Any ideas where i can find the gcc ?

I did a simple "configure ; make ; make install" without any parameters.

2. New or Revised TAs on websco, 970212

3. can i build a mail server that can build class based groups?

4. important announce

5. TK8.0 won't build, so I can't build xcdroast(0.96e)

6. how do I set the environment for ksh for root?

7. problems building cross-compiler host/build in linux for target i686-pc-msdosdjgpp (long)

8. ARCServe support

9. build error, drivers/built-in.o

10. InterViews build problem/IBUILD built anywhere?

11. building 2.8 on a 3000 and using the OS build a 4000

12. link compat=4 built library with a compat=5 build code

13. Can a program which is built by Workshop 4.2 use a dynamic library build by Workshop 6.1?