OpenBSD 3.2 / OpenSSL 0.9.7a compiling fails

OpenBSD 3.2 / OpenSSL 0.9.7a compiling fails

Post by Martij » Fri, 11 Apr 2003 19:49:28



Compiling this OpenSSL version on OpenBSD 3.2 fails
There is a patch released to solve this problem:

http://www.openssl.org/support/faq.html#BUILD12

But there's no info on how to apply this patch.
Anybody got any idea?

En what about this line:

"OpenBSD is equipped with an out-of-date GNU assembler which finds the new
code offensive."

Is there any info on how to update the current assembler version i.o. using
the patch?

I hope these problems will be fixed in 3.3

Thanks in advance,

Martijn.

 
 
 

1. compiling ssh-2.0.9 with tcp_wrapper support fails??

I'm having difficulty in getting ssh to compile with tcp_wrapper
support, using libwrap.
Am I making mistakes in my syntax?
I don't know where to go next after I get the following errors running
make.
my configure command is:

configure --with-libwrap=/usr/local/lib/libwrap.a

followed up with a simple make . . .
and this is the output I get when the make fails:

ISAKMP_CFG_MODE -DSSHDIST_CRYPT_DH -g -Wall -I/usr/openwin/include -c
sshchtcpfwd.c
sshchtcpfwd.c: In function `ssh_channel_ftcp_incoming_connection':
sshchtcpfwd.c:428: storage size of `req' isn't known
sshchtcpfwd.c:434: warning: implicit declaration of function
`getservbyport'
sshchtcpfwd.c:434: warning: assignment makes pointer from integer
without a cast
sshchtcpfwd.c:444: dereferencing pointer to incomplete type
sshchtcpfwd.c:447: warning: implicit declaration of function
`request_init'
sshchtcpfwd.c:447: `RQ_DAEMON' undeclared (first use in this function)
sshchtcpfwd.c:447: (Each undeclared identifier is reported only once
sshchtcpfwd.c:447: for each function it appears in.)
sshchtcpfwd.c:448: `RQ_FILE' undeclared (first use in this function)
sshchtcpfwd.c:448: warning: implicit declaration of function
`ssh_stream_fd_get_readfd'
sshchtcpfwd.c:449: warning: implicit declaration of function `fromhost'
sshchtcpfwd.c:450: warning: implicit declaration of function
`hosts_access'
sshchtcpfwd.c:454: warning: implicit declaration of function
`eval_client'
sshchtcpfwd.c:428: warning: unused variable `req'
sshchtcpfwd.c: In function `ssh_channel_dtcp_incoming_connection':
sshchtcpfwd.c:696: storage size of `req' isn't known
sshchtcpfwd.c:702: warning: assignment makes pointer from integer
without a cast
sshchtcpfwd.c:712: dereferencing pointer to incomplete type
sshchtcpfwd.c:715: `RQ_DAEMON' undeclared (first use in this function)
sshchtcpfwd.c:716: `RQ_FILE' undeclared (first use in this function)
sshchtcpfwd.c:696: warning: unused variable `req'
make[3]: *** [sshchtcpfwd.o] Error 1
make[3]: Leaving directory
`/export/share/src/sshWrap/ssh-2.0.9/apps/ssh'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/export/share/src/sshWrap/ssh-2.0.9/apps'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export/share/src/sshWrap/ssh-2.0.9'
make: *** [all-recursive-am] Error 2
[/export/share/src/sshWrap/ssh-2.0.9] {112}

I haven't seen any other things I need to do in the Makefile,
Has anyone else run into this, and know how to get beyond it?

thank-you for your help in advance,
demian

2. ftape problems

3. OpenSSL version 0.9.6c released

4. klogd is a mystery!

5. Problem with: Apache/2.0.36 (Unix) mod_ssl/2.0.36 OpenSSL/0.9.6d

6. xdm and chooser

7. mod_ssl/2.8.8 OpenSSL/0.9.6b version increments

8. Sunsite Mirror?

9. Apache 2.0.42 with openssl 0.9.6g

10. Updating OpenSSL to 0.9.6g

11. Apache 1.3.12, mod_ssl 2.6.2, OpenSSL 0.9.5a

12. sparc, apache 1.3.23, modssl 2.8.6, openssl 0.9.6c

13. OpenSSL 0.9.6a NetBSD 1.4.2