Boot problems after install to scsi drive on aha1542 adaptor

Boot problems after install to scsi drive on aha1542 adaptor

Post by Dave Edward » Fri, 08 Dec 2000 20:45:05



Hi,

Anyone help with this?

It must be a simple fix but I just can't sus it out.  No help in the howto
unfortunately.

I've got IDE drives that run other OS's and I've installed redhat 7 to a
scsi
disk on an aha1542C connected scsi disk.

The install went fine but I can't boot the system either from the boot
floppy or the drive.  The kernel can't mount the root file system.  LILO
install to the drive seems to have failed too (stops at LI) but that's for
another day.  I just want to boot the *y system.

I'm sure it's because the aha1542 module needs to be loaded but I can't use
mkinitrd to make a ram disk image cos I can't boot the system.

I can boot from the CD and insmod the driver, mount the partitions and play
around but mkinitrd seems to insist on seeing /lib/modules/2.2.16.22/
directory
for the modules and the install images don't have that dir there.

I'm at a loss and can't work out why the install went so well (after insmod
in
expert mode) but it didn't seem to realise that that module was
essential for the drive to boot properly.

Help :-)

ciao
dave

 
 
 

1. Linux install with 2 scsi adaptors - aha1542 + aha2940uw

Hi there,
I've got problems installing Redhat 4.0 with both scsi adapters in
place.
A bit of history first:
I previously had Redhat 4.0 installed and running with a aha1542cp
installed.  Off that adaptor I?had two scsi harddisks, a cdrom and 4mm
backup drive.
And now the problem:
Now I've upgraded with a aha2940 and decided to have the cdrom and tape
drive running off the 1542 and my hardisks running off the 2940uw.  I've
also got win95, winnt and os/2 up and running so there are no hardware
conflicts.  The problem is installing linux.
During boot up with the boot image disk, where it asks what my
installation media is ie. network, ftp ...or cdrom - I?enter local
cdrom.  The next question is - Atapi, scsi or other - I?enter scsi.
Right after this the machine reboots.  I've done this I?few times
without luck.
Any clues????

2. New to CD Burning...

3. RH5.0 and Adaptec AHA1542 SCSI adapter

4. Linux - > XP pro

5. Is it possible to boot from a SCSI drive if two IDE drives are installed?

6. IP-filter Solrais 8

7. SCSI Zip drive w/ Zip zoom scsi adapter problems...

8. Driver for Compaq Netelligent 10/100

9. RH 5.2 boot floppy install abort: timeout talking to scsi adapter???

10. Adding a SCSI controller changing boot drive to SCSI drive

11. Install red hat 6 in scsi aha1542

12. SCSI zip drive: need scsi-2 cable or adapter

13. Ultra2 SCSI drive on Wide Ultra SCSI adapter - help?