Cannot sync Clie to Evolution in Redhat 9

Cannot sync Clie to Evolution in Redhat 9

Post by Spar » Thu, 24 Apr 2003 02:08:22



I recently upgraded, by reinstalling, to RH9 and am happy with the
experience except that I've lost the ability to sync my Sony Clie Palm
OS device.  I can use pilot-link but not gnome-pilot and therefore not
Evolution.  Although I have gnome-pilot watching /dev/ttyUSB1 it seems
to ignore or not see when I press the hotsync button. I even tried
/dev/ttyUSB0 even though it worked on 1 before the upgrade.

I was using RH 7.3 before which I upgraded using red-carpet to use
Evolution.  I was able to hotsync my clie to Evolution when ximian
upgraded the pilot-link etc packages back in the fall of 2002.  This
was understandable because the version of pilot-link that RH 7.3 had
at the time did not support usb.  RH 9 comes with the correct version
of pilot-link and gnome-link so I assumed that it would work.  Well
no.  Nor does RH9 come with the conduits package that has the
evolution conduits.

I get the following in the messages log file when I press the hotsync
button.

Apr 21 17:42:12 Wintermute kernel: usbserial.c: Handspring Visor /
Palm 4.0 / Cli4.x converter detected
Apr 21 17:42:12 Wintermute kernel: visor.c: Handspring Visor / Palm
4.0 / Cli4.x: Number of ports: 2
Apr 21 17:42:12 Wintermute kernel: visor.c: Handspring Visor / Palm
4.0 / Cli4.x: port 1, is for Generic use and is bound to ttyUSB0
Apr 21 17:42:12 Wintermute kernel: visor.c: Handspring Visor / Palm
4.0 / Cli4.x: port 2, is for HotSync use and is bound to ttyUSB1
Apr 21 17:42:12 Wintermute kernel: usb-uhci.c: interrupt, status 2,
frame# 150
Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
0, urb c0f13700, burb c0f13b00
Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
descriptor 0 (error=-6)
Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
0, urb c0f13700, burb c0f13b00
Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
descriptor 0 (error=-6)
Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
0, urb c0f13700, burb c0f13b00
Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
descriptor 0 (error=-6)
Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
0, urb c0f13700, burb c0f13b00
Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
descriptor 0 (error=-6)
Apr 21 17:42:15 Wintermute kernel: usb_control/bulk_msg: timeout
Apr 21 17:42:15 Wintermute kernel: visor.c: visor_startup - error
getting first unknown palm command
Apr 21 17:42:18 Wintermute kernel: usb_control/bulk_msg: timeout
Apr 21 17:42:18 Wintermute kernel: visor.c: visor_startup - error
getting second unknown palm command
Apr 21 17:42:18 Wintermute kernel: usbserial.c: Handspring Visor /
Palm 4.0 / Cli4.x converter now attached to ttyUSB0 (or usb/tts/0
for devfs)
Apr 21 17:42:18 Wintermute kernel: usbserial.c: Handspring Visor /
Palm 4.0 / Cli4.x converter now attached to ttyUSB1 (or usb/tts/1
for devfs)
Apr 21 17:42:21 Wintermute /etc/hotplug/usb.agent: Setup visor for USB
product 54c/66/100
Apr 21 17:42:22 Wintermute devlabel: devlabel service
started/restarted
Apr 21 17:43:12 Wintermute kernel: usb.c: USB disconnect on device
00:07.2-1 address 3
Apr 21 17:43:12 Wintermute kernel: usbserial.c: Handspring Visor /
Palm 4.0 / Cli4.x converter now disconnected from ttyUSB0
Apr 21 17:43:12 Wintermute kernel: usbserial.c: Handspring Visor /
Palm 4.0 / Cli4.x converter now disconnected from ttyUSB1
Apr 21 17:43:14 Wintermute devlabel: devlabel service
started/restarted

Has anyone successfully sync'd (sunk?) a usb pda with gnome-pilot and
RH9 yet?  How about evolution?

Thanks!
David

 
 
 

Cannot sync Clie to Evolution in Redhat 9

Post by Spar » Wed, 30 Apr 2003 16:31:05


Looks to be a kernel bug. https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=85281

> I recently upgraded, by reinstalling, to RH9 and am happy with the
> experience except that I've lost the ability to sync my Sony Clie Palm
> OS device.  I can use pilot-link but not gnome-pilot and therefore not
> Evolution.  Although I have gnome-pilot watching /dev/ttyUSB1 it seems
> to ignore or not see when I press the hotsync button. I even tried
> /dev/ttyUSB0 even though it worked on 1 before the upgrade.

> I was using RH 7.3 before which I upgraded using red-carpet to use
> Evolution.  I was able to hotsync my clie to Evolution when ximian
> upgraded the pilot-link etc packages back in the fall of 2002.  This
> was understandable because the version of pilot-link that RH 7.3 had
> at the time did not support usb.  RH 9 comes with the correct version
> of pilot-link and gnome-link so I assumed that it would work.  Well
> no.  Nor does RH9 come with the conduits package that has the
> evolution conduits.

> I get the following in the messages log file when I press the hotsync
> button.

> Apr 21 17:42:12 Wintermute kernel: usbserial.c: Handspring Visor /
> Palm 4.0 / Cli4.x converter detected
> Apr 21 17:42:12 Wintermute kernel: visor.c: Handspring Visor / Palm
> 4.0 / Cli4.x: Number of ports: 2
> Apr 21 17:42:12 Wintermute kernel: visor.c: Handspring Visor / Palm
> 4.0 / Cli4.x: port 1, is for Generic use and is bound to ttyUSB0
> Apr 21 17:42:12 Wintermute kernel: visor.c: Handspring Visor / Palm
> 4.0 / Cli4.x: port 2, is for HotSync use and is bound to ttyUSB1
> Apr 21 17:42:12 Wintermute kernel: usb-uhci.c: interrupt, status 2,
> frame# 150
> Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
> 0, urb c0f13700, burb c0f13b00
> Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
> descriptor 0 (error=-6)
> Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
> 0, urb c0f13700, burb c0f13b00
> Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
> descriptor 0 (error=-6)
> Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
> 0, urb c0f13700, burb c0f13b00
> Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
> descriptor 0 (error=-6)
> Apr 21 17:42:14 Wintermute kernel: usb-uhci.c: ENXIO 80000380, flags
> 0, urb c0f13700, burb c0f13b00
> Apr 21 17:42:14 Wintermute kernel: usb.c: error getting string
> descriptor 0 (error=-6)
> Apr 21 17:42:15 Wintermute kernel: usb_control/bulk_msg: timeout
> Apr 21 17:42:15 Wintermute kernel: visor.c: visor_startup - error
> getting first unknown palm command
> Apr 21 17:42:18 Wintermute kernel: usb_control/bulk_msg: timeout
> Apr 21 17:42:18 Wintermute kernel: visor.c: visor_startup - error
> getting second unknown palm command
> Apr 21 17:42:18 Wintermute kernel: usbserial.c: Handspring Visor /
> Palm 4.0 / Cli4.x converter now attached to ttyUSB0 (or usb/tts/0
> for devfs)
> Apr 21 17:42:18 Wintermute kernel: usbserial.c: Handspring Visor /
> Palm 4.0 / Cli4.x converter now attached to ttyUSB1 (or usb/tts/1
> for devfs)
> Apr 21 17:42:21 Wintermute /etc/hotplug/usb.agent: Setup visor for USB
> product 54c/66/100
> Apr 21 17:42:22 Wintermute devlabel: devlabel service
> started/restarted
> Apr 21 17:43:12 Wintermute kernel: usb.c: USB disconnect on device
> 00:07.2-1 address 3
> Apr 21 17:43:12 Wintermute kernel: usbserial.c: Handspring Visor /
> Palm 4.0 / Cli4.x converter now disconnected from ttyUSB0
> Apr 21 17:43:12 Wintermute kernel: usbserial.c: Handspring Visor /
> Palm 4.0 / Cli4.x converter now disconnected from ttyUSB1
> Apr 21 17:43:14 Wintermute devlabel: devlabel service
> started/restarted

> Has anyone successfully sync'd (sunk?) a usb pda with gnome-pilot and
> RH9 yet?  How about evolution?

> Thanks!
> David


 
 
 

1. clie won't sync in redhat 9

using red hat 8.0 i had no problems syncing my clie. updated to 9.0
and it will no longer sync. i've looked through dmesg and see these
messages:

usbserial.c: Handspring Visor / Palm 4.0 / Cli4.x converter now attached to tt
yUSB1 (or usb/tts/1 for devfs)
usb.c: USB disconnect on device 00:1f.2-1.3 address 15
usbserial.c: Handspring Visor / Palm 4.0 / Cli4.x converter now disconnected f
rom ttyUSB0
usbserial.c: Handspring Visor / Palm 4.0 / Cli4.x converter now disconnected f
rom ttyUSB1

can any tell me what is happening?

thank you very much.

2. I need compil a C file for SPARC and UltraSparc

3. Sony Clie USB sync problems

4. SPAM

5. Oops when syncing Sony Clie 760 with USB cradle

6. 2.4.18 down to 2.4.9 bind problem RTL8139

7. Seg fault when syncing Sony Clie 760 with USB cradle

8. Why SLIP Drop Out?

9. Handspring sync to Linux vs CLIE to Windoze -> Linux 1 Windoze 10

10. evolution: syncing contacts between machines

11. Palm sync issues with Evolution/Gnome?

12. Sync Problem with Evolution and Palm

13. Sync Evolution category