Failed to initialize the NVdriver kernel module...

Failed to initialize the NVdriver kernel module...

Post by Richar » Sun, 27 Oct 2002 06:31:53



Hi...
I try to run Red Hat 7.3 on satellite 5105-S607..

I got trouble with NVIDIA driver...
Error message is following

[EE]Failed to initialize the NVdriver kernel module...
[EE]*******Aborting***********

So, as intruction...
I downloaded NVIDIA_kernel tar file...and built by using the command:

make install SYSINCLUDE=/path/to/kernel/headers

It was going well, but...it's still not working...
Plus, when I typed modprobe, there was nothing...

I also had changed XF86Config-4 file like remove dri...change to nvidia and
so on...

I have struggled with x-windows for almost month!!!

I'm tired......T.T;

Any advice is appreciated.......

begin 666 smile.gif

M?.KCC/_[TO_\V?_YL?_YL/_XI^[GC]W6A/_[SOWUF/_YM?_WG?KREO_[RO_\
MW/_[Q__ZO<?!=^;?BO_ZN^CAB_;NE/OSEO_XI?3MD_;ND__ZPL*\=<K#><O%

MP)]0Z"L6A\A?,;-B8%Y'I"^3V24F+<\#XAOZ5HW&56-C\2R7KI(Q*Y8\E6+H


,:E[ S]!)QM0_00`[
`
end

 
 
 

Failed to initialize the NVdriver kernel module...

Post by Dick Kistle » Sun, 27 Oct 2002 08:29:09



Quote:> Hi...
> I try to run Red Hat 7.3 on satellite 5105-S607..

> I got trouble with NVIDIA driver...
> Error message is following

> [EE]Failed to initialize the NVdriver kernel module...
> [EE]*******Aborting***********

> So, as intruction...
> I downloaded NVIDIA_kernel tar file...and built by using the command:

> make install SYSINCLUDE=/path/to/kernel/headers

> It was going well, but...it's still not working...
> Plus, when I typed modprobe, there was nothing...

> I also had changed XF86Config-4 file like remove dri...change to nvidia
and
> so on...

> I have struggled with x-windows for almost month!!!

> I'm tired......T.T;

> Any advice is appreciated.......

Read the Readme file in the driver tar.gz. You have to put an entry in the
modules.conf to get the module you built to load. Was there any problem with
the compile, make and install? Did you also install the GLX stuff?

Dick Kistler

 
 
 

1. Pegasus driver fails to initialize when not a module

Chipsets: VIA KT133, VIA MVP4
Adapter: DLink DSB-650 (pegasus version, NOT the klsi one).
Drivers Used: usb-uhci -or- uhci, pegasus
Kernel Versions: 2.4.3, 2.4.6, 2.4.8, 2.4.8-ac2 (at least as far as I've tested).

Problem:
I've got a DLink DSB-650 USB net adapter based on the pegasus chipset. It
works fine when the driver is compiled as a module, but when the driver is
linked into the kernel, it fails to detect the adapter. The USB layer
initializes ok, and my USB keyboard and mouse are detected (although
doing this on a system with a PS/2 or AT kb/mouse changes nothing), but
the NIC is not, even though the pegasus driver prints out  it's loading
string and copyright message.

--ex--
pegasus.c: v0.4.19 2001/06/07 (C) 1999-2001:ADMtek AN986 Pegasus USB
Ethernet driver
usb.c: registered new driver pegasus
--ex--

After this, the kernel loads the net drivers, and (in my case) horks
because there is no eth0 to autoconfigure and mount a nfsroot filesystem
from.

However, on the same system with the same BIOS settings, and the only
change being that pagasus.c is compiled as a module (and not into the
kernel) it works perfectly, and I can use the USB adapter without trouble.

 This happens under either UHCI driver, and regardless of what USB options
are set. With debug on, I get a 'set_configuration_failed()' message from
pegasus under 'normal' uhci, and no notable error message under uhci-je.

My best guess is that either (a) something's wrong with the driver that
makes it not work when linked in, or (b) the driver is working, but is
dong it's initialization in the background, and is not
finishing in time to have eth0 ready for autoconfig/nfsroot (i.e. eth0
would appear some time after 'init' kicked off.

Any suggestions?

- Dave Acklam

P.S. Yes, I read the lkml faq, the kernel docs, the source for
pegasus.c/pegasus.h, et al... Please don't shoot the first-time poster...

If you need the kernel config, I'll be happy to e-mail it to you

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. What is lsof

3. Pegasus driver fails to initialize when not a module (re-post)

4. What is the MMU

5. PB G3 eth0 fails to initialize (module not loading?)...

6. IPX - stumped

7. e100 driver fails to initialize the hardware after kernel bootup through kexec

8. Sound Blaster 4x CDrom not working

9. NVdriver module not compiling on MDK 9.0 final

10. RedHat 7 NVdriver Module

11. Installing Nvidia Riva TNT2 - insmod NVdriver fails

12. NVdriver and kernel 2.4.0-test11

13. Kernel 2.4.0-test8 + XFree 4.01 + Geforce256 + NVdriver =probs?!