newbie:Updating Linux

newbie:Updating Linux

Post by Johann Thalhamm » Wed, 23 May 2001 06:28:39



Hi,

I currently got RedHat 6.1.
Trying to update some packages with rpm,I get the error:

Only packages with major number <= 3 are supported by this version of RPM.

Then I downloaded the source of rpm-4.0.2. But to buid it I need:

libtool-1.3.5, which itself needs rpm-4.

What can I do?

thanks

snoh

 
 
 

newbie:Updating Linux

Post by Gary Dal » Wed, 23 May 2001 07:09:32


You could try downloading the source for libtool as a tarball (.tar.gz)
and compiling it - probably just ./configure; make; make install.

> Hi,

> I currently got RedHat 6.1.
> Trying to update some packages with rpm,I get the error:

> Only packages with major number <= 3 are supported by this version of RPM.

> Then I downloaded the source of rpm-4.0.2. But to buid it I need:

> libtool-1.3.5, which itself needs rpm-4.

> What can I do?

> thanks

> snoh


 
 
 

newbie:Updating Linux

Post by Natma » Thu, 24 May 2001 08:42:01


Many times you can install 2 or more packages at once, and if they are
interdependant they will install.  For example:
rpm -hiv package1.rpm package2.rpm package3.rpm ...

Also, you can usually "force" a package to install by using:
rpm -hiv --nodeps --force package1.rpm
(but be careful, because you might damage some file, like RPM itself,
because RPM doesn't check anything).

Try it out.

Natman


Quote:> Hi,

> I currently got RedHat 6.1.
> Trying to update some packages with rpm,I get the error:

> Only packages with major number <= 3 are supported by this version of RPM.

> Then I downloaded the source of rpm-4.0.2. But to buid it I need:

> libtool-1.3.5, which itself needs rpm-4.

> What can I do?

> thanks

> snoh

 
 
 

1. Linux Newbie Web Site Updated

Hi,
I just finished updating my web site. The site has links and information
about Linux. I have designed the site to help newbies to Linux find
informationon the OS. I would greatly appreciate it if you just checked
it out and let me know what you think, I can use all of the input I can
get. Thanks to all of the people who comented on the site already. I
hope you like the new additions. The address is:
http://www.angelfire.com/sc/linux/lin.html
Thanks
Chris

2. Sol 7 x86: compaq 1850 question

3. Linux Newbie Web Site Updated!!!!!

4. Q:WordPerfect Install?

5. Linux security update - newbie questions

6. Linux installation help

7. WWW: Linux FAQ for newbies & wannabes UPDATED

8. ftp connection

9. Newbie Modem Driver Update Question

10. newbie :how to update environment PATH for all users

11. RH 8.0 - RHN - update agent - newbie

12. Newbie: question about for kernel update for PCI NE2000 Redhat4.2

13. Newbie: Kernel updates