xine installing - zlib problems on rh9

xine installing - zlib problems on rh9

Post by donkim » Mon, 30 Jun 2003 23:53:59



Hi,
I was already searching but couldn't find any solution for my prob:
I am using redHat 9 and I am trying to install the xine-lib-1-beta11.
Well, I untared the package and than I do the ./configure that ends up
with an error: zlib needed. Ok, so I check with the rpm -q zlib. It
tells me that zlib1.1.4-8 is installed. Hmm, I did read the INSTALL
and the README. There it says: "...you need (amongst other things) the
zlib compression library plus the appropriate headers, which are often
found in a package called zlib-devel or similar." So, I am checking
with the rpm -q zlib-devel. Nothing. Maybe I do not have the devel
package or it is called different (who knows?) I am trying to search
on redHat download for zlib-devel rpm's ...:nothing!
I've red in other postings, that I am not the only person with that
problem, and it seems to me that it has something to do with the
zlib-devel thing. But I didn't find any answer yet not even a package
called zlib-devel.... and what is the "appropriate header"?
so... please, help! thanx.
 
 
 

xine installing - zlib problems on rh9

Post by Matt N » Tue, 01 Jul 2003 03:26:55



> found in a package called zlib-devel or similar." So, I am checking
> with the rpm -q zlib-devel. Nothing. Maybe I do not have the devel
> package or it is called different (who knows?) I am trying to search
> on redHat download for zlib-devel rpm's ...:nothing!

Do you have your install CDs? If not, go to rpmfind.net and search for the
zlib-devel. As you've found out, you don't have them installed. If you
have your install CDs they'll probably be found on the 2nd or 3rd CD. Once
you've installed that package you should be able to compile xine, unless
you are missing other devel packages.

 
 
 

xine installing - zlib problems on rh9

Post by donkim » Tue, 01 Jul 2003 09:52:16




> > found in a package called zlib-devel or similar." So, I am checking
> > with the rpm -q zlib-devel. Nothing. Maybe I do not have the devel
> > package or it is called different (who knows?) I am trying to search
> > on redHat download for zlib-devel rpm's ...:nothing!

> Do you have your install CDs? If not, go to rpmfind.net and search for the
> zlib-devel. As you've found out, you don't have them installed. If you
> have your install CDs they'll probably be found on the 2nd or 3rd CD. Once
> you've installed that package you should be able to compile xine, unless
> you are missing other devel packages.

Ok, thank you! The zlib-devel package is on the 2nd install-cd... I
installed it and now it seems to work.
;-)
 
 
 

1. xine configuration fails; zlib not found but is installed

I'm trying to install xine, but "./configure" fails when it looks for
zlib. However, zlib (1.1.3) is installed. I use RH 7.3, running KDE
3.0. Anybody know if zlib needs to be configured once its installed (I
used KPackage to install the rpm off of my cds)? Or is there something
else I'm missing? Thanks.

2. Web activity analysis

3. Xine and RH9

4. linux woes

5. problem installing RH9

6. exit term in linux???

7. Problems with RH9 Install and GeForce FX5200 Video Card

8. Recommended CDROM writers please!

9. installing xine and css with debian

10. Solaris 2.4/SPARC linker problem while building Compress-Zlib

11. qt zlib problem (I know this is not a QT group)

12. ghost script / zlib problems

13. Problem in compile xine 0.9.2!