an issue in apt-get when upgrading mozilla to 1.2.1

an issue in apt-get when upgrading mozilla to 1.2.1

Post by Dieu Pha » Tue, 11 Feb 2003 23:12:14



hi there,
after updating mozilla-1.0.1*.rpm to mozilla-1.2.1*.rpm there is an issue
in apt-get as following:
//start apt-get

Ign http://apt.freshrpms.net redhat/8.0/en/i386 release
Hit http://apt.freshrpms.net redhat/8.0/en/i386/os pkglist
Hit http://apt.freshrpms.net redhat/8.0/en/i386/os release
Get:1 http://apt.freshrpms.net redhat/8.0/en/i386/updates pkglist [330kB]
Hit http://apt.freshrpms.net redhat/8.0/en/i386/updates release
Get:2 http://apt.freshrpms.net redhat/8.0/en/i386/freshrpms pkglist [102kB]
Hit http://apt.freshrpms.net redhat/8.0/en/i386/freshrpms release
Hit http://apt.freshrpms.net redhat/8.0/en/i386/os srclist
Get:3 http://apt.freshrpms.net redhat/8.0/en/i386/updates srclist [12.7kB]
Get:4 http://apt.freshrpms.net redhat/8.0/en/i386/freshrpms srclist [24.5kB]
Fetched 470kB in 2m32s (3077B/s)
Reading Package Lists... Error!
E: There are two or more versions of the package 'mozilla-nspr' installed in your system, which is a situation APT can't handle cleanly at the moment.
Please do one of the following:
1) Keep at most one version of the package in the system; or
2) If you do want to keep multiple versions of that package, lookup RPM::Allow-Duplicated in the documentation.

E: Error occured while processing mozilla-nspr (UsePackage3)
E: Problem with MergeList /var/lib/rpm/Packages
E: The package lists or status file could not be parsed or opened.
//END
I know there are two mozilla-nspr coexisting in system. Yet I can not
erase the old one due to required by evolution pkg? How Can I keep
multi-versions of an app. running that apt-get get no errors like above?
Thanks
--
::DieuPhan::RedHatLinux-8.0/kernel-2.4.18-24.8.0(recompiled)/AMD1800+XP::

 
 
 

an issue in apt-get when upgrading mozilla to 1.2.1

Post by loki » Wed, 12 Feb 2003 11:02:59



Quote:> I know there are two mozilla-nspr coexisting in system. Yet I can not
> erase the old one due to required by evolution pkg? How Can I keep
> multi-versions of an app. running that apt-get get no errors like above?

Well, from reading what apt said, I'd say you can't.  Do the packages
manually.

--
    loki
loki/at/internode.on.net

Dare I disturb the universe?  You bet I do! :)

 
 
 

1. gnome print error after apt-get upgrade

Yesterday i did an upgrade of my debian sarge.
After doing that i cannot print anymore with gnome application.

The error (printed on alt-f1 terminal) is appended.

Perhaps could be worth open a bug-zilla report to gnome developers?

Or any other temporary|definitive solution?
--
Post prandium stabis, post coenam ambulabis.

RRB

[ gnome-error < 1K ]
** (gthumb:13037): WARNING **: Opening 'zpr 2' for output failed

(gthumb:13037): GnomePrint-CRITICAL **: file gnome-print-ps2.c: line 260 (gnome_print_ps2_construct): assertion `ret == GNOME_PRINT_OK' failed

(gthumb:13037): GnomePrint-WARNING **: file gnome-print.c: line 132: Destroying
Context with open transport

(gthumb:13037): GnomePrint-CRITICAL **: file gnome-print-job.c: line 555 (gnome_print_job_print): assertion `ctx != NULL' failed

2. ;-( Diamond Stealth Pro 2meg with Taxan 1095 20" ;-(

3. oops 2.5.58-mm1while 'apt-get dselect-upgrade'

4. Are two PCI NIC cards possible?

5. windowmaker error after apt-get dist-upgrade

6. BUG in inode.c

7. apt-get update/upgrade fails on Debian box

8. lex/yacc/cc/unix question

9. Netscape - Mozilla Java plug-ins

10. Debian Apt-get won't work through win98ICS connection- but everything else does

11. HelP: apt-get under RH mangles names of rpm downloads

12. apt-get command