Problems installing gpg-agent on SuSE 8.1

Problems installing gpg-agent on SuSE 8.1

Post by Iai » Fri, 07 Feb 2003 06:13:57



Attempting to get the OpenPGP plug-in working for kmail (SuSE 8.1, KDE
3.1), I followed the instructions on
http://kmail.kde.org/kmail-pgpmime-howto.html.  I got all the pre-reqs
and  everything in the list compiled and installed without errors.

The problem is that gpg-agent won't run.  When I try to call it I get
the error "gpg-agent: error while loading shared libraries:
libgcrypt.so.1: cannot open shared object file: No such file or
directory".

This is weird because not only do I have libgcrypt.so.1 at the right
version, but the  newpg (package containing gpg-agent) configure found
it with no problems.

Does anyone have any ideas?

Iain.

 
 
 

Problems installing gpg-agent on SuSE 8.1

Post by Iai » Fri, 07 Feb 2003 17:52:33



> Attempting to get the OpenPGP plug-in working for kmail (SuSE 8.1, KDE
> 3.1), I followed the instructions on
> http://kmail.kde.org/kmail-pgpmime-howto.html.  I got all the pre-reqs
> and  everything in the list compiled and installed without errors.

> The problem is that gpg-agent won't run.  When I try to call it I get
> the error "gpg-agent: error while loading shared libraries:
> libgcrypt.so.1: cannot open shared object file: No such file or
> directory".

Problem fixed, and I'm feeling a bit foolish.  It looks like a reboot
sorted it out (Windows all over again).  gpg-agent looks to be working
fine now, as is the OpenPGP plug-in on KMail.

Iain.

 
 
 

1. Using gpg-agent and pinentry

Wanting to get Kmail using PGP/MIME I went through the how to at
http://kmail.kde.org/kmail-pgpmime-howto.html
and gpg will not work by itself. Have a look at this;


gpg: WARNING: using insecure memory!
gpg: please see http://www.gnupg.org/faq.html for more information

You need a passphrase to unlock the secret key for

1024-bit DSA key, ID 20BEEA5E, created 2003-01-20

gpg-agent[28556]: can't connect server: ec=-1
gpg-agent[28556]: can't connect to the PIN entry module: ec=-1
gpg-agent[28556]: command get_passphrase failed: no pin entry
gpg: problem with the agent - disabling agent use
Enter passphrase:
--
Fletch

2. NTFS filesystem driver ??

3. Suse 8.1 install, mouse problem

4. Any trading-NG for RS/6ks?

5. Problem installing HAMR5600 WinModem on SuSE 8.1

6. Some Casual Linux Advocacy

7. Suse 8.1 Install problem

8. Permissions of FTP uploads

9. about installing SuSE 8.1

10. Help installing SUSE Linux 8.1

11. installing Suse 8.1 on same drive as 8.0

12. PCI Hardware Modem USR 2977 not recognized after install in Suse 8.1

13. suse 8.1 ftp install, please help!!