mouse prob: 3-button; branded CPC - no selection in VCs

mouse prob: 3-button; branded CPC - no selection in VCs

Post by Stephen Bens » Mon, 22 Aug 1994 01:45:16



I have a new mouse -- branded CPC -- with a switch for Microsoft or Mouse
Systems mode (the labels say PC/MS -- a little confusing). Anyway in  Mouse
Systems mode (PC) the third button works in X as it  should _except_ I can no
longer double-click into a directory in xfm.

More seriously -- selection no longer works in the VCs; it  does work in X. If
I switch into MS mode (without rebooting)  the selection cursor comes up, but
the response is almost  non-existant ie unuseable. Installed properly and booted
into  MS mode it works but like a two button mouse (chordmiddle or
not). On balance the Mouse Systems mode is best but I miss selection...

Also after switching into/booting X I get _long_ periods (20
secs) before the mouse will even work -- this happened before with my old
MS-compat 2-button switching back to X from a VC, but now happens even when
I've just booted X -- a bit irritating

Anyone recognise the symptoms?

--
+  stephen benson  +   +   +   +   +   +  linux 1.0.9  +   +  xfree86 2.1.1  +

                    .                   * .
+                                  .                                .        +

 
 
 

mouse prob: 3-button; branded CPC - no selection in VCs

Post by Stephen Bens » Mon, 22 Aug 1994 21:44:33



>I have a new mouse -- branded CPC -- with a switch for Microsoft or Mouse
>Systems mode (the labels say PC/MS -- a little confusing). Anyway in  Mouse
>Systems mode (PC) the third button works in X as it  should _except_ I can no
>longer double-click into a directory in xfm.

>More seriously -- selection no longer works in the VCs; it does work in X.  If
>I switch into MS mode (without rebooting)  the selection cursor comes up, but
>the response is almost  non-existant ie unuseable. Installed properly and booted
>into  MS mode it works but like a two button mouse (chordmiddle or
>not). On balance the Mouse Systems mode is best but I miss selection...

>Also after switching into/booting X I get _long_ periods (20
>secs) before the mouse will even work -- this happened before with my old
>MS-compat 2-button switching back to X from a VC, but now happens even when
>I've just booted X -- a bit irritating

>Anyone recognise the symptoms?

And now another problem: intermittent freeze-ups/crashes in X. So far these
have occurred when I double-click in a file selection box (aXe, Xfilemanager,
a couple of tcl/tk apps): in some cases I think a single click was all that
is required - but force of habit... still, a full freeze is a harsh response.

*Freeze: everything remains on screen but I can't *do* anything with mouse or
keyboard. I have to hit reset (a nervous moment - no backup - to do that I need
many disks and/or a method)

This is all a real headache, but I want to use the 3-button mouse if I can.

--
+  stephen benson  +   +   +   +   +   +  linux 1.0.9  +   +  xfree86 2.1.1  +

                    .                   * .
+                                  .                                .        +

 
 
 

mouse prob: 3-button; branded CPC - no selection in VCs

Post by Z. Ya » Mon, 22 Aug 1994 23:38:47



Quote:>And now another problem: intermittent freeze-ups/crashes in X. So far these
>have occurred when I double-click in a file selection box (aXe, Xfilemanager,
>a couple of tcl/tk apps): in some cases I think a single click was all that
>is required - but force of habit... still, a full freeze is a harsh response.
>*Freeze: everything remains on screen but I can't *do* anything with mouse or
>keyboard. I have to hit reset (a nervous moment - no backup - to do that I need
>many disks and/or a method)
>This is all a real headache, but I want to use the 3-button mouse if I can.

i believe this all comes with your setup for the mouse. its not working
properly (see 1st followup).

zack

 
 
 

mouse prob: 3-button; branded CPC - no selection in VCs

Post by Z. Ya » Mon, 22 Aug 1994 23:36:02



Quote:>I have a new mouse -- branded CPC -- with a switch for Microsoft or Mouse
>Systems mode (the labels say PC/MS -- a little confusing). Anyway in  Mouse
>Systems mode (PC) the third button works in X as it  should _except_ I can no
>longer double-click into a directory in xfm.
>More seriously -- selection no longer works in the VCs; it  does work in X. If
>I switch into MS mode (without rebooting)  the selection cursor comes up, but
>the response is almost  non-existant ie unuseable. Installed properly and booted
>into  MS mode it works but like a two button mouse (chordmiddle or
>not). On balance the Mouse Systems mode is best but I miss selection...

have you also changed settings for selection, too? i guess not!
for mousesystems, in your rc.local file:

selection -t msc -p m &

flag '-p m' tells selection cut/paste with middle button.

zack

 
 
 

1. selection 1.3: patch for 3-button Mouse Systems devices

This is a patch to version 1.3 of selection, courtesy of Bill Earnest, that
fixes a problem with 3-button Mouse Systems devices. Apply by going into your
selection source directory and typing 'patch < patch-filename'.

*** mouse.c     Mon Jul 20 17:06:52 1992
--- mouse.c.new Mon Jul 20 17:08:31 1992
***************
*** 123,127 ****
  int get_ms_event(struct ms_event *ev)
  {
!     unsigned char buf[3];
      char dx, dy;
      int i, acc;
--- 123,127 ----
  int get_ms_event(struct ms_event *ev)
  {
!     unsigned char buf[5];
      char dx, dy;
      int i, acc;
--

GEC-Marconi Research | Tel: +44 245 73331 x.3283 | Telex: 995016 GECRES G

2. Help with iptable and port forwarding - Please

3. Can 2-button mouse do 3-button mouse works?

4. Where to store the expire date?

5. : 2-button vs 3-button mouse

6. ScanJet w/o interface card

7. Middle button on 3-button mouse not registering

8. LINUX BUMPER STICKERS ARE HERE!

9. Combining 2-button trackball with 3-button mouse

10. Setting up 3-button mouse with the middle button as wheel?

11. Make a 2-button mouse function like 3-button?

12. Emulating 3-button mouse/trackball with a 2-button device?

13. KeyMouse 3-button mouse - anyone get the third button working?