kde-1.1.1 bug (kab & korganizer) on solaris/egcs-1.1.2

kde-1.1.1 bug (kab & korganizer) on solaris/egcs-1.1.2

Post by Johannes Beh » Tue, 04 May 1999 04:00:00



Hi,

I just compiled kde-1.1.1 with kab and korganizer on my box
(Sparc solaris 7.0/egcs-1.1.2)

Everything works but kab and korganizer segfault right at the
beginning:

both print the same error message befor the segfault:

KCharset: Wrong charset!

KCharset: Wrong charset!

any Idea
  Johannes

-----------------------------------------------------------------
float o=0.075,h=1.5,T,r,O,l,I;int _,L=80,s=3200;main(){for(;s%L||
(h-=o,T= -2),s;4 -(r=O*O)<(l=I*I)|++ _==L&&write(1,(--s%L?_<L?--_
%6:6:7)+"World! \n",1)&&(O=I=l=_=r=0,T+=o /2))O=I*2*O+h,I=l+T-r;}

 
 
 

kde-1.1.1 bug (kab & korganizer) on solaris/egcs-1.1.2

Post by James Tappi » Wed, 05 May 1999 04:00:00



> Hi,

> I just compiled kde-1.1.1 with kab and korganizer on my box
> (Sparc solaris 7.0/egcs-1.1.2)

> Everything works but kab and korganizer segfault right at the
> beginning:

> both print the same error message befor the segfault:

> KCharset: Wrong charset!

> KCharset: Wrong charset!

I suspect the "Wrong charset" error is a red herring. This can be fixed
by setting your languages in Kcontrol (I use #1 English (UK), #2 English
(US) and #3 Default (C)), but I'm sure German first will be just as
good, just as long as it's not all 3 set to C.

--
James Tappin,               O__      "I forget the punishment for using

http://www.tappin.force9.co.uk/       with data loss in it I fancy"

 
 
 

kde-1.1.1 bug (kab & korganizer) on solaris/egcs-1.1.2

Post by Johannes Beh » Wed, 05 May 1999 04:00:00


Hi,

Quote:> > both print the same error message befor the segfault:

> > KCharset: Wrong charset!

> > KCharset: Wrong charset!

> I suspect the "Wrong charset" error is a red herring. This can be fixed
> by setting your languages in Kcontrol (I use #1 English (UK), #2 English
> (US) and #3 Default (C)), but I'm sure German first will be just as

Done. But I still get the same error (and segfault).

Maybe it has do to something with the kab part of the kdelib. Is there
another program beside kab and korganizer which uses the kab lib ?

thanks
  Johannes

> good, just as long as it's not all 3 set to C.

> --
> James Tappin,               O__      "I forget the punishment for using

> http://www.tappin.force9.co.uk/       with data loss in it I fancy"

 
 
 

1. glibc-2.1.1 and egcs-1.1.2

  Just installed Slackware 4.0 and want to put some glibc progs on
there. Love slack, but it needs to be glibc based. Anyway, I started
with gcc 2.7.?.? and compiled and installed egcs-1.1.2. Worked great,
gcc -v returns "gcc version egcs-2.91.66 19990314 (egcs-1.1.2 release)".
Next, I compiled and installed glibc-2.1.1 with crypt, linuxthreads, and
localedata. I installed it to /usr/local so I didn't break libc5 right
away. Next, I changed the specs file, changing ld-linux.so.1 to
ld-linux.so.2 and removing two references to -lgmon under the *lib:
section. I was able to compile and run a test program just fine and it
linked to libc.so.6 which is a link to libc-2.1.1.so like it should be.
Now, I get the same error when I have the glibc2 libs in /usr/local/lib
as I do when I tar that directory up and move it to /lib. Here is the
error I get
/lib/crt1.o(.text+0x1d): undefined reference to '__libc_start_main'
../lib/libncurses.so: undefined reference to '__strdup'
make[1]: *** [tic] Error1
make[1]: Leaving directory '/root/ncurses-5.0-990626/progs'
make: *** [all] Error2

Anyone know what it is linking against, why, and most importantly, how I
can change it?

--
Peter Buelow
**
"Becoming a Slack expert so I can permanently
walk outside and see the world without windows!"
**

2. Very slooow Netscape ???

3. Upgrading KDE from 1.1 to 1.2 in RH6.0

4. PCMCIA / PS2 IRQ12 Conflict (2.4 kernel)

5. math inline bugs with egcs1.1.2 glibc2.1.1

6. Star Office Download Problem

7. Java JDK 1.2 libs with JDK 1.1 VM - or 1.2 version available?

8. Linux Software Archive + more

9. GTK 1.2 & PGCC & EGCS

10. kernel 1.1 & 1.2

11. Does installing KDE-1.1.2 on Solaris require root and /opt/kde?

12. EGCS-1.1.1-x installation problem

13. Some notes on glibc-2.1 and egcs-1.1.1