KDE 3 beta1 - problems with compiling kdebindings

KDE 3 beta1 - problems with compiling kdebindings

Post by Lukasz Pluteck » Tue, 08 Jan 2002 03:06:50



Hi,
I've got problem with compiling kdebindings. I have jdk1.3.1 and during
compilation with java it's stops with Segmentation Faut :
[...]
Option.java QKeySequence.java QSqlFieldInfo.java QSqlRecordInfo.java
make[6]: *** [classjava.stamp] Segmentation fault
make[6]: Leaving directory
`/usr/local/src/kde3/kdebindings-3.0beta1/qtjava/javalib/org/kde/qt'
[....]

When I try to compile without java it also doesn't work ( can't find
jni.h ).
Others packages works without any problems ( GNU make-3.79.1 and qt-3.0.1 )

---
Lukasz Plutecki.

 
 
 

KDE 3 beta1 - problems with compiling kdebindings

Post by Richard Dal » Wed, 09 Jan 2002 10:30:39



> Hi,
> I've got problem with compiling kdebindings. I have jdk1.3.1 and during
> compilation with java it's stops with Segmentation Faut :
> [...]
> Option.java QKeySequence.java QSqlFieldInfo.java QSqlRecordInfo.java
> make[6]: *** [classjava.stamp] Segmentation fault
> make[6]: Leaving directory
> `/usr/local/src/kde3/kdebindings-3.0beta1/qtjava/javalib/org/kde/qt'
> [....]

It looks like it's failing when it has finished compiling the java sources - as the error message mentions 'classjava.stamp' (the build updates
classjava.stamp when finished). Is it possible that there is a permissions
problem with that file so javac can't write to it? Otherwise, is it javac
running out of memory perhaps?

Quote:> When I try to compile without java it also doesn't work ( can't find
> jni.h ).
> Others packages works without any problems ( GNU make-3.79.1 and qt-3.0.1 )

Yes, the qtjava project certainly needs jni.h - the configure script in
kdebindings should find that ok (as long as you don't disable java).

-- Richard

 
 
 

1. KDE 2.2.1: kdebindings doesn't compile

Hi everybody,

I tried to compile KDE 2.2.1 on my SuSE 7.0 Linux system. With the
kdebindings package, I got the following error:

/usr/i486-suse-linux/bin/ld: cannot find -lmimelib

In KDE 2.1.1, "mimelib" was in the kdesupport package, but in 2.2.1 there
is no such package.

Can anybody help?

Thanks in advance,

Tilman

2. Welcome to comp.unix.programmer (v1.16)

3. KDE 2.2.1 kdebindings (qtjava) won't compile due to too long argument list

4. checksums of S10 u 2 - what is md5sum.list ?

5. KDE 2.1-beta1 Compiling on LM 7.2

6. Unix

7. KDE Update 3.0.3 - 3.1 beta1

8. replace ^L by hard-return

9. KDE 2.1-beta1 doesn't save desktop settings

10. KMail / Kde 2.2.beta1 still does not support SMTP Authentication

11. KDE 2.2 Beta1 and MP3 Audio grabbing

12. KDE 2.2 beta1 out and looking good!

13. kde 3.0 beta1 rpms for redhat 7.2?