ktalk/ktalkd wont work

ktalk/ktalkd wont work

Post by cjf » Mon, 08 May 2000 04:00:00



I have been trying to get ktalk and ktalkd running on CorelLinux,
but with no success.  I get a segfault every time I try and run
ktalk, and when I try and run ktlakd manually, followed by ktalk,
I get the following:

PID could not get read.
Segmentation fault

I think I have inetd.conf configured properly:

talk            dgram   udp     wait    nobody.tty
/usr/sbin/tcpd  /usr/X11R6/bin/kotalkd
ntalk           dgram   udp     wait    nobody.tty
/usr/sbin/tcpd  /usr/X11R6/bin/ktalkd

any help most appreciated.

* Sent from RemarQ http://www.remarq.com The Internet's Discussion Network *
The fastest and easiest way to search and participate in Usenet - Free!

 
 
 

ktalk/ktalkd wont work

Post by David Faur » Tue, 09 May 2000 04:00:00



> I have been trying to get ktalk and ktalkd running on CorelLinux,
> but with no success.  I get a segfault every time I try and run
> ktalk, and when I try and run ktlakd manually, followed by ktalk,
> I get the following:

> PID could not get read.
> Segmentation fault

ktalkd is a daemon, it has to be started by inetd, you can't run it
manually.
How much I regret not writing that black on white in the documentation
now ! :)

Quote:> I think I have inetd.conf configured properly:

> talk            dgram   udp     wait    nobody.tty /usr/sbin/tcpd  /usr/X11R6/bin/kotalkd
> ntalk           dgram   udp     wait    nobody.tty /usr/sbin/tcpd  /usr/X11R6/bin/ktalkd

Try with root.root instead of nobody.tty.
Question: where did you find nobody.tty ? Ah, I guess it's the standard
setup ?
Well, ktalkd's documentation definitely says root.root IIRC.

Quote:> any help most appreciated.

Hope this helps.

--
David Faure


See http://www.kde.org/kde1-and-kde2.html for how to set up KDE 2.

 
 
 

ktalk/ktalkd wont work

Post by cjf » Wed, 10 May 2000 04:00:00


Thanks David,

I changed to root.root from nobody.tty, but now invoking ktalk
returns an "Illegal instruction" message.

Chris

* Sent from RemarQ http://www.remarq.com The Internet's Discussion Network *
The fastest and easiest way to search and participate in Usenet - Free!

 
 
 

ktalk/ktalkd wont work

Post by David Faur » Thu, 11 May 2000 04:00:00



> Thanks David,

> I changed to root.root from nobody.tty, but now invoking ktalk
> returns an "Illegal instruction" message.

The client (ktalk) ? That's a completely different matter then.
(I'm only the author of the daemon :-)
Make sure that ktalkd works with the standard 'talk' client, and
about the K client, make sure it's been correctly compiled (did you
compile it ? Is it a binary you got somewhere ?). In all else
fails, use 'strace ktalk' and send the last 20 lines, so that
we can see where it does that (I suppose it does it on startup ?
Or later on ?)

--
David Faure


See http://www.kde.org/kde1-and-kde2.html for how to set up KDE 2.

 
 
 

ktalk/ktalkd wont work

Post by cjf » Thu, 11 May 2000 04:00:00


David,

Here is the tail of the strace:

fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
close(6)                                = 0
munmap(0x40015000, 4096)                = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

* Sent from RemarQ http://www.remarq.com The Internet's Discussion Network *
The fastest and easiest way to search and participate in Usenet - Free!

 
 
 

ktalk/ktalkd wont work

Post by David Faur » Fri, 12 May 2000 04:00:00


Oooh, it segfaults. I guess I missed that.
It must give you a core file, then, no ?
In this case, do 'gdb ktalk core' then 'bt'
and send the result here - or to the author.
Remind me: did you compile ktalk yourself or installed
some binary or RPM ? If the latter, it may simply be some
wrong-lib problem....


> David,

> Here is the tail of the strace:

> fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
> fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
> fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
> fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
> fstat(6, {st_mode=S_IFREG|0644, st_size=587, ...}) = 0
> close(6)                                = 0
> munmap(0x40015000, 4096)                = 0
> --- SIGSEGV (Segmentation fault) ---
> +++ killed by SIGSEGV +++

> * Sent from RemarQ http://www.remarq.com The Internet's Discussion Network *
> The fastest and easiest way to search and participate in Usenet - Free!

--
David Faure


See http://www.kde.org/kde1-and-kde2.html for how to set up KDE 2.
 
 
 

1. dosemu was working then croaked now wont work at all

I was running the dosemulator and it had a problem and died
now I can't even start it
I copied my old hdimage overtop of the current one
still nothing
it gets the banner up and say's staring dos
just when you think it is going to work
it comes up with bad command or file not found
and kicks me out???
any idea what is wrong there
--
Merritt Secondary School - Computer Support Teacher

2. PPP and dynamic passwords

3. ktalkd

4. Intellimouse Trackball...

5. ktalkd buggy in KDE 1.1.2

6. tcsh completion

7. ktalk

8. objprelink success or failure?

9. ktalk configure problem

10. Ktalk and KDM 2.1 (expert needed)

11. Ktalk

12. wordperfect 8 wont work after reinstallation

13. ESD wont work on Debian potato GNOME/Enlightenment?!