How about jpeg in kde3?

How about jpeg in kde3?

Post by Palanti » Fri, 08 Feb 2002 01:01:08



Hi all!
I am playing around with my self compiled kde3 frm cvs, but I can't get
jpegs to be displayed... If I run KImageViewer and I try to open a jpeg
image, it says "Cannot load image" or it just stays black and doesn't load
it. I reckon it's a general problem (and not only of kview) because I can't
set up any jpeg desktop background nor can I get jpeg previews in konqueror
on in the common open file dialogues.
I compiled qt from cvs (qt-copy)  with the following options:

./configure -system-zlib -qt-gif -system-libpng -system-libjpeg
-plugin-imgfmt-mng -thread -no-stl -no-xinerama -no-g++-exceptions

What am I missing?

--
---Palantir---
ICQ:57482808  
Hi! I'm a .signature virus! Copy me into your ~/.signature, please!

 
 
 

How about jpeg in kde3?

Post by Gregory Davi » Fri, 08 Feb 2002 05:40:23



> ./configure -system-zlib -qt-gif -system-libpng -system-libjpeg
> -plugin-imgfmt-mng -thread -no-stl -no-xinerama -no-g++-exceptions

> What am I missing?

I thought the flag for qt-jpeg was "-system-jpeg" and not "system-libjpeg".
 Maybe that is the problem.

Greg

 
 
 

How about jpeg in kde3?

Post by karl » Fri, 08 Feb 2002 17:28:42




>> ./configure -system-zlib -qt-gif -system-libpng -system-libjpeg
>> -plugin-imgfmt-mng -thread -no-stl -no-xinerama -no-g++-exceptions

>> What am I missing?

> I thought the flag for qt-jpeg was "-system-jpeg" and not
> "system-libjpeg".
>  Maybe that is the problem.

> Greg

Your right "-system-jpeg" is the correct flag. I found its a good idea to
burn them to a cd so you don't have to recompile qt every time you upgrade
KDE. I have noticed KDE is tolerant of the QT version. I just insert the
libraries directly into /usr/lib/qt-2.3.2/lib and delete the old libs.
I'm interested in how architecture dependant the new libs are. I am using
pentium compiled libs succesfully on an AMDK6-2
--
the internet is a higher mind.
word your question carefully.
 
 
 

1. No JPEG and GIF support in KDE3

No JPEG and GIF support in KDE3

Von:


Datum:

Dienstag, 30. Juli 2002 22:10:44

Gruppen:

blfs.support

Keine Referenzen

I have compiled qt-3.0.3 with jpeg, gif ,  png and mng support, and
thereafter kde-3.0.2 following the kde3 hint, But there are no jpeg's or
gif's displayed in kde - as background, in kfm-thumnails and some other
applications, konqueror however displays them ion webpages and kview also
can display them. I don't understand where there is the mistake.

Please Help!

--
SebasTEAan Meisel

2. graphics under gcc..please reply with syntax

3. JPEG is not JPEG ?

4. Sound card support problem

5. How to upgrade from KDE3.02 to KDE3.03??

6. Question on Apache 1.3.19/FilesMatch/Content Handler behavior - kinda long but please read

7. Repacking KDE3.01 to /opt/kde3 ??

8. How to disable monitor power management

9. Howdy: Question - upgrading KDE3 - KDE3.1 (SuSE 8.1 distro)

10. Why is KDE3 using /home/dir/.kde/ instead of .kde3 ?

11. In search of Solaris 2.5 Netscape Navigator 3.0 plug ins

12. Need HELP to Log User Log-ins form the internet

13. Suse 7.0; Yast2, kinternet, rc.dialout und ich komme nicht ins Internet