kdegraphics snapshot configure error with kdvi

kdegraphics snapshot configure error with kdvi

Post by Eric Laffoo » Fri, 22 Sep 2000 04:00:00



Hi all,
I'm not quite a wizard on configuration scripting. I have this error during
config.
--------------------------------------------------
checking for /usr/share/texmf/texmf/web2c/texmf.cnf
configure: error. Please use the --with-tex-datadir option to point to the
main
directory of your TeX installation, where the file texmf/web2c/texmf.cnf
is found.
configure: error: ./configure failed for kdvi/kpathsea                      
--------------------------------------------------
I have tried to correct this.*should be looking here
/usr/share/texmf/web2c/texmf.cnf
so somehow texmf is replicating it's self. I've tried to compile like so
./configure --with-tex-datadir=/usr/share
and
./configure --without-tex-datadir
all to no avail. Does anyone have some advice for what is probably
something simple I am missing here?

Thanx

--
Eric Laffoon
A member of the Quanta+ Web development team
http://www.veryComputer.com/

 
 
 

kdegraphics snapshot configure error with kdvi

Post by tom » Sat, 23 Sep 2000 04:00:00


try --with-tex-datadir=/usr/share/texmf/web2c if that's where the file really
resides.


> Hi all,
> I'm not quite a wizard on configuration scripting. I have this error during
> config.
> --------------------------------------------------
> checking for /usr/share/texmf/texmf/web2c/texmf.cnf
> configure: error. Please use the --with-tex-datadir option to point to the
> main
> directory of your TeX installation, where the file texmf/web2c/texmf.cnf
> is found.
> configure: error: ./configure failed for kdvi/kpathsea
> --------------------------------------------------
> I have tried to correct this.*should be looking here
> /usr/share/texmf/web2c/texmf.cnf
> so somehow texmf is replicating it's self. I've tried to compile like so
> ./configure --with-tex-datadir=/usr/share
> and
> ./configure --without-tex-datadir
> all to no avail. Does anyone have some advice for what is probably
> something simple I am missing here?

> Thanx

> --
> Eric Laffoon
> A member of the Quanta+ Web development team
> http://www.veryComputer.com/

-- Check out www.diylinux.com and learn to create your own linux distribution.

 
 
 

kdegraphics snapshot configure error with kdvi

Post by Eric Laffoo » Sat, 23 Sep 2000 04:00:00


Well I almost got e*d...
Here's excerpts from my config run...
----------
creating config.h
configuring in kdvi/kpathsea
running /bin/sh ./configure  --with-tex-datadir=/usr/share/texmf/web2c
--prefix /opt/kde2 --with-tex-datadir=/usr/share/texmf
--cache-file=../.././config.cache --srcdir=.
loading cache ../.././config.cache
---------
doesnt seem to matter what i tell it, it knows that my tex direcory is
/usr/share/texmf. Then again if I tell it nothing it still chokes.
Then a little later...
---------
checking for /usr/share/texmf/texmf/web2c/texmf.cnf
configure: error. Please use the --with-tex-datadir option to point to the
main
directory of your TeX installation, where the file texmf/web2c/texmf.cnf
is found.
configure: error: ./configure failed for kdvi/kpathsea                      
---------
I gotta wonder... do other people compile these snapshots? This is just
plain weird! Where does it get teh extra /texmf and how do I make it
stop??? The last I could compile of kdegraphics was the beta. Everything
else compiles, even kdevelop. Is it possible there is somethign weird I'm
missing? The directory in question contains these files...
----------

amiga-pl.tcx  elatex.log     lambda.fmt    mktexnam.opt    pdflatex.fmt
amstex.fmt    etex.efmt      lambda.log    mktexupd*       pdflatex.log
amstex.log    etex.log       latex.fmt     mp.pool         pdftex.fmt
bamstex.fmt   etex.pool      latex.log     mpost.log       pdftex.log
bamstex.log   fmtutil.cnf    maz-pl.tcx    mpost.mem       pdftex.pool




cp1250t1.tcx  il2-pl.tcx     mktex.cnf     pdfelatex.log   tex.log
cp852-cs.tcx  il2-t1.tcx     mktex.opt     pdfetex.efmt    tex.pool
cp852-pl.tcx  jadetex.fmt    mktexdir*     pdfetex.log     texmf.cnf
cp8bit.tcx    kam-cs.tcx     mktexdir.opt  pdfetex.pool
elatex.efmt   kam-t1.tcx     mktexnam*     pdfjadetex.fmt
-------------
Am I in the right solar system here?

Any help appreciated.


> try --with-tex-datadir=/usr/share/texmf/web2c if that's where the file
> really resides.


> > Hi all,
> > I'm not quite a wizard on configuration scripting. I have this error
> > during config.
> > --------------------------------------------------
> > checking for /usr/share/texmf/texmf/web2c/texmf.cnf
> > configure: error. Please use the --with-tex-datadir option to point to
> > the main
> > directory of your TeX installation, where the file texmf/web2c/texmf.cnf
> > is found.
> > configure: error: ./configure failed for kdvi/kpathsea
> > --------------------------------------------------
> > I have tried to correct this.*should be looking here
> > /usr/share/texmf/web2c/texmf.cnf
> > so somehow texmf is replicating it's self. I've tried to compile like so
> > ./configure --with-tex-datadir=/usr/share
> > and
> > ./configure --without-tex-datadir
> > all to no avail. Does anyone have some advice for what is probably
> > something simple I am missing here?

> > Thanx

> > --
> > Eric Laffoon
> > A member of the Quanta+ Web development team
> > http://www.veryComputer.com/

--
Eric Laffoon
A member of the Quanta+ Web development team
http://www.veryComputer.com/
 
 
 

kdegraphics snapshot configure error with kdvi

Post by Kolbjorn Bekkelun » Sun, 24 Sep 2000 04:00:00



> Hi all,
> I'm not quite a wizard on configuration scripting. I have this error
> during config.
> --------------------------------------------------
> checking for /usr/share/texmf/texmf/web2c/texmf.cnf
> configure: error. Please use the --with-tex-datadir option to point to the
> main
> directory of your TeX installation, where the file texmf/web2c/texmf.cnf
> is found.
> configure: error: ./configure failed for kdvi/kpathsea
> --------------------------------------------------
> I have tried to correct this.*should be looking here
> /usr/share/texmf/web2c/texmf.cnf
> so somehow texmf is replicating it's self. I've tried to compile like so
> ./configure --with-tex-datadir=/usr/share
> and
> ./configure --without-tex-datadir
> all to no avail. Does anyone have some advice for what is probably
> something simple I am missing here?

> Thanx

It's something wrong with the configure script.
I fixed it so that I could compile the package by changing line 7068 in
configure to:

ac_configure_args="$ac_configure_args --with-tex-datadir="/usr/share/""

Kolbjorn
--
Kolbjorn Bekkelund
Bardufoss, Norway
http://www.veryComputer.com/~kolbekk

 
 
 

kdegraphics snapshot configure error with kdvi

Post by Eric Laffoo » Sun, 24 Sep 2000 04:00:00




> > Hi all,
> > I'm not quite a wizard on configuration scripting. I have this error
> > during config.
> > --------------------------------------------------
> > checking for /usr/share/texmf/texmf/web2c/texmf.cnf
> > configure: error. Please use the --with-tex-datadir option to point to
> > the main
> > directory of your TeX installation, where the file texmf/web2c/texmf.cnf
> > is found.
> > configure: error: ./configure failed for kdvi/kpathsea
> > --------------------------------------------------
> > I have tried to correct this.*should be looking here
> > /usr/share/texmf/web2c/texmf.cnf
> > so somehow texmf is replicating it's self. I've tried to compile like so
> > ./configure --with-tex-datadir=/usr/share
> > and
> > ./configure --without-tex-datadir
> > all to no avail. Does anyone have some advice for what is probably
> > something simple I am missing here?

> > Thanx

> It's something wrong with the configure script.
> I fixed it so that I could compile the package by changing line 7068 in
> configure to:

> ac_configure_args="$ac_configure_args --with-tex-datadir="/usr/share/""

> Kolbjorn

Many many thanks.. It worked! I may try the script as it is with an extra
recursion and upload it to cvs if it works.
--
Eric Laffoon
A member of the Quanta+ Web development team
http://www.veryComputer.com/
 
 
 

1. kdegraphics compile error on a rh6.2 (kdvi responsible?)

Any ideas as to why kdegraphics (for kde2.0) gives me the following
error during compilation
on a rh6.2 system? (I have the tetex packages installed and have
successfully
compiled _all_ the other kde2.0 packages):

.libs/libkdvi_la.all_cpp.o: In function `font::font_open(char *, char
**, double, int *, char **)':
.libs/libkdvi_la.all_cpp.o(.text+0xea30): undefined reference to
`xdvi_xfopen(char const *, char *)'
.libs/libkdvi_la.all_cpp.o: In function `font::glyphptr(unsigned int)':
.libs/libkdvi_la.all_cpp.o(.text+0xf656): undefined reference to
`xdvi_xfopen(char const *, char *)'
collect2: ld returned 1 exit status
make[3]: *** [libkdvi.la.closure] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/kdegraphics-2.0/kdvi'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/kdegraphics-2.0/kdvi'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/kdegraphics-2.0'
make: *** [all-recursive-am] Error 2
Bad exit status from /var/tmp/rpm-tmp.36529 (%build)    

Many thanks,

Cev.

2. SIMS's WebAccess put wrong FROM: field

3. Error compiling kdegraphics-3.0 with gcc-3.0.4

4. ftp attempt = 421 Service not available

5. JFS2 AIX 5.2 snapshot: consistent snapshot for multiple file systems

6. Real Audio privacy patch for Linux?

7. kde 981022 snapshots configure issues

8. HELP ... I have lost DOS

9. KDE 2.0 configure error --- can't find :admin/configure ?

10. fssnap - snapshot error: File system could not be write locked

11. kdevelop error: QT(snapshot >= Qt 2.1 beta2)

12. (Minor) errors when installing 2.7 snapshot, should they be reported?

13. snapshot error: File system could not be write locked