Koffice for kde 1.1?

Koffice for kde 1.1?

Post by Rod Roar » Sun, 21 Feb 1999 04:00:00



I'm trying to compile the 2/20 koffice snapshot for kde 1.1 with Red
Hat 5.2 and the required autoconf, automake, python, mico, etc.  I
did already compile kdelibs with --enable-new-stuff, and of course
corba.

koFilterManager.cc is giving me compile-time errors indicating that
/usr/local/kde/include/kregistry.h is not the required version.  
Indeed, it does seem to date back to September and the referenced
methods are not there.

Am I doing something wrong, or is koffice just going to be forever
incompatible with KDE 1.1?

TIA for any illumination....

-- Rod
----------------------------------------------------------------------
Sunset Systems                           Preconfigured Linux Computers
http://www.sunsetsystems.com/                         Starting at $499
----------------------------------------------------------------------

 
 
 

Koffice for kde 1.1?

Post by Yehoshua Shosha » Tue, 23 Feb 1999 04:00:00


In addition to Rod question:
On Solaris 2.6 with egcs 1.1.1 and qt1.42 kde1.1 compiled with --enable-new-stuff
I get the following message:
###############################
.
.
/bin/sh ../../libtool --silent --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../lib/koml -I../../lib/koml -I../../lib/store -I../../lib/store -I./../ -I/home/yssw/kde/include/idl -I/home/yssw/kde/include -I/home/yssw/kde/Prep/qt-1.42/include  -I/usr/openwin/include -I/home/yssw/kde/include    -O2 -Wall -c koFilterManager.cc
koFilterManager.cc: In method `class QString KoFilterManager::fileSelectorList(enum KoFilterManager::Direction, const char *, const char *, const char *, bool) const':
koFilterManager.cc:82: no matching function for call to `KRegistry::load (char[17])'
/home/yssw/kde/include/kregistry.h:179: candidates are: KRegistry::load()
koFilterManager.cc:83: no matching function for call to `KRegistry::isModified ()'
koFilterManager.cc:85: no matching function for call to `KRegistry::save (char[17])'
/home/yssw/kde/include/kregistry.h:173: candidates are: KRegistry::save()
koFilterManager.cc:86: no matching function for call to `KRegistry::clearModified ()'
gmake[3]: *** [koFilterManager.lo] Error 1
gmake[3]: Leaving directory `/home/yssw/koffice/koffice/lib/kofficecore'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/home/yssw/koffice/koffice/lib'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/home/yssw/koffice/koffice'
gmake: *** [all-recursive-am] Error 2
#################################################

Does anyone know how to solve this problem?
Yehoshua


> I'm trying to compile the 2/20 koffice snapshot for kde 1.1 with Red
> Hat 5.2 and the required autoconf, automake, python, mico, etc.  I
> did already compile kdelibs with --enable-new-stuff, and of course
> corba.

> koFilterManager.cc is giving me compile-time errors indicating that
> /usr/local/kde/include/kregistry.h is not the required version.
> Indeed, it does seem to date back to September and the referenced
> methods are not there.

> Am I doing something wrong, or is koffice just going to be forever
> incompatible with KDE 1.1?

> TIA for any illumination....

> -- Rod
> ----------------------------------------------------------------------
> Sunset Systems                           Preconfigured Linux Computers
> http://www.sunsetsystems.com/                         Starting at $499
> ----------------------------------------------------------------------


 
 
 

Koffice for kde 1.1?

Post by Rod Roar » Tue, 23 Feb 1999 04:00:00



>In addition to Rod question:
>On Solaris 2.6 with egcs 1.1.1 and qt1.42 kde1.1 compiled with --enable-new-stuff
>I get the following message:
>....

It turns out that KDE 1.1 is not new enough for the current koffice
snapshots.  You have to get a more recent KDE.  This info came from
one of the koffice developers.  I also reported two other compile-time
bugs (missing kword/filters/Makefile.am, and two misplaced .idl files)
which may or may not be fixed by now.

-- Rod
----------------------------------------------------------------------
Sunset Systems                           Preconfigured Linux Computers
http://www.sunsetsystems.com/                      and Custom Software
----------------------------------------------------------------------

 
 
 

1. KDE 2.2 and KOffice 1.1 RC1 for Tru64 released

From: Dr. Tom Leitner:

This is to inform you all that I have just released KDE 2.2 along with
KOffice 1.1 Release Candidate 1 for Compaq Tru64 Systems. The official
announcement by the KDE team will follow on monday next week.

KDE 2.2 for Tru64 can be downloaded from my FTP server:

           ftp://ftp.radar.tugraz.at/pub/kde2/tru64/2.2

and KOffice 1.1 RC1 can be downloaded from:

           ftp://ftp.radar.tugraz.at/pub/kde2/tru64/koffice-1.1-rc1

Please note that this KOffice version will only work with KDE 2.2
and not with earlier releases.

There are some minor known bugs in this KDE 2.2 release. Also https://
URLs for SSL connections do not work yet under Tru64. The next version KDE
2.2.1 should fix these problems. It is expected to be released in
September 2001.

--

Tru64.org, http://www.tru64.org
Tru64.org Newsletter:
http://www2.tru64.org/pages.php?page=Newsletter-Registration

2. RH6.1 Installation problem on PC64

3. GIMP 1.1 and KDE 1.1 problem

4. redhat 7.3

5. KOffice 1.1 Release Date?

6. Video Blaster Source for Linux??

7. KOffice-1.1.1 packages for Solaris-8 x86 available for download

8. Kword 1.1 beta 3: 1) print preview/printing in landscape mode is buggy, 2) Cannot save a .doc document. 3) Help

9. Koffice beta 1.1 libkdeprint.so

10. Koffice 1.1?

11. Koffice 1.1 beta3 for RH7.1??

12. KOffice 1.1 Print-to-Fax

13. Koffice 1.1 is out