Konqueror and Javascript

Konqueror and Javascript

Post by Rafael Amer Ramo » Wed, 04 Jul 2001 21:50:27



Hi.

I have several web pages with the following html text in a form

<input type=button value="O K" onClick=submit()>

It works correctly with netscape and IE, but not with konqueror. If I
enable
the debug messages, I get the following:

Can't find variable: submit. Initialising to null.
JS: Type error at line 1. Expression is no object.

Does anybody knows how I can solve this problem?

Thanks.

----------------------------------------------------------------------
     _/    _/  _/_/_/_/  _/_/_/  Rafael Amer Ramon
    _/    _/  _/    _/  _/       Departament de Matemtica Aplicada II
   _/    _/  _/_/_/_/  _/        E.T.S.E.I.T.
  _/    _/  _/        _/         Universitat Politcnica de Catalunya

----------------------------------------------------------------------

 
 
 

Konqueror and Javascript

Post by Guus vd Brin » Wed, 04 Jul 2001 22:27:41



Quote:

> Hi.

> I have several web pages with the following html text in a form

> <input type=button value="O K" onClick=submit()>

> It works correctly with netscape and IE, but not with konqueror. If I
> enable
> the debug messages, I get the following:

> Can't find variable: submit. Initialising to null.
> JS: Type error at line 1. Expression is no object.

May I ask where you enabled debug, or did you mean you started it from a
konsole?

BTW: Does it help to change it to: OnClick="submit(this.form)"
Otherwise, you should create a function called submit;
http://developer.irt.org/script/script.htm

Guus

--

Registered Linux user #219790 -- http://counter.li.org/


 
 
 

Konqueror and Javascript

Post by Nils O. Sel?sda » Wed, 04 Jul 2001 23:54:44





> > Hi.

> > I have several web pages with the following html text in a form

> > <input type=button value="O K" onClick=submit()>

> > It works correctly with netscape and IE, but not with konqueror. If
I
> > enable
> > the debug messages, I get the following:

> > Can't find variable: submit. Initialising to null.
> > JS: Type error at line 1. Expression is no object.

> May I ask where you enabled debug, or did you mean you started it
from a
> konsole?

> BTW: Does it help to change it to: OnClick="submit(this.form)"

I would go the other way.
OnClick="this.form.submit()" works Ok.
 
 
 

1. Problem with konqueror 2.2.2 and javascript button

Hi there,

I am using KDE 2.2.2 on a Debian/Linux unstable box.
Within konqueror, I do have java / javascript enabled
globally and all applets do work properly.

Unfortunately, the login button to my bank account
does not. I.e. "Anmelden" at
https://directnet1.credit-suisse.com/dn5/ident_post.eval?FUNCTION=ANM...

Clicking on "Anmelden" tries to execute
   javascript:do_submit_by_name("theform",'ABSENDEN_x')
but nothing happens.

Could someone please check, if you can get to the
next screen which would begin with "Eingabefehler ..."

Thanks and bye

Tobias

--

                 http://www.vt.ilw.agrl.ethz.ch/~hoevekam
WORK: ETH Zurich, LFO E21, CH-8092 Zurich, +41 1 632 3304
HOME: Anna Heer-Str. 2,  CH-8057  Zurich,  +41 1 350 5986

2. Humbled

3. Konqueror 2.2.2 and Javascript?

4. re-paritioning diskb i/o error ?

5. Konqueror: JavaScript Version?

6. Cannot using POST method.

7. Javascript in Konqueror!

8. apropos problems

9. Konqueror & Javascript

10. javascript in Konqueror?

11. Konqueror and JavaScript nav bars

12. javascript in konqueror 3.1.x

13. Javascript in Konqueror