KDE 3.1.x extremely slow

KDE 3.1.x extremely slow

Post by Roberto M » Sun, 29 Jun 2003 00:17:56



Hello everybody. I have some troubles with KDE 3.1.x, and even searching in
Google groups didn't help me: nobody seems to have the same problem! So, my
KDE 3.1 (and also its upgrades to 3.1.1 and 3.1.2) is extremely slow in
drawing windows and also background image; I found many people having
problem with slow startup of applications and also of kde itself, but this
is not my case. I use Suse 8.2 under a Duron 1 GHz cpu, with 512 mb of ram;
I have to say that kde 3.0.x was indeed very fast, and I can't understand
this sudden fall of performances. Furthermore, the same version of KDE
under Slackware on the same pc is as fast as the old kde 3.0.x. I thought
it might be a XFree problem: under Slackware there is XFree 4.2, while
under Suse XFree 4.3 is installed (and my graphic card is a Matrox G400 Max
with 32 mb). I really don't know what to do, so any suggestion will be very
appreciated, even a search key for Google! Thanks!
Roberto
 
 
 

KDE 3.1.x extremely slow

Post by Roberto M » Mon, 30 Jun 2003 02:19:07


I killed all kded instances, and now everything works fine!
Roberto

 
 
 

1. Extremely slow 3.1

Just installed Mandrake 9.1 on an 800 MHz Athlon machine and
commenced using the distribution KDE 3.1.

To my dismay, all KDE applications are extremely slow to launch.  
Both kcalc and konsole take 12-13 sec to come up.  In contrast,
Netscape 7 comes up in 6 sec; a straight xterm comes up in about 1 sec.

This happens even if I run another desktop such as Gnome and launch
KDE apps from there.  I also tried moving all my local KDE settings
(.kde etc)  and then starting KDE, but nothing changed.

My only clue is this: Lauching kcalc from a terminal, these messages
are printed:

        Loading required GL library /usr/X11R6/lib/libGL.so.1.2
        QLayout "unnamed" added to QtCalculator "kcalc-mainwindow#1",
        which already has a layout

So, what's going on?  Is something messed up in my installation,
or is KDE just a big fat pig?

2. X memory leaks?

3. KDE extremely slow "ls -l"

4. Load or import Quatro worksheet

5. KDE-Look.org site extremely slow

6. Installing TWO (2) D-Link DFE-530TX in the same box

7. kde 3.1 not displaying 3.1 "theme"

8. Using semaphores!

9. KDE 3.1 RC1/RC2 comparison to KDE 3.0.4

10. AT&T 3416 w/SCO - extremely slow

11. AST 4 port extremely slow!! Help!

12. Samba 2.0.5 on FreeBSD 3.1-RELEASE - very very slow writing to Samba from win98

13. My mouse is extremely slow in 2.4.1