wu-ftpd-2.4 problem

wu-ftpd-2.4 problem

Post by Trouble Typin » Sat, 16 Apr 1994 07:15:14



Wasn't the SITE EXEC problem supposed to be fixed by v2.4?  I just
installed it, and had a root shell in under 5 minutes (after logging
as a non-privileged user).  If it matters, this is under Ultrix v4.3

Jeff

--
+-------------------------------------------------------------------------+

+      ---=>  http://csugrad.cs.vt.edu/~jaitken/jaitken.html  <=---       +
+-------------------------------------------------------------------------+

 
 
 

wu-ftpd-2.4 problem

Post by Trouble Typin » Sat, 16 Apr 1994 14:24:02



: Wasn't the SITE EXEC problem supposed to be fixed by v2.4?  I just

Sorry for the alert here, it turns out I had changed one line in the
pathnames.h file which resulted in this problem.  So unless you've
gone and done something like this, you're not affected (I don't think)

Jeff
--
+-------------------------------------------------------------------------+

+      ---=>  http://csugrad.cs.vt.edu/~jaitken/jaitken.html  <=---       +
+-------------------------------------------------------------------------+

 
 
 

wu-ftpd-2.4 problem

Post by Karl Strickla » Sat, 16 Apr 1994 20:22:22



Quote:>  Wasn't the SITE EXEC problem supposed to be fixed by v2.4?  I just
>  installed it, and had a root shell in under 5 minutes (after logging
>  as a non-privileged user).  If it matters, this is under Ultrix v4.3

What did you have installed in your ftp-exec directory?  Or did you manage
to execute something from another directory?  I haven't yet seen 2.4 src,
but its supposed to be fixed in that.
--
------------------------------------------+-----------------------------------
Posted using GNUS 4.1 on FreeBSD          |                    Karl Strickland


 
 
 

1. wu-ftpd-2.4 problems

I used shadow in a box, and in part of it the wu-ftpd-2.4 is used.

However, it has an error when trying to run.

The error is glob.c:240 dereferencing pointer to impomplete type
make *** [glob.o] error 1

Not knowing what this has to do with, can someone help me out, or refer
me to some book or manual that I can use to solve this problem.

The version is wu-ftpd-2.4-fixed, if this helps.  I am also using
linux slakeware 2.0.0, the gcc is 2.7.2.

Please respond here for other as well.

Thanks in advance.

David

2. Tutorials on csh programming

3. WU-FTPD 2.6 Security Problem

4. >using Openwin3.3 in XDMCP mode

5. wu-ftpd sudden login problem for some accts

6. trainig for AIX

7. wu-ftpd v2.1 problems -- SIGSEGV (!)

8. KDE 2.1.1

9. wu.ftpd connection refused problem

10. wu.ftpd guest setup problems

11. wu-ftpd 2.4 install problems

12. FTP or wu-ftpd and Telnet problems.....

13. wu-ftpd virtual upload problem