libgd.so.1 not found with LinuxPPC2000

libgd.so.1 not found with LinuxPPC2000

Post by TGN » Mon, 20 Mar 2000 04:00:00



Hi,

I'm trying to install Linuxconf from the LinuxPPC2000 cd rom, but rpm
tells me that the libdg.so.1 is missing! There are also some other
programs that I've installed from the CD complaining of missing
libraries. Where can I find them?  Are they on the Cd - they should be!!

Also, where is the best guide to getting mac-on-linux working with the
2000 cd install??

Graeme

--
"Expansion leaves the ashes of change."

www.systementerprises.com/pixels

 
 
 

libgd.so.1 not found with LinuxPPC2000

Post by Chap Harriso » Mon, 20 Mar 2000 04:00:00



> I'm trying to install Linuxconf from the LinuxPPC2000 cd rom, but rpm
> tells me that the libdg.so.1 is missing!

You need to install the gd package first.  You'll find it under the
"Miscellaneous" category of packages.  (I don't know why, if linuxconf
is dependent on gd, gd doesn't get installed, but there you have it)

Chap

 
 
 

1. linuxconf - libgd.so.1 not found


Chap,
You aren't doing anything wrong. That's just the way Linux is. If you
noticed, you probably got an error message during the install about
linuxconf. This was because the installer got an error when it tried to
install it. The same error that you get when you run it. Just install
the gd rpm and linuxconf will work.

You might also want to edit your rc.local file and change hwclock to
clock since you don't have an hwclock.

For 'hello.cc' you might just need to add the c++ standard library to
your compile line. It isn't included by default. For any gcc c++ code,
you need:

gcc hello.cc -lstdc++

I'm still kind of puzzled by linuxppc 2000. I've had MkLinux running for
years with no problems and found it quite easy to use. I still haven't
ever gotten pump or dhcp to work in linuxppc. And if I look at the thing
wrong it will stop resolving names (but everything else will still work).

Do yourself a favor. Make backups of any files in /etc (or the whole
directory) before you edit them and/or run linuxconf, netconfig, etc.

John

2. 68040 MacBSD?

3. Missing libgd.so.1(linuxconf)& "not signed" Cups package

4. 2.1.99 pre 3

5. URGENT (NOT NEWBIE) Sendmail is Asking for libgd.so.2

6. Firewall

7. libgd.so.1

8. raid manager and volume manager

9. network down; libgd.so.1 AWOL

10. help: linuxconf-1.12r5-6rh RPM won't install without libgd.so.1

11. Whereis libgd.so.x?

12. libgd.so.1 and php mod?

13. ? libgd.so.1