G3 LinuxPPC Install ... HELP!

G3 LinuxPPC Install ... HELP!

Post by Mark Hornblow » Wed, 07 Oct 1998 04:00:00



okay ... my tail is between my legs and i am begging for help.  to wit:

i have a new g3/300 (minitower) with the a/v personality card. want to
install linuxppc.  partitioned the drive as recommended in the linuxppc
installation giude.

i did the multibooter thing, did the boot vaiables thing.

put a newly formatted floppy with g3intaller.coff in the drive.

the 'puter boots, the open firmware monitor comes up, it tries to boot from
the floppy ... the spinning stick whirls around for a while, the drive
grinds merrily away, and then it barfs.  here is the open firmware output:

<<------------------------------------------------->>

loader: loading XCOFF
tsize=5AEC  dsize=2D0  bsize=11B8  entry=500000

sections:
.text    00500000 00500000 00005AEC 00000124
.data    00510000 00510000 000002D0 00005C10
.bss     005102D0 005102D0 000011B8 00000000
.initrd  00000000 00000000 000CC230 00005EE0
.image   00000000 00000000 00076BD0 000D2110

loading .text, done..
loading .data, done..
cleaning .bss, done..
CLAIM failed

<<------------------------------------------------->>

at this point it tosses me back to the open firmware prompt.  successive
attempts to install fromt he floppy give the same result, until i give up
and type "BYE" in * and defeat.

NOTE 1: i have pulled the extra ram out of the box - running with the
factory-equipped 64meg

NOTE 2: i have tried setting the laod-base to 1000000, 100000, 60000, and
4000 (as suggested in the linuxppc installation guide)

any suggestions and/or mad inspiration would be muchly appreciated.  if you
reply to the group, could you also please send a copy to me via email?  i
use multiple machines during the day and don't want to miss an answer
jumping from one news reader to another ....

thanks plenty,
mark

--
--                                  
   ___  
 {(ojo)}
 | \O/ |                    
 \ /-\ /          Speed Kills!  Use Windows ... Save Lives
   | |                      
   / /

   /__\                http://www.veryComputer.com/~wombat

 
 
 

G3 LinuxPPC Install ... HELP!

Post by Steven L » Wed, 07 Oct 1998 04:00:00




>i did the multibooter thing, did the boot vaiables thing.

>put a newly formatted floppy with g3intaller.coff in the drive.

>the 'puter boots, the open firmware monitor comes up, it tries to boot from
>the floppy ... the spinning stick whirls around for a while, the drive
>grinds merrily away, and then it barfs.  here is the open firmware output:

Mark,

From my experience, I have never been able to boot off the installer
floppy with the Multibooter OF patch applied.  This is what you need to do
now:

1) Reset PRAM to clear out the Multibooter patch.  (Hold down command,
option, P, and R at the same time when turning on the Mac.  Wait until the
second chime.  Release).

2) Use BootVar to set boot-device to fd:g3installer.coff.  Uncheck the
auto-boot option.

3) Restart and type boot at the OF prompt.  You might have to try a few
times.  After you boot into the installer, proceed to install Linux.

4) After installation, boot MacOS.  NOW apply the MultiBooter patch.

Good luck.

Steve

--
Steven Lee

Return address was modified to fight off spammers.  
Send replies to: slee1 (at) erols (dot) com

 
 
 

1. Help Installing LinuxPPC Q3 on G3/266

I've got an installer disc for Linux PPC 1999 Q3, and I've installed the
kernel installer, live.filesystem, and BootX on my external SCSI.  When I
enter the XWindows installer and try to select CD-ROM as the installation
option I get a message saying that the CD-ROM does not mount.  I've tried
physically mounting the CD-ROM in an X-Term shell to no avail.  I've also
loaded up Red Hat independent of the XWindows Installer and it tells me
there are no Red Hat images on the disc.  I am also unable to access my
network.  Anybody have any idea what is going on.  I'm using a G3/266 with
64 megs RAM, 3 Gig external SCSI (two A/UX partitions, one MacOS standard),
and a 36x onboard standard CD-ROM.  Thanks in advance.

isaiah

2. Patches for ATI/XL mouse driver to fix clicking bug

3. problem installing linuxppc on G3 :please help

4. AT&T Unix 3.2 File System 5 - need to mount in R/W format under linux

5. Installing LinuxPPC (r4) on G3 minitower - please help

6. PD version of SysV 'news' wanted

7. Powerlogix G3 ZIP 466/233 on Beige G3 + LinuxPPC 99

8. trailing slashes in pathname?

9. LinuxPPC install on PB G3

10. Linuxppc install on PB G3 Series

11. LinuxPPC install on original 250Mhz G3 Powerbook

12. LinuxPPC '99 B&W G3 Install Woes

13. Installing linuxppc on a Mac G3/233