Printer on Digi PortServer II

Printer on Digi PortServer II

Post by Justin Weather » Tue, 27 Oct 1998 04:00:00



Running SCO OSr5.0.4 and Digi RealPort v2.3.0.
I'm trying to set up an Okidata ML521 serial printer
on a Digi PSII using Digi cable 76000195.
And I'm printing nothing fast.

on the ps2 i have
dev=prn & baud=9600

on SCO I'm using  mkdev lp just like I would any other printer
also per the RealPort manual...
sleep 999999 < /dev/ttyb16 &

Somebody through me a bone
TIA
Justin

 
 
 

Printer on Digi PortServer II

Post by Jeff Lieberma » Wed, 28 Oct 1998 04:00:00


On Mon, 26 Oct 1998 13:38:43 -0500, "Justin Weathers"


>Running SCO OSr5.0.4 and Digi RealPort v2.3.0.
>I'm trying to set up an Okidata ML521 serial printer
>on a Digi PSII using Digi cable 76000195.

Make sure you have "DTR enable" set to "invalid" in the serial portion
of the printer setup or your printer will probably not work.

Quote:>And I'm printing nothing fast.

If your paper is blank, perhaps you're printing too many form feeds?

Quote:>on the ps2 i have
>dev=prn & baud=9600
>on SCO I'm using  mkdev lp just like I would any other printer
>also per the RealPort manual...
>sleep 999999 < /dev/ttyb16 &

I vaguely recall that sleep has a finite limit of 32768 seconds.  Not
sure.  Never mind the sleep stuff and flow control for now.  Just run:
        cat somefile > /dev/ttyb16
and see if anything appears.  If not, play with one of the RS-232
anlayzers (2 db25 connectors and a bunch of LED's) and see if the lights
make sense.  There's a big difference between DTE and DCE wiring.

Quote:>Somebody through me a bone

Woof.  See:
   http://www.cruzio.com/~jeffl/sco/serial_print.txt
for some clues.

[ ]email  [x]news  [ ]mailing list      
--
Jeff Liebermann  150 Felker St #D  Santa Cruz CA 95060
(831)699-0483 pgr (831)426-1240 fax (831)336-2558 home
http://www.cruzio.com/~jeffl   WB6SSY


 
 
 

Printer on Digi PortServer II

Post by Ron N Schrein » Thu, 29 Oct 1998 04:00:00




>Running SCO OSr5.0.4 and Digi RealPort v2.3.0.
>I'm trying to set up an Okidata ML521 serial printer
>on a Digi PSII using Digi cable 76000195.
>And I'm printing nothing fast.

>on the ps2 i have
>dev=prn & baud=9600

I don't have my portserver book handy so the cmds may not be right...
Even though you are declairing the port as a dev=prn, make sure
logins and auto connect mode are turned off, also make sure
the IP port=0 and dest=255.255.255.255

Also check the flow settings and the altpin settings on the ps2.

Quote:>on SCO I'm using  mkdev lp just like I would any other printer
>also per the RealPort manual...
>sleep 999999 < /dev/ttyb16 &

Use the front pannel on the portserver to monitor the port,
(I am only familiar with the Digi PortServer, I assume the PortServerII
has a front pannel!)
cat a large file to the device you created, at 9600 baud you should
see the data lights flash.

>Somebody through me a bone
>TIA
>Justin


--

RONSAT Technologies, Inc.;   1686 Barclay Blvd.;   Buffalo  Grove,  IL  60089

UNIX Products   UNIX Services   UNIX Application Development   UNIX Solutions
--

RONSAT Technologies, Inc.;   1686 Barclay Blvd.;   Buffalo  Grove,  IL  60089

UNIX Products   UNIX Services   UNIX Application Development   UNIX Solutions
 
 
 

Printer on Digi PortServer II

Post by Steven L Coope » Fri, 30 Oct 1998 04:00:00


Justin,
We run printers at 9600 and 19.2 "round" here with hardware flow control.
Here is a sample of one of our setups:  
$ pwd
/etc/rc.d/8
$ cat userdef
:

#
#       Copyright (C) 1988-1991 The Santa Cruz Operation, Inc.
#               All Rights Reserved.
.
#       /etc/rc.d/8/userdef - User definable commands executed after boot
#
(stty  9600 ctsflow; while : ; do sleep 604800; done) < /dev/ttya05 &
(stty 19200 ctsflow; while : ; do sleep 604800; done) < /dev/ttya06 &
$

--
Steven L Cooper
Manager, Systems Engineering
---------------------------------------
Please reply to NG only, so others may be enlightened...
The views expressed here are mine and
you can't have them...unless you agree!



Quote:> Running SCO OSr5.0.4 and Digi RealPort v2.3.0.
> I'm trying to set up an Okidata ML521 serial printer
> on a Digi PSII using Digi cable 76000195.
> And I'm printing nothing fast.

> on the ps2 i have
> dev=prn & baud=9600

> on SCO I'm using  mkdev lp just like I would any other printer
> also per the RealPort manual...
> sleep 999999 < /dev/ttyb16 &

I never did understand the 999999 thing, it only lasts 11 days!  Was there
some version of SCO that treated this is "forever"?
Steve

> Somebody through me a bone
> TIA
> Justin