XFree86 3.x.x SCO Mach64 server dump core - help !

XFree86 3.x.x SCO Mach64 server dump core - help !

Post by Max V. Tereshenk » Tue, 05 Dec 1995 04:00:00



Ok I got dmmap and install it.
XF86_mach64 start but dump core.
It's OS 5.0
Anybody see this problem ?

server output:
-----------
TRANS(Open): transport open failed for named/max.maak.msk.su:1
TRANS(MakeAllCOTSServerListeners) failed to open listener for named

XFree86 Version 3.1.2 / X Window System
(protocol Version 11, revision 0, vendor release 6000)
Operating System: UNIX System V/386 Release 3 (SCO Version 3.2.4)
Configured drivers:
  Mach64: accelerated server for ATI Mach64 graphics adaptors (Patchlevel 0)
(using VT number 1)

XF86Config: /etc/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) Mouse: type: Microsoft, device: /dev/tty1a, baudrate: 1200,
       3 button emulation (timeout: 50ms)
(**) Mach64: Graphics device ID: "mach64"
(**) Mach64: Monitor ID: "alfa"
(**) FontPath set to "/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/Type1/,/usr/li
b/X11/fonts/Speedo/,/usr/lib/X11/fonts/75dpi/,/usr/lib/X11/fonts/100dpi/"
(--) Mach64: card type: PCI
(--) Mach64: Clock type: ATI18818-1
(--) Mach64: Number of Clocks: 32
(--) Mach64: clocks:  50.35  56.64  63.00  72.00  40.00  44.90  49.50  50.00
(--) Mach64: clocks:   0.00 110.00 126.00 135.00   0.00  80.00  75.00  65.00
(--) Mach64: clocks:  25.18  28.32  31.50  36.00  20.00  22.45  24.75  25.00
(--) Mach64: clocks:   0.00  55.00  63.00  67.50   0.00  40.00  37.50  32.50
(--) Mach64: Maximum allowed dot-clock: 135.000 MHz
(**) Mach64: Mode "1024x768": mode clock =  75.000, clock used =  75.000
(**) Mach64: Virtual resolution: 1280x1024
(--) Mach64: videoram: 2048k
(--) Mach64: Using hardware cursor
Using dmmap version 0x0100.
(--) Mach64: Using 4 MB aperture
(--) Mach64: Ramdac is ATI68880
(**) Mach64: Using 6 bits per RGB value
(--) Mach64: Aperture mapped to 0x7c000000
(--) Mach64: Pixmap cache: 1 256x256 slots, 2 128x128 slots, 8 64x64 slots
(--) Mach64: Font cache: 16 fonts

Fatal server error:
Caught signal 11.  Server aborting
----------

sdb output:

----------

kill() has no subroutine linkage (pushl)
        Maybe kill() from abort() <-- My guess
        Maybe kill() from __gnu_compiled_c()
        Maybe kill() from miSpriteImageText16()
abort()
ddxGiveUp(0x406028)
AbortDDX()
AbortServer()
FatalError()
xf86SigHandler(0xb)
malloc(0x158)
Xalloc(0x158)
InitKeyClassDeviceStruct(0x4337b8,0x7ffffd7c,0x7ffffc7c)
InitKeyboardDeviceStruct()
xf86KbdProc(0x4337b8,0)
InitAndStartDevices(4,0x7ffffde4)
main(4,0x7ffffde4,0x7ffffdf8)
*x
 eax/ 0              ebx/ 0x400218       ecx/ 0              edx/ 0x1f9      
 edi/ 0x7ffffc7c     esi/ 1              ebp/ 0x7ffffa38     esp/ 0x7ffffa28  
 eip/ 0x1171ac      flag/ 0x246         trap/ 0x212          err/ 0x25        
fpsw/ 0x00004020    fpcw/ 0x00001272    fpip/ 0x00000000    fpdp/ 0x00000000
 st(0)/ [ EMPTY ] 0x0000 0000 0000 0000 0000 ????
 st(1)/ [ EMPTY ] 0x0000 0000 0000 0000 0000 ????
 st(2)/ [ EMPTY ] 0x4005 a028 f5c2 8f5c 2000 ????
 st(3)/ [ EMPTY ] 0x4005 b42e 147a e147 a800 ????
 st(4)/ [ EMPTY ] 0x4005 8603 c500 0000 0000 ????
 st(5)/ [ EMPTY ] 0x3fff 8020 c49b a5e3 5000 ????
 st(6)/ [ EMPTY ] 0x3ffe ffbe 76c8 b439 5800 ????
 st(7)/ [ EMPTY ] 0x4005 9600 0000 0000 0000 ????
0x1171ac (kill+0xc):    jb     +0x00000016 <1171c8>     [_cerror]
*
----------
HELP!
--

-------------------------------------------------------------
                        Max V. Tereshenkov
                        System Administrator,
                        ITC Ost-In, Moscow, Russia

 
 
 

1. XFree86 3.x.x SCO Mach64 server - help !

I got it from ftp://ftp.ibp.fr .
My system is OS 5.0

After configuring /etc/XF86Config I tried to run and got:

-------------------
TRANS(Open): transport open failed for named/max.maak.msk.su:1
TRANS(MakeAllCOTSServerListeners) failed to open listener for named

XFree86 Version 3.1.2 / X Window System
(protocol Version 11, revision 0, vendor release 6000)
Operating System: UNIX System V/386 Release 3 (SCO Version 3.2.4)
Configured drivers:
  Mach64: accelerated server for ATI Mach64 graphics adaptors (Patchlevel 0)
(using VT number 1)

XF86Config: /etc/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) Mouse: type: Microsoft, device: /dev/tty1a, baudrate: 1200,
       3 button emulation (timeout: 50ms)
(**) Mach64: Graphics device ID: "mach64"
(**) Mach64: Monitor ID: "daewoo"
(**) FontPath set to "/usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/Type1/,/usr/lib/X11/fonts/Speedo/,/usr/lib/X11/fonts/75dpi/,/usr/lib/X11/fonts/100dpi/"
(--) Mach64: card type: PCI
(--) Mach64: Clock type: ATI18818-1
(--) Mach64: Number of Clocks: 32
(--) Mach64: clocks:  50.35  56.64  63.00  72.00  40.00  44.90  49.50  50.00
(--) Mach64: clocks:   0.00 110.00 126.00 135.00   0.00  80.00  75.00  65.00
(--) Mach64: clocks:  25.18  28.32  31.50  36.00  20.00  22.45  24.75  25.00
(--) Mach64: clocks:   0.00  55.00  63.00  67.50   0.00  40.00  37.50  32.50
(--) Mach64: Maximum allowed dot-clock: 135.000 MHz
(**) Mach64: Mode "640x480": mode clock =  25.175, clock used =  25.175
(**) Mach64: Virtual resolution: 640x480
(**) Mach64: videoram: 2048k
(--) Mach64: Using hardware cursor
The mach64 X server requires at least a 4Mb memory aperture.

 *** A configured device found, but display modes could not be resolved.***

Fatal server error:
no screens found
-------------------------

what's wrong ? HELP please !

Bye.
--

-------------------------------------------------------------
                        Max V. Tereshenkov
                        System Administrator,
                        ITC Ost-In, Moscow, Russia

2. XNTP using Port 123 only... how can i change this?

3. dump core or not dump core

4. The "unimplemented" Class value?

5. core dumps core dumps everywhere...

6. video creation application on Linux?

7. HELP: SCO memory fault: core dumped

8. Changing Filesystems Size on the Fly

9. Can I use XFree86 3.1 Mach64 SVGA server in XFree86 2.1?

10. Help needed with XFree86 X Server and ATI Mach64

11. Problem (core dumping) with Uniplex v7 on SCO Openserver 5

12. KStatusBar core dump - XFree86 4.0 + FreeBSD 4.0

13. SCO Unix 5.0.5 - Compiles fine but Core dump on start up ?