VisionFS won't start - Address already in use

VisionFS won't start - Address already in use

Post by Tom Parson » Thu, 06 Aug 1998 04:00:00




| I have installed VisionFS on my server with SCO OpenServer 5.0.4, TCPIP is
| configured, but I receive this message and the server fails to load.
|
| MESSAGE START-------
|
| 1998/08/05 08:26:34.590 process/start  SCO VisionFS(1.2) 1998/08/05
| 08:27:35.010 NameServer/Network/OpenUDPSocket  SCO VisionFS(1.2 )
|
| SCO VisionFS(1.2) FATAL ERROR: The server has encountered an error that means
| it cannot continue.  It will now exit.        A technical description is given
| below to help establish the cause. Failed to open UDP port 137:
| bind(11,145.229.46.255:137): (102) Address already in use The naming has
| failed to start. Check that no other application is using the same port.
|
| 1998/08/05 08:27:35.010 process/exit    SCO VisionFS(1.2)
| Exiting abnormally
|
| MESSAGE END ----
|
| Neither AFPS or LM Client are installed or running.  What could cause this
| problem and how can I solve it?

It thinks Port 137 is in use.  Grab lsof from the Skunkware archives
at ftp.sco.com and see what is camped on that port.
--
==========================================================================

==========================================================================    

 
 
 

VisionFS won't start - Address already in use

Post by Matt Schofiel » Thu, 06 Aug 1998 04:00:00



> I have installed VisionFS on my server with SCO OpenServer 5.0.4, TCPIP is
> configured, but I receive this message and the server fails to load.

> MESSAGE START-------

> 1998/08/05 08:26:34.590 process/start  SCO VisionFS(1.2) 1998/08/05
> 08:27:35.010 NameServer/Network/OpenUDPSocket  SCO VisionFS(1.2 )

> SCO VisionFS(1.2) FATAL ERROR: The server has encountered an error that means
> it cannot continue.  It will now exit.  A technical description is given
> below to help establish the cause. Failed to open UDP port 137:
> bind(11,145.229.46.255:137): (102) Address already in use The naming has
> failed to start. Check that no other application is using the same port.

Nigel,

Does the machine have two network cards? If so please post the output of
the command 'ifconfig -a'.

If it only has one network card then please send the output of

netstat -a | grep 137
netstat -a | grep nb

Regards

Matthew Schofield

 
 
 

VisionFS won't start - Address already in use

Post by Toby Darlin » Fri, 07 Aug 1998 04:00:00


It appears to be broadcast address bind failure. Do you have 2 (or more)
NICs installed?

Cheers
Toby

Quote:> >1998/08/05 08:26:34.590 process/start  SCO VisionFS(1.2) 1998/08/05
> >08:27:35.010 NameServer/Network/OpenUDPSocket  SCO VisionFS(1.2 )

> >SCO VisionFS(1.2) FATAL ERROR: The server has encountered an error that
> means
> >it cannot continue.  It will now exit. A technical description is given
> >below to help establish the cause. Failed to open UDP port 137:
> >bind(11,145.229.46.255:137): (102) Address already in use The naming has
> >failed to start. Check that no other application is using the same port.

 
 
 

VisionFS won't start - Address already in use

Post by Tony Lawrenc » Fri, 07 Aug 1998 04:00:00



> I have installed VisionFS on my server with SCO OpenServer 5.0.4, TCPIP is
> configured, but I receive this message and the server fails to load.
> Neither AFPS or LM Client are installed or running.  What could cause this
> problem and how can I solve it?

But what about netbios?  Did you remove or otherwise
cripple /etc/rc2.d/S86netbios so that it won't start?  Either
moving it to "s86netbios" or inserting an "exit 0" at
the beginning will accomplish that.

See article on visionfs at http://www.aplawrence.com/unixarticles.html

--

SCO ACE
SCO articles, help, book reviews: http://www.aplawrence.com

 
 
 

VisionFS won't start - Address already in use

Post by Eric G. Marchan » Fri, 07 Aug 1998 04:00:00


Hi,
To resolve your problem you must remove TPI NetBios for TCP/IP of SCO TCP/IP
LoopBack Driver before to load your lan and before to load VisionFS.

Best Regards

Eric Marchand
Tech. Supp. Manager

 
 
 

1. visionFS problem starting server - socket address 139 already in use

Probably Samba.  Do you have Samba or some other SMB networking
package installed?

Try:
  netstat -an | more
for a clue as to which socket numbers are being used.  The list of
programs to socket numbers is in /etc/services.

To get the calling program name, you'll need to download and use
"lsof" at:    
        ftp://ftp.sco.com/TLS/tls615.tar.Z
        ftp://ftp.sco.com/TLS/tls615.ltr

2. rzsz9305 - dir checksum error

3. 'Server already active for display 0' - won't start

4. UNIX filesystems on Sun SPARCstation floppy disks (solve

5. VisionFs won't start

6. restricting rsh...

7. ERROR: can't bind local address: Address already in use ???

8. Unix - Frequently Asked Questions (Contents) [Frequent posting]

9. CDE won't start after IP address change

10. Regular problem - 'Address already in use'

11. 'Address already in use' socket problem

12. Problem restarting server: 'Address already in use' error persists

13. linuxconf error: 'nfssvc: Address already in use'