glib-config, gtk-config

glib-config, gtk-config

Post by Maina » Thu, 02 Jan 2003 02:06:08



hi,
i am using Suse-8.1 and tried to upgrade the Mplayer and add a few video
plugins to xmms, but all the configuration scripts i ran gave the same
error.
glib ver >= 1.2 not found .
similar error for gtk as well.
i checked out and found that these two libraries are installed but the
glib-config and gtk-config files are not there in /usr/bin/.
i checked other linux versions RH-7.3 for ex and found these two files. i
copied these two files to the /usr/bin/ dir and changed the perms
accordingly. but still the scripts give the same error which was quite
expected. i did not try to edit those two files in ne way as i understood
little of what was written in it.
ne help will be appreciated
Mainak

--
-------------------------------------------------------------------------------------------------------

We are the people our parents warned us about...

 
 
 

glib-config, gtk-config

Post by lobotom » Thu, 02 Jan 2003 09:49:45



> hi,
> i am using Suse-8.1 and tried to upgrade the Mplayer and add a few video
> plugins to xmms, but all the configuration scripts i ran gave the same
> error.
> glib ver >= 1.2 not found .
> similar error for gtk as well.

Probably there are gtk-devel and glib-devel (or something like that)
packages that you need to install to get these.  I don't know exactly
what they are called on SuSE, but this is what you need.  They contain
the header files you need to compile software against these libraries.

Quote:> i checked out and found that these two libraries are installed but the
> glib-config and gtk-config files are not there in /usr/bin/. i checked
> other linux versions RH-7.3 for ex and found these two files. i copied
> these two files to the /usr/bin/ dir and changed the perms accordingly.
> but still the scripts give the same error which was quite expected.

That won't help you.  The xxx-config programs just tell the configure
script where to look for the headers, and what version is installed.  If
you just copy the program, without the rest of the stuff in the devel
package, it won't do anything constructive.

 
 
 

1. gtk-config glib-config and configure

        Greetings, I'm having some issues with gtk-config and
glib-config when used by the configure scripts when compile various
gtk software. I'm receiving the following error:

*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the glib-config script: /usr/bin/glib-config

Exact same error for gtk-config. This was working just fine. The same
software that compiled just fine are now breaking when I run
./configure

I have the following system:
RedHat 6.2 upgraded with Helix Gnome.

        I had run into some lilo problems the other week and the only
thing I could do was reinstall. Ever since then gtk-config and
glib-config have been giving problems when I run ./configure. I did
not know they existed until they broke.
        The scripts are there and I can run them from the command line
and receive the various output meant to be used with gcc. But I
receive the above error when I run ./configure as the same user.
        I installed Helix Gnome on top of all this hoping that the gtk
and glib rpms from the Helix cd would clear things up. Well Helix
Gnome is working just fine but I'm still running into the same
problem. I check and the new gtk and glib libraries from the helix cd
were installed.

        I can't make heads or tales of what's broken. If someone could
give some pointers, I'll be eternally greatfull.

        thanks

        narbey

2. Can't compile 1.1.XX on Pentinum

3. gtk+ && glib-config?

4. Multiple Displays on Solaris x86

5. glib-config returned 1.2.10 but glib 2.0.3 found error.

6. How to find the source of Python Dynamic Library?

7. Missing gtk-config while blding gvim w/ gtk

8. Problem with finger command

9. glib-config path not found

10. Problem installing xdelta-1.1.3 [glib-config not found]

11. what & where is glib-config?

12. can't compile gnome - "'gtk-config' script not found"

13. gtk-config not found?