Serial Problems with getty, setserial, etc... (please help)

Serial Problems with getty, setserial, etc... (please help)

Post by Peter C. Nort » Sun, 18 Jul 1993 14:26:19



Here are my questions:

I just got setserial 2.02 off of tsx-11.  When I ran make, there were some
ASYNC_?????_???? errors.  If necessary, I can provide these errors if
anyone's interested, but I'm wondering if setserial 2.02 was made for pl10,
or do I need pl11 to run it?  Or are there files that may have been missed
when pl10 was compiled (from pl9)?

Also (this may be a FAQ, but I haven't seen it), is there a bug in getty?
It barfs at any speed higher then 9600 baud.  At 38400 it sort of works,
however, it periodically spews crap.

Anyway, any advice is appreciated...

---Peter

 
 
 

1. Serial, getty etc.

Hello there,

I seem to be having a problem with my dialin on my FreeBSD 3.3 machine.
Basicly, it's been working fine for months until recently. For no reason
it all it just started giving garbage when I dial into it.

It's a simple setup. I've enabled getty in /etc/ttys and set the modem
to AA. (I will run mgetty when I get this fixed. Mgetty won't even answer
the phone at the moment - presumably because it gets garbage rather than a
RING string)

After much RTFM'ing and stuffing around, I got it to work ONLY after I had
run: cu -s 115200 -l /dev/cuaa0 dir

After doing a ~. when successfully connected and talking to the modem it
would then allow me to dialin and work without garbage.

This is confusing the hell out of me as cu works with cuaa0 (dialout) while
getty uses ttyd0 (dialin). I assume it's changing the serial features for
both when I use cu.

What I'd really like to know is why on earth would it suddenly screw up like
this? (I haven't changed any settings on this machine. It's task was to
simply route between the ethernet and the PPP interfaces and take incomming
calls. I don't use it appart from that!!)

Also I'd like to know how I can get the box to set and keep the settings
that are set when I run cu. (Whenever I turn off and on the modem or
of course, reboot the settings are reset). stty -f /dev/ttyd0 115200 crtscts
doesn't fix it.

Any help would be appreciated. (I can provide more details if needed!!)

Appart from this, my "FreeBeastie" box has been worth it's weight in gold.

Thanks in advance.

Regards,

Chris Fletcher.

2. Sound problem on Toshiba Laptop

3. Serial Card / Setserial Help

4. #include <stdio.h> error

5. Getty problems/Serial problem

6. Static IP w/ PPPoe xDSL Firewall

7. /etc/getty and /etc/inittab woes

8. how should I secure my socks5 server?

9. Help: Setserial says serial port/modem exists, no responses from minicom

10. Serial Card /setserial Help

11. Sendmail problems. Please please please please help!

12. setserial help please RH 6.1

13. isapnp, setserial, ppp - I need your help please...