Upgrading glibc 2.1 -> 2.2

Upgrading glibc 2.1 -> 2.2

Post by John » Sat, 28 Jul 2001 14:01:34



Hi all.
I am in dire need of upgrading glibc 2.1 to 2.2 in RH 6.2. I have
searched for documentation etc and have not found any. Here is what I
currently have installed:
rpm -qa | grep glib
glibc-2.1.3-15
glib-1.2.6-3
glib-devel-1.2.6-3
glib10-1.0.6-6
glibc-devel-2.1.3-15

Is there a sane way to go about doing this? I don't want to "upgrade"
to RH 7.1.

When I do:
rpm -Uvh glibc-2.2.1-3.i386.rpm
error: failed dependencies:
        glibc-common = 2.2.1 is needed by glibc-2.2.1-3
        rpm <= 4.0-0.65 conflicts with glibc-2.2.1-3
        libdb.so.2 is needed by chkfontpath-1.7-2
        libdb.so.2 is needed by bug-buddy-0.7-1
        libdb.so.2 is needed by control-center-1.0.51-3
        libdb.so.2 is needed by ee-0.3.11-1
        libdb.so.2 is needed by enlightenment-conf-0.15-9
        libdb.so.2 is needed by gdm-2.0beta2-23
        libdb.so.2 is needed by gedit-0.6.1-3
        libdb.so.2 is needed by glade-0.5.5-4
        libdb.so.2 is needed by gmc-4.5.42-10
        libdb.so.2 is needed by gnome-core-1.0.55-12
        libdb.so.2 is needed by gnome-games-1.0.51-4
        libdb.so.2 is needed by gnome-libs-1.0.55-12
        libdb.so.2 is needed by gnome-linuxconf-0.25-2
        libdb.so.2 is needed by gnome-media-1.0.51-2
        libdb.so.2 is needed by gnome-objc-1.0.2-6
        libdb.so.2 is needed by gnome-pim-1.0.55-1
        libdb.so.2 is needed by gnome-utils-1.0.50-4
        libdb.so.2 is needed by gnorpm-0.9-15
        libdb.so.2 is needed by gnumeric-0.48-3
        libdb.so.2 is needed by gpgp-0.4-2
        libdb.so.2 is needed by gtop-1.0.5-1
        libdb.so.2 is needed by libglade-0.11-1
        libdb.so.2 is needed by magicdev-0.2.7-1
        libdb.so.2 is needed by memprof-0.3.0-4
        libdb.so.2 is needed by passwd-0.64.1-1
        libdb.so.2 is needed by pygnome-1.0.51-1
        libdb.so.2 is needed by pygnome-libglade-0.6.4-1
        libdb.so.2 is needed by python-1.5.2-13
        libdb.so.2 is needed by rp3-1.0.7-4
        libdb.so.2 is needed by rpm-build-3.0.4-0.48
        libdb.so.2 is needed by rpm-python-3.0.4-0.48
        libdb.so.2 is needed by sawmill-gnome-0.24-3
        libdb.so.2 is needed by wmconfig-0.9.8-1
        libdb.so.2 is needed by xchat-1.4.0-1
        libdb.so.2 is needed by rpm-3.0.5-9.6x
        libdb.so.2(GLIBC_2.0) is needed by gnome-libs-1.0.55-12
        libdb.so.2(GLIBC_2.0) is needed by python-1.5.2-13
        libdb.so.2(GLIBC_2.0) is needed by rpm-3.0.5-9.6x
        libdb.so.3 is needed by pam-0.72-6
        libdb.so.3 is needed by perl-5.00503-10
        libdb.so.3 is needed by nmh-1.0.3-6x
        libdb.so.3 is needed by python-1.5.2-13
        libdb.so.3 is needed by sendmail-8.9.3-20
        libdb.so.3(GLIBC_2.0) is needed by perl-5.00503-10
        libdb.so.3(GLIBC_2.0) is needed by nmh-1.0.3-6x
        libdb.so.3(GLIBC_2.0) is needed by python-1.5.2-13
        libdb.so.3(GLIBC_2.1) is needed by pam-0.72-6
        libdb.so.3(GLIBC_2.1) is needed by perl-5.00503-10
        libdb.so.3(GLIBC_2.1) is needed by sendmail-8.9.3-20

 
 
 

1. Upgrading from glibc 2.1 to glibc 2.2

Using a RedHat 6.x distro, I have a lot of things updated:

kernel 2.2.19 with reiserfs
glibc 2.1.3
binutils 2.9.5
cpp 2.95
gcc 2.95
gcc-c++ 2.95
qt 2.3
Xfree 4.0.3
kde 2.1

As you can see above, I have upgraded gcc from 2.9.1 ( that came with
egcs ) to gcc 2.95 ( from libc6 contrib RPM ) due to a compiler bug that
I encounered compiling qt 2.3 with "march=i686".

However, I wanted to upgrade from kde 2.1 to kde 2.1.1. Since there are
no RPMs for RedHat6.x of kde 2.1.1, I downloaded the SRPMS and try to
build the RPMs and install them. Building kdesupport went okay ( with
"rpm -bb --target=i686 kdesupport-2.1.spec" ). Now I am trying to build
kdedoc with "rpm -bb --target=i686 kdedoc-2.1.1.spec". However, the
build requires perl 5.6.0, which in turn requires glibc 2.2.

With the exception of installing a new distro, I have not done a major
glibc upgrade. So my questions are:

1) Is it safe? Will the existing apps that were compiled, static or
shared, with glibc 2.1 still work with glibc 2.2? The only information I
can find about this is on the link below:

        http://www.imaxx.net/~thrytis/glibc/glibc-FAQ.html#2.3

... but it seems that the document is about a move from libc5  to libc6.
Is there a more updated version of this doc specifically for a move from
glibc 2.1 to glibc 2.2?

2) Has anyone with a RedHat 6.x distro done this, using the glibc-2.2
RPMS from rawhide?

Any help appreciated,

John
--
Homepage: http://homepages.tig.com.au/~jmsalvo/
Public Key:
http://pgp5.ai.mit.edu:11371/pks/lookup?op=get&search=0x51F47D34

2. Backup Strategies

3. Here's HOW-TO use vi command history with bash.

4. How to upgrade glibc 2.1 to 2.2

5. WordPerfect?

6. Upgrading from glibc 2.1 to 2.2?

7. GusMax and Linux

8. glibc 2.1 and glibc 2.2

9. glibc 2.1 -> 2.2 update issue

10. Can primary glibc 2.1.x coexist with non-primary glibc 2.2.x WRT shared binaries?

11. Problem during upgrade from 2.1 -> 2.2

12. upgrade kde 2.1 -> 2.2 - mouse no longer working