problem running Java Applets on linux - threads: cannot find class java/lang/Thread ????

problem running Java Applets on linux - threads: cannot find class java/lang/Thread ????

Post by John van der Ploe » Mon, 08 Oct 2001 09:39:38



I have a problem running Java Applets.
I'm running a SuSE7.2 based machine.

When accessing a page that has a simple "Hello World!" Java Applet
on it, the Konqueror window stays "Loading Applet".
When accessing the same page from another machne, it runs fine.

So... conclusion: the Applet is fine?

So now what is wrong?
I already checked some things.

In the browser, Settings->KonquerorBrowser->Java
I Do have: "Enable Java Globally" enabled,
I have Path to java executable to 'java'
And have not specified any Domain specific stuff

The 'java' points to:


/usr/lib/java/bin/java

This is a version 1.1.8:

java version "1.1.8"

So, IMHO, it seems that I DO have a working java. Don't I?

I also tried a different java, under: :/usr/lib/jdk1.3/jre/bin/java

java version "1.3.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0)
Java HotSpot(TM) Client VM (build 1.3.0, mixed mode)

But with similar results.

I tried starting Konqueror from the commandline, to see if it
complains.... Well it does, a little.


http://www.veryComputer.com/~jvdploe/*/johncamjava.cgi
kdecore (KProtocolManager): ERROR: Protocol  not found
Unable to initialize threads: cannot find class java/lang/Thread
kjas: ERROR: could not parse length out of:
kjas: ERROR: could not parse length out of:

BUT, I can not really understand what would be wrong.
It seems that the 'threads' error might be the clue....

Anyone who has a suggestion here?

Btw, I also tried Netscape's Java, but with similar restults.

    - John

--
John van der Ploeg
http://www.veryComputer.com/~jvdploe   (direct)
http://www.veryComputer.com/~jvdploe            (mirror op planet)

 
 
 

1. IBM JAVA problem panic: CL: Can't find class java.lang.NoClassDefFoundError IOT

Hi,

i can launch java full version "J2RE 1.2.2 IBM build ca122-20011213"      
but i can't launch any java program i have
*** panic: CL: Can't find class java.lang.NoClassDefFoundError.    
./xap1[29]: 40166 Interruption de IOT/Abandon(coredump)            
If i tried with JDK1.1.8 that is ok.
Could you say me where is my mistake

Thanks
Philippe

2. Shell Script Needed

3. java/47447: linux-sun-jdk1.4.1: java command can't find java.lang.Object

4. How do I get 16bpp color?

5. Java, Java, Java, Java, Java, Java .....

6. Apache HEADER and FOOTER

7. jdk1.3.1p4_1: java.lang.Process blocks Thread.sleep() and Object.wait()

8. virus protection SVR4.3

9. I cannot get tscroll java applet to run from Apache

10. Linux-Java-LimeWire-java.lang.NoClassDefFoundError:

11. Java Kernel Support can't find class in .class file

12. Problem with Java Native Threads in Linux

13. Java applet and Java plug-in