cannot link static using KDE 2.2.1 (Suse 7.3)

cannot link static using KDE 2.2.1 (Suse 7.3)

Post by mur » Sat, 02 Feb 2002 22:57:44



Hi, I am a newcomer to linux.

I want to link a static application.

I installed the complete Suse Linux 7.3 professional (7.3 GB on Harddisk).
When I enter the KDE-Desktop and make a new console-project using the
wizard, a "Hello World" application is made.
But the option "prevent using shared libraries" in project/options/linker
option does not work: I always get the same file length and ldd says:

libc.so.6 => /lib/libc.so.6 (0x40038000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

The compiler and linker is started with:
gcc -DHAVE_CONFIG -I. -I. -I.. -o0 -Wall -c main.c
/bin/sh  ../libtool  --mode=link gcc -o0 -Wall -static -o progname main.o
gcc -o0 -Wall -0 progname main.o

What do I make wrong? Or is there a bug in KDE?

Greetings
Ernst Murnleitner

 
 
 

1. cannot link static using KDE 2.2.1

Hi,

I am a newcomer to Linux. Recently I installed Suse Linux 7.3 completely
(the professional Version using 7.3 GB of disk space). When I make a new
project using the wizard and I make a terminal application, it happens with
both, C and C++ applications:

"prevent using shared libraries" in the options/linker dialog has no effect.
Though g++ (or gcc when making a C program) is called with the option
"-static", the programm links dynamically. Even the "Hello
world!"-application generated by the wizard. All .a libraries are present
(in the /usr/lib directory).

ldd programname says (in case of the C program):
libc.so.6 => lib/libc.so.6 (0x40038000)
/lib/ld-linux.lib.2 => /lib/ld-linux.so.2 (0x40000000)

What do I make wrong? Or is it a bug in the KDE or Suse 7.3?

The compiler and linker is called like this:
gcc -DHAVE_CONFIG_H -I. -I. -I..   -o0 -Wall -c main.c
/bin/sh ../libtool --mode=link  gcc -o0 -Wall -static -o programname main.o
gcc -o0 -Wall -o programname main.o

2. HP7200e - HEADACHE

3. A question on upgrading to KDE 3.0.1 from KDE 2.2.2 (SuSE 7.3)

4. Domains.... again... :)

5. KDE 2.2.2, SuSE 7.3: kio_help disfunctional

6. RedHat 6.1/PHP with MySQL support / mod_perl

7. SuSE 7.3 SPARC and KDE

8. IP Chains / IP Masq FTP Problem

9. No Font-AA in KDE 3.0.2 on SuSE 7.3

10. suse 7.3 kde 2.2.1 kppp question

11. Why is SuSE updates for 7.3 older than 7.3?

12. Help needed: Font Anti-Aliasing under SuSE Linux 7.3 (KDE 2.2.1) no longer works

13. KDE 3.x and SUSE 7.3 Pro?