gimp compilation broken,undefined reference to 'jpeg..'

gimp compilation broken,undefined reference to 'jpeg..'

Post by Jan Krup » Sun, 01 Jun 1997 04:00:00



[ gimp.error 1K ]

First of all I would like to thank all people who has tried to help me
compiling 'gimp'. Thanks to them I've moved on a little bit
but I have still new problem to compile gimp-0.9.99 from sources.

I have put all things from '.libs' into /usr/local/lib/
and I have installed 'jpeg-6a'.
I've type 'ldconfig' , then
cd /usr/local/gimp-0.9.99
change the three files 'Makefiles.in' from gtk+/gtk/, gtk+/gdk/, libgimp/
according the 'patch' I've received from somebody from the 'gimp mailing list'
then:
1 ../configure
2. make
(and I have got rid of the problem with -lglib, -lgtk, -lgdk
library: before the compilation was broken and I've got:
' -lglib no such file or directory')
but finally the compilation was broken again but much much later and
I've got the following message:
------
l/lib../gtk+/glib/.libs/lglib.so -L/X11R6/lib -lXext -lX11 -ljep -lc -lm
jpeg.o: In function 'load_image':
/usr/local/gimp-0.99.9/plug-ins/jpeg.c:281: undefined reference to 'jpeg_std_err
or'
/usr/local/gimp-0.99.9/plug-ins/jpeg.c:302: .......................'jpeg_destroy_
decompress
and similarly: ...jpeg.c:310:................jpeg_CreateDecompress
                  jpeg.c:314
                         ..
                         618.. (about in 20 lines were  errors)
make[2]: ***[jpeg] Error 1
make[2]: Leaving directory '/usr/local/gimp-0.99.9/plug-ins'
make[1]: *** [all-recursive] Error 1
make[1] leaving directory '/usr/local/gimp-0.99.9'

Could someone please suggest how to avoid this problem?

Jan Krupa

 
 
 

gimp compilation broken,undefined reference to 'jpeg..'

Post by E. You » Mon, 02 Jun 1997 04:00:00


 [trying to compile gimp 0.99.9]

Quote:> but finally the compilation was broken again but much much later and
> I've got the following message:
> ------
> l/lib../gtk+/glib/.libs/lglib.so -L/X11R6/lib -lXext -lX11 -ljep -lc -lm
> jpeg.o: In function 'load_image':

shouldn't -ljep be -ljpeg? Just a thought...

--
Edwin

 
 
 

gimp compilation broken,undefined reference to 'jpeg..'

Post by E. You » Mon, 02 Jun 1997 04:00:00


 [trying to compile gimp 0.99.9]

Quote:> but finally the compilation was broken again but much much later and
> I've got the following message:
> ------
> l/lib../gtk+/glib/.libs/lglib.so -L/X11R6/lib -lXext -lX11 -ljep -lc -lm
> jpeg.o: In function 'load_image':

shouldn't -ljep be -ljpeg? Just a thought...

--
Edwin

 
 
 

1. gimp compilation broken, undefined reference to 'jpeg..'

[ gimp.error 1K ]

First of all I would like to thank all people who has tried to help me
compiling 'gimp'. Thanks to them I've moved on a little bit
but I have still new problem to compile gimp-0.9.99 from sources.

I have put all things from '.libs' into /usr/local/lib/
and I have installed 'jpeg-6a'.
I've type 'ldconfig' , then
cd /usr/local/gimp-0.9.99
change the three files 'Makefiles.in' from gtk+/gtk/, gtk+/gdk/, libgimp/
according the 'patch' I've received from somebody from the 'gimp mailing list'
then:
1 ../configure
2. make
(and I have got rid of the problem with -lglib, -lgtk, -lgdk
library: before the compilation was broken and I've got:
' -lglib no such file or directory')
but finally the compilation was broken again but much much later and
I've got the following message:
------
l/lib../gtk+/glib/.libs/lglib.so -L/X11R6/lib -lXext -lX11 -ljep -lc -lm
jpeg.o: In function 'load_image':
/usr/local/gimp-0.99.9/plug-ins/jpeg.c:281: undefined reference to 'jpeg_std_err
or'
/usr/local/gimp-0.99.9/plug-ins/jpeg.c:302: .......................'jpeg_destroy_
decompress
and similarly: ...jpeg.c:310:................jpeg_CreateDecompress
                  jpeg.c:314
                         ..
                         618.. (about in 20 lines were  errors)
make[2]: ***[jpeg] Error 1
make[2]: Leaving directory '/usr/local/gimp-0.99.9/plug-ins'
make[1]: *** [all-recursive] Error 1
make[1] leaving directory '/usr/local/gimp-0.99.9'

Could someone please suggest how to avoid this problem?

Jan Krupa

2. kernel-2.4.2 and ax25-utils

3. undefined reference to `pw_crypt',undefined reference to `spw_unpack'

4. users cgi scripts?

5. Kernel Compilation Errors: 'undefined reference'

6. help with battle.net patch

7. Build breaks with undefined reference to '__bswap_32'

8. at -- Job Name

9. undefined reference to 'main', In function '__uClibc_main'..

10. GIMP undefined reference to `jpeg_CreateDecompress'

11. general compilation problem: undefined reference to `mcount'

12. Can't seem to fix `undefined reference to `stat'' and `undefined reference to `atexit''