Upgrading Kernels - Now Insmod fails...

Upgrading Kernels - Now Insmod fails...

Post by Eric Handbur » Fri, 11 Feb 2000 04:00:00



Hello,

   I am upgrading from kernel 2.0.36 to 2.2.5-15. I have a third-party
module which I cannot re-compile for the new kernel.
   When I try to 'insmod -f xxxx_module', I get a whole bunch of unresolved
symbols. Obviously, these are symbols from the 2.0.36.

   So my question is: how do I run the 2.2.5 kernel (which works fine), but
install a single module which was compiled using 2.0.36?

   Thanks for any help.  Eric.

 
 
 

Upgrading Kernels - Now Insmod fails...

Post by t.. » Sun, 13 Feb 2000 04:00:00




>   I am upgrading from kernel 2.0.36 to 2.2.5-15. I have a third-party
>module which I cannot re-compile for the new kernel.
>   When I try to 'insmod -f xxxx_module', I get a whole bunch of unresolved
>symbols. Obviously, these are symbols from the 2.0.36.

>   So my question is: how do I run the 2.2.5 kernel (which works fine), but
>install a single module which was compiled using 2.0.36?

Run the two different kernels on two different boxes.
Or recompile the module.

Linus allows but doesn't actively support binary-only modules for various
reasons. For details, check the following:

http://lwn.net/1999/0211/a/lt-binary.html or
http://lwn.net/1999/0211/a/lt-afs.html or
http://kt.linuxcare.com/kt19991227_48.epl#1

                -Daz.
--
Darren Tucker.          (dtucker at the domain zip dot com dot au)
A programmer is a device for converting caffeine into source code.

 
 
 

1. Upgrading Kernel - Now insmod fails...

Hello,

   I am upgrading from kernel 2.0.36 to 2.2.5-15. I have a third-party
module which I cannot re-compile for the new kernel.
   When I try to 'insmod -f xxxx_module', I get a whole bunch of unresolved
symbols. Obviously, these are symbols from the 2.0.36.

   So my question is: how do I run the 2.2.5 kernel (which works fine), but
install a single module which was compiled using 2.0.36?

   Thanks for any help.  Eric.

2. DiskSuite, Solstice - problem, help me !

3. Upgraded Kernels - now insmod fails...

4. can't open initial console

5. insmod: ipv6.o: insmod net-pf-10 failed

6. HELP installing from CD-ROM

7. Kernel 2.1.x fails to compile... and fails... and fails...

8. Where can I get OSF/MOTIF < V2.0 (= V1.x)

9. pump fails after upgrading kernel to 2.2.13

10. RedHat 4.2 upgrade--kernel build fails

11. can I still upgrade rh6.0 if rpm -i on kernel fails dependencies?

12. upgrading kernel to 2.2.10 failed.

13. kernel 4.1 upgrade - fail to boot again