apache www server with frontpage server extensions

apache www server with frontpage server extensions

Post by Marius Heule » Wed, 10 Sep 1997 04:00:00



Hello!

I run a web server using the apache server (version 1.1 and 1.2). Now we
need the frontpage server extensions on this server. I tried version 97
and 98beta of the server extension. But I always get segmentation faults
when executing fpsrvadm.exe and choosing to "recalculate links".
The other tools shtml.exe, admin.exe ... cause segmentation faults, too.
This problem seems to be related to the shared libraries I use.
If I install VERY old libraries (libc-5.2.18, libm-5.0.5, libstdc++-27.0.1
and libg++-27.0.1) it works fine. But most other programs on the server
cause problems with this old libraries.

If the server extensions work for someone, could you please tell me which
version of libraries you use and from which distribution you get this!

Thank you for your interest
Marius

--
#############################################################################
#  Marius Heuler   #  LinuX  -  The Choice of the Jilted Generation         #
#     |Rave|       # ------------------------------------------------------ #

# Computer Science #  http://www-info3.informatik.uni-wuerzburg.de/~heuler  #
#   Uni Wuerzburg  #        Don't believe the Hype - Use your Brain!        #
#############################################################################

 
 
 

apache www server with frontpage server extensions

Post by Henrik Storn » Thu, 11 Sep 1997 04:00:00



Quote:>I run a web server using the apache server (version 1.1 and 1.2). Now we
>need the frontpage server extensions on this server. I tried version 97
>and 98beta of the server extension. But I always get segmentation faults
>when executing fpsrvadm.exe and choosing to "recalculate links".
>The other tools shtml.exe, admin.exe ... cause segmentation faults, too.

Ah yes, the frontpage server extensions. Now there's a bunch of
buggy programming, if ever there was one. Besides, the documentation
on installing them is ... well, "hard to understand" is an under-
statement.

Someone - I have the URL at work - has figured out how to install
Frontpage server extensions so that

a) they work
b) they use the old libs (necessary for a)), but nothing else does.

You should be able to find it with DejaNews or some such, if you search

I'll send you the URL. I also have it all wrapped up in a couple of
RPM-files, in case anyone is interested.

--
Henrik Storner                               http://www.image.dk/~storner/
"The POP3 server service depends on the SMTP server service, which
 failed to start because of the following error:
 The operation completed successfully." -Windows NT Server v3.51

 
 
 

1. manual compile of frontpage extensions on apache server

I have 2 apache servers. Both on Solaris 2.5.1 Sparcs. The first one is
our production one that was manually compiled but frontpage does not
work with. The second one, I let the frontpage scripts compile and works
fine. Does anybody have any directions on the right way to compile it
manually?
***********

slash > ./httpd -l
Compiled-in modules:
  http_core.c
  mod_env.c
  mod_log_config.c
  mod_mime.c
  mod_negotiation.c
  mod_status.c
  mod_info.c
  mod_include.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_access.c
  mod_auth.c
  mod_auth_dbm.c
  mod_browser.c
  mod_frontpage.c
slash > ./httpd -v
Server version Apache/1.2.4.
slash >
**********
trainer# ./httpd -l
Compiled-in modules:
  http_core.c
  mod_env.c
  mod_log_config.c
  mod_mime.c
  mod_negotiation.c
  mod_include.c
  mod_dir.c
  mod_cgi.c
  mod_asis.c
  mod_imap.c
  mod_actions.c
  mod_userdir.c
  mod_alias.c
  mod_access.c
  mod_auth.c
  mod_frontpage.c
  mod_browser.c
trainer# ./httpd -v
Server version Apache/1.2.5 FrontPage/3.0.4.
trainer#

--

2. Can't use TAR successfully

3. Apache 1.3.9 + frontpage version 4 server extensions

4. WWW calendar system

5. Frontpage extensions on Apache Server/AIX

6. Changing from alone to multi-user mode.

7. OpenBSD 2.7, Apache and FrontPage 2000 Server Extensions???

8. Semaphore, semctl help needed

9. Apache 1.3.9 and FrontPage Server Extension

10. Apache 1.3 + FrontPage Server Extension

11. FrontPage 98 Server Extensions & Apache

12. Apache & FrontPage Server Extensions

13. Frontpage server extensions on Apache: problem with FollowSymlinks option