Insure Chaperon gives lots of errors

Insure Chaperon gives lots of errors

Post by Vsevolod Ilyushchenk » Wed, 29 Aug 2001 06:29:43



Hi,

When I am running a simple app under Insure's Chaperon, I get several
errors is glibc code and a bunch of errors in I/O and/or pthread-related
code. None of them surface if I use insure to compile the application. I am
running Redhat 7.1. Did anybody else have similar experience?

Thanks,
Simon
--
 _________    

| y = e   |                                    

                Disclaimer: This is not me.                    
        This is just my mailer talking to your mailer...

 
 
 

Insure Chaperon gives lots of errors

Post by Junping Zhan » Fri, 31 Aug 2001 03:54:21


I had similar experience, both under Chaperon and Insure++ on RH6.2. I think
insure++ is very aggressive when it's configured to do so and complains about
the "static" ( which is quite common) memory blocks in glibc ( strerror() and
localtime(), to name a few), you have to ignore some of them.

- Junping


> Hi,

> When I am running a simple app under Insure's Chaperon, I get several
> errors is glibc code and a bunch of errors in I/O and/or pthread-related
> code. None of them surface if I use insure to compile the application. I am
> running Redhat 7.1. Did anybody else have similar experience?

> Thanks,
> Simon
> --
>  _________

> | y = e   |

>                 Disclaimer: This is not me.
>         This is just my mailer talking to your mailer...


 
 
 

1. netstat -v gives transmit errors lots of deferred

We have a cluster (2-nodes) with "old" 10 Mbps Ethernet adapter
on an MCA machine.

Since at least 10 days, we have some bad network performances.
10 days ago, we replace an adapter on a node but both nodes have
the same problem.

When entering command "netstat -v", we have a lot of:
Transmit errors most of then "Deferred".

What does Deferred means, what are the reasons????

Edouard

_____
A few numbers given by netstat -v (since last boot):
51e6 packets  ,   7e9 bytes    ,    37e6 interrupts  ,
18e6 *transmit errors* (most of them deferred??)

2. Starting Apache: "__register_frame_info unresolved"

3. Oldest Mitsumi gives *lots* of timeout errors HELP

4. SOmething went wrong when installing my printer!

5. tinyX gives "xinit: Unknown error (errno 0): Client error." error and dies

6. Question...Enlightenment comes up with no key bindings or default buttons...

7. Lots of errors in .xsession-errors when launching xterm from kicker

8. transparent squid cache?

9. 'make dep' gives error - what gives?

10. glibc-2.1.2 gives me lots of headache

11. netstat -I gives LOTS of packets on loopback interface

12. Installing libc-5.2.18 gives me grief - LOTS of grief...

13. Install Error: Boot Disk Gives crc error