QT-Apps: Most crash when compiling with qt-3.0.4

QT-Apps: Most crash when compiling with qt-3.0.4

Post by Bert Speckel » Wed, 15 May 2002 18:04:07



Hi Developers who are using QT for their applications.

Just want to mention that on my computer (SuSE 7.2/KDE3) most of the
qt-application (kshowmail, kkeyled, ...) krash when I compile them with qt
version 3.0.4.

So: check your own apps!

Greetings
Bert.

 
 
 

QT-Apps: Most crash when compiling with qt-3.0.4

Post by Bernd Striede » Thu, 16 May 2002 04:02:27


Hi


> Hi Developers who are using QT for their applications.

> Just want to mention that on my computer (SuSE 7.2/KDE3) most of the
> qt-application (kshowmail, kkeyled, ...) krash when I compile them with qt
> version 3.0.4.

This might be due to different Qt versions saving their settings into the
same files under $HOME/.qt/. Some of the settings files contain plugin
paths. Sharing plugin paths might cause loading the wrong plugins, which
definitely causes crashes when using different g++ releases when compiling.
I had just mailed it to the qt-interest mailing list when reading your
message.

Bernd Strieder

 
 
 

1. KDE / QT apps : configure error with QT

Hi all, I am trying to add a plugin to kate (cppsymbolviewer) but I
always have a the following configure error (whatever the options, e.g.
--with-qt-dir=/usr/lib/qt3, or by setting QTDIR...), I'd like to mention
that is not specific to this program (same error for various apps):

checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library
qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

INFO :

# ldconfig -p | grep qt-mt
         libqt-mt.so.3.1 (libc6) => /usr/lib/qt3/lib/libqt-mt.so.3.1
         libqt-mt.so.3 (libc6) => /usr/lib/qt3/lib/libqt-mt.so.3
         libqt-mt.so (libc6) => /usr/lib/qt3/lib/libqt-mt.so

# g++ -v
Reading specs from /usr/lib/gcc-lib/i586-mandrake-linux-gnu/2.96/specs
gcc version 2.96 20000731 (Mandrake Linux 8.1 2.96-0.63.1mdk)

Does anybody have (at least) a guess on this problem?

2. XKB

3. QT-1.3 vs. QT-1.44 for compiling games

4. SIOCSIFADDR: No such device by booting

5. QT 3.0.5_x with opengl causes KDE apps(konsole) to crash

6. SCO Openserver Installation - URGENT

7. rather big Qt-apps

8. GDI-Printer

9. compiling KDE apps after qt-2.3.2 upgrade

10. trouble compiling Qt app - librio500_api

11. KDE-3.0.5 with QT-3.1, konsole crash

12. QT socket question, maybe qt signal/slot

13. KDEstudio -> checking for Qt... configure: error: Qt (>= 19991109) (libraries) not found.