Question on TCL/TK

Question on TCL/TK

Post by Dan Haske » Sat, 30 Aug 1997 04:00:00




>Hi there !

>Can anybody explain me what I have to do to generate a "beep" (ascii 7)
>at a X terminal (not in the shell where I start my program) ?

>The \a works only with the "puts" command to write to the stout.

>Andi

Tk's beep command should do the trick. I have noticed, however, it
doesn't seem to work under Window$95. Anyway, it works just fine in
Linux.

PS, comp.lang.tcl might be a better place to ask such questions.

--
Note my email address has been obscured to frustrate the spammer scum.
My actual address starts with Fesinc and ends with cris.com.

 
 
 

Question on TCL/TK

Post by Dan Haske » Sun, 31 Aug 1997 04:00:00




>>Can anybody explain me what I have to do to generate a "beep" (ascii 7)
>>at a X terminal (not in the shell where I start my program) ?

>>The \a works only with the "puts" command to write to the stout.

>>Andi

>Tk's beep command should do the trick. I have noticed, however, it

Ahem. I meant to say the "bell" command - not beep, bong, alarm, or
dingdong, but bell. I have to look the stupid name up everytime I use
it.

--
Note my email address has been obscured to frustrate the spammer scum.
My actual address starts with Fesinc and ends with cris.com.

 
 
 

Question on TCL/TK

Post by Andreas Heis » Tue, 02 Sep 1997 04:00:00





> >>Can anybody explain me what I have to do to generate a "beep" (ascii 7)
> >>at a X terminal (not in the shell where I start my program) ?

> >>The \a works only with the "puts" command to write to the stout.

> >>Andi

> >Tk's beep command should do the trick. I have noticed, however, it
> Ahem. I meant to say the "bell" command - not beep, bong, alarm, or
> dingdong, but bell. I have to look the stupid name up everytime I use
> it.

Thanks !
Works fine under Digital Unix 4.0 as well.
Andi
 
 
 

1. TK/tcl gurus: wrong version of Tk loaded (3.6): need 4.x?

Hi:

I'm trying to run tkHTML 2.3, and when it loads, it gives an error:

Tcl_AppInit failed: wrong version of Tk loaded (3.6): need 4.x

According to glint (I've installed RH 3.0.3), I've got tcl version
7.4-5 and tk version 4.0-5.  Why does tkHTML seem to think my tk is
version 3.6 and not 4.0?  

I'm not a tk/tcl guru nor do I play one on TV.  So if anyone out there
is, please let me know what I can do.  After it (tkHTML) loads, none
of the menus work, it's basically broken, and I get error messages like:

tkerror failed to handle background error.
    Original error: invalid command name "tk_butEnter"
    Error in tkerror: unknown option "-wraplength"
tkerror failed to handle background error.
    Original error: invalid command name "tk_butLeave"
    Error in tkerror: unknown option "-wraplength"
etc.

Thanks in advance for any info.

Mark

--
****************************************************************

Committee on Social Thought, University of Chicago

****************************************************************

2. PPP detection

3. Linux Tcl/Tk diffs in netcom.com: ~ftp/pub/yggdrasil/misc/tcl-diffs

4. capturing output from shell into a buffer

5. Plans for Tcl/Tk8.4 version of tksh (ksh93 + Tcl/Tk)?

6. Second Hand RS/6000's in UK?

7. RPM/Tcl-Tk Question: Right Upgrade Procedure?

8. Kproc Processes

9. question about tcl/tk

10. Tcl/tk question

11. TCL/Tk and TCP sockets question

12. Tcl/Tk 8.0b2 Install question, Linux 2.0.30

13. Newbie question: what is tcl/tk?