gtk+ wont install because of glib

gtk+ wont install because of glib

Post by Mark Leun » Tue, 23 Mar 1999 04:00:00



Hi,
I installed glib 1.2.0 successfully, but now gtk+ won't install. When I run
configure, the error is:

checking for glib-config... /usr/bin/glib-config
checking for GLIB - version >= 1.2.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for
the
*** exact error that occured. This usually means GLIB was incorrectly
installed
*** or that you have moved GLIB since it was installed. In the latter case,
you
*** may want to edit the glib-config script: /usr/bin/glib-config

I can see that glib-config is there, because a glib-config usage text
appears when it tries to find glib-config. I looked at the config.log, but
I don't know what it means. Here it is:

configure:4608: checking for glib-config
configure:4643: checking for GLIB - version >= 1.2.0
configure:4742: gcc -o conftest -g -O2 -Wall    conftest.c   1>&5
In file included from configure:4668:
/usr/local/include/glib.h:66: glibconfig.h: No such file or directory
configure: failed program was:
#line 4666 "configure"
#include "confdefs.h"
#include <glib.h>
#include <stdio.h>
#include <stdlib.h>

Anybody know why I can't install gtk+?
Thanks

------------------  Posted via SearchLinux  ------------------
                  http://www.searchlinux.com

 
 
 

gtk+ wont install because of glib

Post by NF Steve » Tue, 23 Mar 1999 04:00:00



>Hi,
>I installed glib 1.2.0 successfully, but now gtk+ won't install. When I run
>configure, the error is:

>checking for glib-config... /usr/bin/glib-config
>checking for GLIB - version >= 1.2.0... no
>*** Could not run GLIB test program, checking why...
>*** The test program failed to compile or link. See the file config.log for

Running "glib-config --cflags" should give an output something like

-I/usr/local/lib/glib/include -I/usr/local/include

Check in the directories listed for the file glibconfig.h

"glib-config --version" will print the version (which should
be 1.2.0). If you have an older version of glib-config then
this would indicate that a previous installation of glib
has not been removed and is causing conflicts.

Norman

 
 
 

gtk+ wont install because of glib

Post by Pete Blac » Wed, 24 Mar 1999 04:00:00


i got the same, or very similar problem here.

i tried compiling gtk forcing it to use the glib in ../glib-1.2.0/ (i
forget the precise syntax i used) and it got a lot further but still
arsed out before completion.

Any ideas?


> Hi,

> I installed glib 1.2.0 successfully, but now gtk+ won't install. When I run

> configure, the error is:

> checking for glib-config... /usr/bin/glib-config

> checking for GLIB - version >= 1.2.0... no

> *** Could not run GLIB test program, checking why...

> *** The test program failed to compile or link. See the file config.log for

> the

> *** exact error that occured. This usually means GLIB was incorrectly

> installed

> *** or that you have moved GLIB since it was installed. In the latter case,

> you

> *** may want to edit the glib-config script: /usr/bin/glib-config

> I can see that glib-config is there, because a glib-config usage text

> appears when it tries to find glib-config. I looked at the config.log, but

> I don't know what it means. Here it is:

> configure:4608: checking for glib-config

> configure:4643: checking for GLIB - version >= 1.2.0

> configure:4742: gcc -o conftest -g -O2 -Wall    conftest.c   1>&5

> In file included from configure:4668:

> /usr/local/include/glib.h:66: glibconfig.h: No such file or directory

> configure: failed program was:

> #line 4666 "configure"

> #include "confdefs.h"

> #include <glib.h>

> #include <stdio.h>

> #include <stdlib.h>

> Anybody know why I can't install gtk+?

> Thanks

> ------------------  Posted via SearchLinux  ------------------
>                   http://www.searchlinux.com

 
 
 

gtk+ wont install because of glib

Post by F. Guillau » Wed, 24 Mar 1999 04:00:00


Hello World,

    I assume you're working with tgz-archives of glib & gtk.

 You need to compil and *install* the new glib before compiling gtk 1.2.
You also need to update info from the dynamic linker with
/sbin/ldconfig. Then compil gtk 1.2.

           Hope this helps.

                                  Franck.


> i got the same, or very similar problem here.

> i tried compiling gtk forcing it to use the glib in ../glib-1.2.0/ (i
> forget the precise syntax i used) and it got a lot further but still
> arsed out before completion.

> Any ideas?


> > Hi,

> > I installed glib 1.2.0 successfully, but now gtk+ won't install. When I run

> > configure, the error is:

> > checking for glib-config... /usr/bin/glib-config

> > checking for GLIB - version >= 1.2.0... no

> > *** Could not run GLIB test program, checking why...

> > *** The test program failed to compile or link. See the file config.log for

> > the

> > *** exact error that occured. This usually means GLIB was incorrectly

> > installed

> > *** or that you have moved GLIB since it was installed. In the latter case,

> > you

> > *** may want to edit the glib-config script: /usr/bin/glib-config

> > I can see that glib-config is there, because a glib-config usage text

> > appears when it tries to find glib-config. I looked at the config.log, but

> > I don't know what it means. Here it is:

> > configure:4608: checking for glib-config

> > configure:4643: checking for GLIB - version >= 1.2.0

> > configure:4742: gcc -o conftest -g -O2 -Wall    conftest.c   1>&5

> > In file included from configure:4668:

> > /usr/local/include/glib.h:66: glibconfig.h: No such file or directory

> > configure: failed program was:

> > #line 4666 "configure"

> > #include "confdefs.h"

> > #include <glib.h>

> > #include <stdio.h>

> > #include <stdlib.h>

> > Anybody know why I can't install gtk+?

> > Thanks

> > ------------------  Posted via SearchLinux  ------------------
> >                   http://www.searchlinux.com