TK/tcl gurus: wrong version of Tk loaded (3.6): need 4.x?

TK/tcl gurus: wrong version of Tk loaded (3.6): need 4.x?

Post by Mark Shacklett » Sun, 26 May 1996 04:00:00



Hi:

I'm trying to run tkHTML 2.3, and when it loads, it gives an error:

Tcl_AppInit failed: wrong version of Tk loaded (3.6): need 4.x

According to glint (I've installed RH 3.0.3), I've got tcl version
7.4-5 and tk version 4.0-5.  Why does tkHTML seem to think my tk is
version 3.6 and not 4.0?  

I'm not a tk/tcl guru nor do I play one on TV.  So if anyone out there
is, please let me know what I can do.  After it (tkHTML) loads, none
of the menus work, it's basically broken, and I get error messages like:

tkerror failed to handle background error.
    Original error: invalid command name "tk_butEnter"
    Error in tkerror: unknown option "-wraplength"
tkerror failed to handle background error.
    Original error: invalid command name "tk_butLeave"
    Error in tkerror: unknown option "-wraplength"
etc.

Thanks in advance for any info.

Mark

--
****************************************************************

Committee on Social Thought, University of Chicago

****************************************************************

 
 
 

1. XF2.3 and tcl 7.3 & tk 3.6

I've managed to compile/install xf2.3 but the man pages/help files are
giving me trouble, each makeAdd3.x etc. seems not find any *.H files in the
source tree. I am running tcl7.3 and tk3.6 - is this problem ? Too recent ?

Any help would be appreciated.

S.
--
_________________________________________________________________________
Steven M. Hill                                  Mostly Aardvark Media Lab

2. Shared Memeory size on V.4 and BSD

3. Wish(TCL/Tk 3.6 )

4. Matrox G200 Video cards

5. tcl/tk/tclx 7.3,3.6

6. What's that character called???

7. Problems recompiling tcl/tk for Sicstus 3.6 on a RH 5.2

8. My beloved NIC...

9. Wish(TCL/Tk 3.6 )

10. Plans for Tcl/Tk8.4 version of tksh (ksh93 + Tcl/Tk)?

11. tkHTML loading wrong tk version??

12. tkHTML - need tk 3.6, got 4.0 => won't work!!!