open source is getting worst with time.

open source is getting worst with time.

Post by stev » Mon, 25 Dec 2000 17:13:44



Ok, I wanted to try this program that is supposed to be good.

When I tried to install AbiWord using rpm, I get the error

"only packages with major numbers <= 3 are supported by this version of RPM"

Ok, after searching the net, I found rpm version 4 out there
(I was using rpm 3.0.3). So, I download rpm for rpm 4.0, but
when I try to install rpm 4.0 using my current rpm, I also get
the same error.

So, I search the net again, and I find someone saying that rpm 3.0.5
will not give the above error. So, I search for rpm 3.0.5 and downdownload
the rpm file for it.

I rpm -Uhv it, but I get dependcy error, it wanted these

error: failed dependencies:
        textutils   is needed by rpm-3.0.5-9.6x
        sh-utils   is needed by rpm-3.0.5-9.6x
        bzip2 >= 0.9.0c-2 is needed by rpm-3.0.5-9.6x
        libbz2.so.0 is needed by rpm-3.0.5-9.6x

Ok, so I hit the net again searching for textutils, I download
it, then I do

root>rpm -Uhv textutils-2.0g-1.i386.rpm
only packages with major numbers <= 3 are supported by this version of RPM
error: textutils-2.0g-1.i386.rpm cannot be installed
root>

Ok, so to update my rpm, I need an rpm that needs a packages that
will not install with my current rpm.

This is so amazing. NO wonder 90% of the world uses windows.

On windows, I never had such idiotic installation problems. never.

back to windows, you guys can keep this junk.

it is true what they say, linux is for those whose time is worthless.
It has been years, and this system is still as hard to install
programs for as ever, I thought maybe after all this time, someone
would have fixed this crap. But I was wrong.

 
 
 

open source is getting worst with time.

Post by Darren Winspe » Mon, 25 Dec 2000 20:02:44



> Ok, so to update my rpm, I need an rpm that needs a packages that will
> not install with my current rpm.

> This is so amazing. NO wonder 90% of the world uses windows.

> On windows, I never had such idiotic installation problems. never.

> back to windows, you guys can keep this junk.

Oh dear, you really did have a few problems.  Oh well, let's see what
happens when I want to install abiword:

apt-get install abiword
Press return a couple of times
Done

Now, why did I want abiword again?  Oh yeah, I didn't, I just wanted to
prove that Linux needn't be as bad as Steve portrays.

 
 
 

open source is getting worst with time.

Post by stev » Mon, 25 Dec 2000 20:57:49



Quote:

>Oh dear, you really did have a few problems.  Oh well, let's see what
>happens when I want to install abiword:

>apt-get install abiword
>Press return a couple of times
>Done

>Now, why did I want abiword again?  Oh yeah, I didn't, I just wanted to
>prove that Linux needn't be as bad as Steve portrays.

apt-get install abiword
bash: apt-get: command not found

now, which rpm I need to install this apt-get thing so I can
install abiword which my rpm could install becuase the abiword
package I allready have needed an newer rpm program that needed
a package that needed the newer rpm to install?

 
 
 

open source is getting worst with time.

Post by Yati » Mon, 25 Dec 2000 21:58:57



Quote:

>apt-get install abiword
>bash: apt-get: command not found

>now, which rpm I need to install this apt-get thing so I can
>install abiword which my rpm could install becuase the abiword
>package I allready have needed an newer rpm program that needed
>a package that needed the newer rpm to install?

You need to be running either debian or a debian based system like Storm
Linux or Libranet in order to use apt (although I hear they are porting
it to rpm based distributions so you may be in luck soon).

--
yatima

 
 
 

open source is getting worst with time.

Post by Nick Ruis » Mon, 25 Dec 2000 22:32:13


rpm -i --force --nodeps

The software might not work after install, though.

 
 
 

open source is getting worst with time.

Post by matt newel » Mon, 25 Dec 2000 21:14:23



> Ok, I wanted to try this program that is supposed to be good.

> When I tried to install AbiWord using rpm, I get the error

> "only packages with major numbers <= 3 are supported by this version of RPM"

> Ok, after searching the net, I found rpm version 4 out there
> (I was using rpm 3.0.3). So, I download rpm for rpm 4.0, but
> when I try to install rpm 4.0 using my current rpm, I also get
> the same error.

> So, I search the net again, and I find someone saying that rpm 3.0.5
> will not give the above error. So, I search for rpm 3.0.5 and downdownload
> the rpm file for it.

> I rpm -Uhv it, but I get dependcy error, it wanted these

> error: failed dependencies:
>         textutils   is needed by rpm-3.0.5-9.6x
>         sh-utils   is needed by rpm-3.0.5-9.6x
>         bzip2 >= 0.9.0c-2 is needed by rpm-3.0.5-9.6x
>         libbz2.so.0 is needed by rpm-3.0.5-9.6x

> Ok, so I hit the net again searching for textutils, I download
> it, then I do

> root>rpm -Uhv textutils-2.0g-1.i386.rpm
> only packages with major numbers <= 3 are supported by this version of RPM
> error: textutils-2.0g-1.i386.rpm cannot be installed
> root>

> Ok, so to update my rpm, I need an rpm that needs a packages that
> will not install with my current rpm.

> This is so amazing. NO wonder 90% of the world uses windows.

> On windows, I never had such idiotic installation problems. never.

> back to windows, you guys can keep this junk.

> it is true what they say, linux is for those whose time is worthless.
> It has been years, and this system is still as hard to install
> programs for as ever, I thought maybe after all this time, someone
> would have fixed this crap. But I was wrong.

Linux is all about options, you could

A.  Use Debian - No more rpms
B.  Compile from source - This results in faster programs that are optimized
for your computer
C.  kindly ask that package maintainer to use rpm version < 4 - This may work.

There will always be stumbling blocks in our lives, don't curse at the men
building the steps, help them out.

I relize that linux is not perfect, but I have rock solid opengl drivers,
anti-aliased text in all my applications(looks great), a browser that is
faster and more complient than IE(konqueror), a kernel that NEVER crashes, and
an obsolutely wonderfull set of applications provided by KDE.  None of these
things were available a year ago, so I don't see how you can justify that open
source is getting worse with time.

Matt Newell

 
 
 

open source is getting worst with time.

Post by Vann » Tue, 26 Dec 2000 03:21:54



> Ok, I wanted to try this program that is supposed to be good.

> When I tried to install AbiWord using rpm, I get the error

> "only packages with major numbers <= 3 are supported by this version of
> RPM"

> Ok, after searching the net, I found rpm version 4 out there
> (I was using rpm 3.0.3). So, I download rpm for rpm 4.0, but
> when I try to install rpm 4.0 using my current rpm, I also get the same
> error.

> So, I search the net again, and I find someone saying that rpm 3.0.5
> will not give the above error. So, I search for rpm 3.0.5 and
> downdownload the rpm file for it.

> I rpm -Uhv it, but I get dependcy error, it wanted these

> error: failed dependencies:
>         textutils   is needed by rpm-3.0.5-9.6x sh-utils   is needed by
>         rpm-3.0.5-9.6x bzip2 >= 0.9.0c-2 is needed by rpm-3.0.5-9.6x
>         libbz2.so.0 is needed by rpm-3.0.5-9.6x

> Ok, so I hit the net again searching for textutils, I download it, then
> I do

> root>rpm -Uhv textutils-2.0g-1.i386.rpm only packages with major numbers
> <= 3 are supported by this version of RPM error:
> textutils-2.0g-1.i386.rpm cannot be installed root>

> Ok, so to update my rpm, I need an rpm that needs a packages that will
> not install with my current rpm.

> This is so amazing. NO wonder 90% of the world uses windows.

> On windows, I never had such idiotic installation problems. never.

> back to windows, you guys can keep this junk.

> it is true what they say, linux is for those whose time is worthless. It
> has been years, and this system is still as hard to install programs for
> as ever, I thought maybe after all this time, someone would have fixed
> this crap. But I was wrong.

RPM is sort of like that.  Use Debian where you can just use apt-get, as
another poster pointed out.  Personally, I compile everything from
source.  I have _less_ trouble with that than dealing with RPMs when they
are pre-compiled.  Oh well, I never liked the RPM system, anyhow, nor did
I like Mandrake and RedHat.  Please don't think that RPM is the only
package management system.
 
 
 

open source is getting worst with time.

Post by sfcybea » Tue, 26 Dec 2000 04:17:21


Funny, my Mandrake 7.2 comes with AbiWord that installs at the time of
install and runs just great. I notice that you did not mention what
distribution or distro version you were using. Could it be that the
version you are using is hopelessly out of date?



Quote:

> Ok, I wanted to try this program that is supposed to be good.

> When I tried to install AbiWord using rpm, I get the error

> "only packages with major numbers <= 3 are supported by this version
of RPM"

> Ok, after searching the net, I found rpm version 4 out there
> (I was using rpm 3.0.3). So, I download rpm for rpm 4.0, but
> when I try to install rpm 4.0 using my current rpm, I also get
> the same error.

> So, I search the net again, and I find someone saying that rpm 3.0.5
> will not give the above error. So, I search for rpm 3.0.5 and
downdownload
> the rpm file for it.

> I rpm -Uhv it, but I get dependcy error, it wanted these

> error: failed dependencies:
>         textutils   is needed by rpm-3.0.5-9.6x
>         sh-utils   is needed by rpm-3.0.5-9.6x
>         bzip2 >= 0.9.0c-2 is needed by rpm-3.0.5-9.6x
>         libbz2.so.0 is needed by rpm-3.0.5-9.6x

> Ok, so I hit the net again searching for textutils, I download
> it, then I do

> root>rpm -Uhv textutils-2.0g-1.i386.rpm
> only packages with major numbers <= 3 are supported by this version of
RPM
> error: textutils-2.0g-1.i386.rpm cannot be installed
> root>

> Ok, so to update my rpm, I need an rpm that needs a packages that
> will not install with my current rpm.

> This is so amazing. NO wonder 90% of the world uses windows.

> On windows, I never had such idiotic installation problems. never.

> back to windows, you guys can keep this junk.

> it is true what they say, linux is for those whose time is worthless.
> It has been years, and this system is still as hard to install
> programs for as ever, I thought maybe after all this time, someone
> would have fixed this crap. But I was wrong.

Sent via Deja.com
http://www.deja.com/
 
 
 

open source is getting worst with time.

Post by stev » Tue, 26 Dec 2000 03:54:59



Quote:

>rpm -i --force --nodeps

>The software might not work after install, though.

root>rpm -i --force --nodeps rpm-4.0.2-0.7.i386.rpm
only packages with major numbers <= 3 are supported by this version of RPM
error: rpm-4.0.2-0.7.i386.rpm cannot be installed
root>

root>rpm -i --force --nodeps  textutils-2.0g-1.i386.rpm
only packages with major numbers <= 3 are supported by this version of RPM
error: textutils-2.0g-1.i386.rpm cannot be installed
root>

 
 
 

open source is getting worst with time.

Post by Craig Kelle » Tue, 26 Dec 2000 05:11:49



> Ok, I wanted to try this program that is supposed to be good.

> When I tried to install AbiWord using rpm, I get the error

> "only packages with major numbers <= 3 are supported by this version of RPM"

> Ok, after searching the net, I found rpm version 4 out there
> (I was using rpm 3.0.3). So, I download rpm for rpm 4.0, but
> when I try to install rpm 4.0 using my current rpm, I also get
> the same error.

> So, I search the net again, and I find someone saying that rpm 3.0.5
> will not give the above error. So, I search for rpm 3.0.5 and downdownload
> the rpm file for it.

> I rpm -Uhv it, but I get dependcy error, it wanted these

> error: failed dependencies:
>         textutils   is needed by rpm-3.0.5-9.6x
>         sh-utils   is needed by rpm-3.0.5-9.6x
>         bzip2 >= 0.9.0c-2 is needed by rpm-3.0.5-9.6x
>         libbz2.so.0 is needed by rpm-3.0.5-9.6x

> Ok, so I hit the net again searching for textutils, I download
> it, then I do

Funny, just click on gnorpm and pick abiword -- it does all this for
you.  But, if you insist on using the wrong tool for hte job then go
ahead.

Gnorpm is an example; there are several such tools including rpmfind,
which will do dependencies.

Now, how to I update my Windows 2000 machine from the command line
again?  Remotely?

I thought not.

--
The wheel is turning but the hamster is dead.


 
 
 

open source is getting worst with time.

Post by stev » Tue, 26 Dec 2000 05:19:29



Quote:>Could it be that the
>version you are using is hopelessly out of date?

SuSe 6.3 (I know, it is really OLD, may be 6 months old by now,
which in the linux world, comes to 5000 years).

funny, that I had win95 for 5 years before I upgraded, and in
all that time, never had an application not install becuase
it needed something else to be there before it installed.

only on linux is installing a program a chore.

give linux 10 more years, may be they'll figure what the end
user needs are.

 
 
 

open source is getting worst with time.

Post by pip » Tue, 26 Dec 2000 06:21:09




> >Could it be that the
> >version you are using is hopelessly out of date?

> SuSe 6.3 (I know, it is really OLD, may be 6 months old by now,
> which in the linux world, comes to 5000 years).

If you are having loads of problems with the way a particular
distribution does things then you can always switch to another.

Quote:> funny, that I had win95 for 5 years before I upgraded, and in
> all that time, never had an application not install becuase
> it needed something else to be there before it installed.

No you are correct. They just do a forced install leading to many other
problems, especially with dll's.

Quote:> only on linux is installing a program a chore.

You are correct - installing can be a chore and it is not as easy as in
Windows.
As other people have pointed out though, in Linux you have a number of
choices in how to install programs - so why don't you try another way?

Quote:> give linux 10 more years, may be they'll figure what the end
> user needs are.

Try 5. Very neat things are happening all the time and people are
figuring out that non-guru users need a little more hand holding.
 
 
 

open source is getting worst with time.

Post by David Steinbe » Tue, 26 Dec 2000 06:36:26


: Ok, I wanted to try this program that is supposed to be good.
: When I tried to install AbiWord using rpm, I get the error
: "only packages with major numbers <= 3 are supported by this version of RPM"

I can see from the tone of this posting and subsequent postings in the
thread that you're more interested in bashing Linux than finding a
solution to your problem, but I'd like to try to help you solve your
problem anyway.

Where did you get this rpm of AbiWord?  Instead of updating your RPM
system, let's look for an rpm of AbiWord that was built for your
system.  Later on, you say that you're running...

: SuSe 6.3 (I know, it is really OLD, may be 6 months old by now,
: which in the linux world, comes to 5000 years).

Knowing that AbiWord is a GNOME application, I think, "Helix Code has
packages of just about every GNOME application for just about every
distribution out there."

I head over to their website (http://www.helixcode.com), and find the
following AbiWord package for SuSE 6.3:
http://spidermonkey.helixcode.com/distributions/SuSE/abisuite-0.7.11-...

If you find you have dependency problems, don't just look for the first
RPM you find on the 'net.  Try to find packages for your version of your
distribution.  Start with the distribution itself (ie. look at your CD's
or on SuSE's web site), and if they don't have it, look for packages from
the project's authors or packagers, or rpmfind, that were built for your
distribution (example: for other GNOME packages look back at Helixcode --
their complete set of packages for SuSE 6.3 can be found at
http://www.helixcode.com/desktop/packages.php3?distribution=suse&mirr...

Hope this helps.

--
David Steinberg                             -o)
Computer Engineering Undergrad, UBC         / \

 
 
 

open source is getting worst with time.

Post by stev » Tue, 26 Dec 2000 05:53:51



Quote:

>Funny, just click on gnorpm and pick abiword -- it does all this for
>you.

#gnorpm
bash: gnorpm: command not found

which rpm do I need to download to install gnorpm so I can install
abiword becuase my current rpm will not install a package that
I needed to upgrade my current rpm version to a newer version
so I can install abiword with the newer rpm version?

Quote:> But, if you insist on using the wrong tool for hte job then go
>ahead.

RPM is now the wrong tool for the job? interesting. If it is wrong,
why give to the user to use? to tourture them?

Quote:>Gnorpm is an example; there are several such tools including rpmfind,
>which will do dependencies.

yes, smarty. I use rpmfind. HOw else you think I find all those
rpm packages then?

Quote:>Now, how to I update my Windows 2000 machine from the command line
>again?  Remotely?

oh , pleeeese. what a cop out.  I am trying to install a program, and
you tell me about the power of linix remote update.  it can't even
do a local simple program installation.

you linux geeks are so out of it, it is scary.

 
 
 

open source is getting worst with time.

Post by stev » Tue, 26 Dec 2000 08:21:51



says...

Quote:

>I can see from the tone of this posting and subsequent postings in the
>thread that you're more interested in bashing Linux than finding a
>solution to your problem,

typical response. when someone whows how bad something in linux is,
it is called bashing.

Quote:>I head over to their website (http://www.helixcode.com), and find the
>following AbiWord package for SuSE 6.3:
>http://spidermonkey.helixcode.com/distributions/SuSE/abisuite-0.7.11-...

That is an OLD package. I wanted 0.7.12, not 0.7.11.

If you go to http://www.gnome.org you will see that 0.7.11 is old and
newer one exist. But the new one I can't install becuase it needs a new
rpm version that my current rpm will not install becuase I can't install
a package that the new rpm needs, becuase the package needs the
new rpm to install it which my old rpm can;t install.

Quote:>Hope this helps.

No, it does not help.  

You are missing the forest by looking at the trees. The problem
is more fundemental that just this one application. The whole design
of application installation system is broke on linux.

do you expect my grandmother to download and compile from source the
200,000 lines of code?

someone said to try apt-get, so I need to install a new flavour of
Linux for this. Aother said rpm is the wrong tool, andother said to
try debian, and you point to old package to install, and someone says
to download the tar files and install from source.

all this just to install an application.

no wonder linux will never make it to the desktop. Given that the
most basic task of an easy to use installation system does not
exist, how can linux ever hope that john does, who knows nothing about
computers, deal with all this crap?