Net-tools 1.50 and Kernel 2.0.29 - Compiler Error?

Net-tools 1.50 and Kernel 2.0.29 - Compiler Error?

Post by Avi Kivit » Tue, 04 May 1999 04:00:00



Net-tools 1.50 will not compile with my kernel, complaining that
linux/pkt_sched.h is missing (file lib/utils.c, line 29). Is this a problem
with configuration, or am I missing a file, or is net-tools broken?
 
 
 

Net-tools 1.50 and Kernel 2.0.29 - Compiler Error?

Post by Paul Kimo » Tue, 04 May 1999 04:00:00



> Net-tools 1.50 will not compile with my kernel, complaining that
> linux/pkt_sched.h is missing (file lib/utils.c, line 29). Is this a problem
> with configuration, or am I missing a file, or is net-tools broken?

The README file in net-tools-1.51 says:

: You need kernel 2.0 or later to use these programs.  These programs
: should compile cleanly with either glibc or libc5.  The `iptunnel' and
: `ipmaddr' programs require kernel version 2.2 or later.

and

: Some configuration options require recent 2.1.x or 2.2.x kernels
: and/or particular versions of the C library.  The defaults should be
: safe for all common environments but some of the more esoteric
: hardware and protocol families may be more touchy.  Feel free to send
: patches if you have problems.

--


 
 
 

Net-tools 1.50 and Kernel 2.0.29 - Compiler Error?

Post by Avi Kivit » Tue, 04 May 1999 04:00:00




>> Net-tools 1.50 will not compile with my kernel, complaining that
>> linux/pkt_sched.h is missing (file lib/utils.c, line 29). Is this a
problem
>> with configuration, or am I missing a file, or is net-tools broken?

>The README file in net-tools-1.51 says:

>: You need kernel 2.0 or later to use these programs.  These programs
>: should compile cleanly with either glibc or libc5.  The `iptunnel' and
>: `ipmaddr' programs require kernel version 2.2 or later.

Didn't ask for them

Quote:>and

>: Some configuration options require recent 2.1.x or 2.2.x kernels
>: and/or particular versions of the C library.  The defaults should be
>: safe for all common environments but some of the more esoteric
>: hardware and protocol families may be more touchy.  Feel free to send
>: patches if you have problems.

Turned out I could use what I had before, thanks anyway.
 
 
 

1. symbols from kernel 2.0.29 don't match 2.0.29?!?!?

I just upgraded my linux 1.2.13 to 2.0.29 using upgrade in a box...
everything seemed to compile fine, however all of my loadable modules are
giving me the error:
Failed to load module! The symbols from kernel 2.0.29 don't match 2.0.29
This is becoming a little more than a nuisance.
I boot from loadlin using the zImage that I compiled with the modules,
and I load the modules using insmod (I've tried from both the command
line, and from my rc files) I have tried loading them with a kernel with
CONFIG_MODVERSIONS on and again with it set off, and I still keep getting
the same error.
Any suggestions?

2. X Error: Popup 'Games' not defined...

3. 2.0.29 modules cannot be loaded by 2.0.29 kernel??????

4. idprio problems

5. Module net-pf-5 (Kernel 2.0.29)

6. Report Corel Piracy! 1-888 761 6907

7. 2.0.29 Kernel: [misc.o] Error 1

8. Mystique

9. Kernel 2.0.29 and wierd TCP error message

10. Compiling Kernel 2.0.29 - error

11. Compiling Kernel 2.0.29 (error).

12. error while booting after kernel [2.0.29] compiled

13. ERROR - bad inode number 0 - kernel 2.0.29 using Adaptec 2940