2.0.33 kernel building problems

2.0.33 kernel building problems

Post by Alex Buel » Sun, 15 Feb 1998 04:00:00



Guys,

I'm getting a strange error that never happened before and I have built
kernels successfully in the past - but following accidental loss of a hard
disk I rebuilt my system, and then once was up and running, I attempted to
recompile the kernel again.

I'm using binutils-2.8.1.0.15, gcc 2.7.2.3, ld.so.1.9.5 on this system.
Kernel source used is 2.0.33.

make[1]: Entering directory `/usr/src/linux-2.0.33/arch/i386/boot'
gcc -D__KERNEL__ -I/usr/src/linux/include -E -D__ELF__ -traditional
-DSVGA_MODE=NORMAL_VGA  bootsect.S -o bootsect.s
as86 -0 -a -o bootsect.o bootsect.s
make[1]: as86: Command not found
make[1]: *** [bootsect.o] Error 127
make[1]: Leaving directory `/usr/src/linux-2.0.33/arch/i386/boot'
make: *** [zlilo] Error 2

I tried making a symbolic link for as86->as, but it didn't work either -
said "-0" was invalid parameter. :/

Any ideas?

Cheers,
Alex
--
 /\_/\  Make the police happy,
( o.o ) Smoke some * today!
 > ^ <  Peace, Love, Unity and Respect to all.

http://www.veryComputer.com/

 
 
 

2.0.33 kernel building problems

Post by Frank Sweetse » Sun, 15 Feb 1998 04:00:00



> as86 -0 -a -o bootsect.o bootsect.s
> make[1]: as86: Command not found

you need to install as86, an x86 assembler that outputs code for real-mode
instead of protected mode.  it's part of the bin86 package, you should be
able to find it on sunsite.

--
Frank Sweetser rasmusin at wpi.edu fsweetser at blee.net | PGP key available
paramount.res.wpi.net RH 5.0 kernel 2.0.33/2.1.85   i586 | at public servers
"Where's the ladies' sty?  I desperately need to powder my snout."
                              -- Wally's Elbonian Mail-Order Bride

 
 
 

2.0.33 kernel building problems

Post by Alex Buel » Mon, 16 Feb 1998 04:00:00



Quote:> > as86 -0 -a -o bootsect.o bootsect.s
> > make[1]: as86: Command not found

> you need to install as86, an x86 assembler that outputs code for real-mode
> instead of protected mode.  it's part of the bin86 package, you should be
> able to find it on sunsite.

Aha! Thank you, Frank, you have solved the remaining problem I was having
with my system. All lights green! :o)

Cheers,
Alex
--
 /\_/\  Make the police happy,
( o.o ) Smoke some * today!
 > ^ <  Peace, Love, Unity and Respect to all.

http://www.veryComputer.com/

 
 
 

1. error building kernel 2.0.33

I've been trying to build a new kernel for my Red Hat linux
system to give myself ppp support.  I initially tried with my
current version (2.0.18), but had some errors on compilation.
I've now got the source for version 2.0.33, which I have been told
is stable.  That along with pppd version 2.0.0f.  However, I am still
getting errors when I build.  This is the error I am constantly
receiving when i "make zImage":

make [2]: Entering directory '/usr/src/linux-2.0.33/drivers/net'
make all targets
make [3]: Entering directory '/usr/src/linux-2.0.33/drivers/net'
gcc -D__KERNEL__ -I/usr/src/linux-2.0.33/include -Wall -Wstrict-prototypes -02
-fomit-frame-pointer -fno-strength-reduce -pipe -m486 -malign-loops=2 -malign-
jumps=2 -malign-functions=2 -DCPU=586 -c -o ppp.o ppp.c
ppp.c In function 'ppp_dev_xmit':
ppp.c: 3104: too few arguments to function 'dev_kfree_skb'
ppp.c: 3115: too few arguments to function 'dev_kfree_skb'
ppp.c: 3128: too few arguments to function 'dev_kfree_skb'
ppp.c: 3169: too few arguments to function 'dev_kfree_skb'
ppp.c: 3177: too few arguments to function 'dev_kfree_skb'
ppp.c: 3182: too few arguments to function 'dev_kfree_skb'
make[3]: *** [ppp.o] Error 1
make[3]: Leaving directory '/usr/src/linux-2.0.33/drivers/net'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory '/usr/src/linux-2.0.33/drivers/net'
make[1]: *** [sub_dirs] Error 2
make[1]: Leaving directory '/usr/src/linux-2.0.33/drivers'
make: *** [linuxsubdirs] Error 2

I have looked at the code very briefly, but couldn't notice anything
wrong.  However, I am not a kernel programmer.  Does anyone know
why this might be happening?  I have tried a number of things and have
just about exhausted all my options.

Any help would be much appreciated.

James.

--
 ,_ o     James Della-Porta

  \>> |   ICQ: 14189645                  
   \\,    http://www.dezzanet.net.au/~james        

2. Restricting TELNET and FTP access. Please help.

3. Missing Font? X11R6, XF86Config, && Advil

4. Kernel 2.0.33 + SCSI - Kernel panic

5. how to optimize linux

6. PPP and 2.0.33 Kernel problem

7. egcs: what to install?

8. sound module xconfig problem with kernel 2.0.33

9. Problem: automounter hangs (Kernel 2.0.33)

10. NIS problem with kernel-2.4.33.3

11. restore problem with taper 6.7.4 under Kernel 2.0.33

12. PPP and 2.0.33 Kernel Compile problem