COL 2.2 Modem

COL 2.2 Modem

Post by David Pullia » Mon, 24 May 1999 04:00:00



I am having trouble getting COL 2.2 to activate my modem and connect to my
ISP.  I set up everything else just fine(i.e. dns, phone #,
username/password).  It's in the device area that I'm having the problem.

The only setting that respont are ttyS1 and cua1, but when I try and
connect, they both say "Initializing Modem", (I never do here the modem
click like it should), then it says and stops at "setting modem sound".

It seems like linux can't find my modem.  How do I fix this.

 
 
 

COL 2.2 Modem

Post by Johan Kullsta » Tue, 25 May 1999 04:00:00



> I am having trouble getting COL 2.2 to activate my modem and connect
> to my ISP.  I set up everything else just fine(i.e. dns, phone #,
> username/password).  It's in the device area that I'm having the
> problem.
> The only setting that respont are ttyS1 and cua1, but when I try and
> connect, they both say "Initializing Modem", (I never do here the
> modem click like it should), then it says and stops at "setting
> modem sound".

since you mention ttyS1 and cua1 which in the ibm/microsoft world is
com2, i am assuming you are hooking up an external modem to the second
serial port.  you didn't specify modem brand and model.  that would
help.

ignore /dev/cua1.  it's been depreciated in favor of /dev/ttyS1.
do you get anything in your kernel boot up messages about the serial
ports?  did you enable com2 in the bios settings?

are you using a regular straight cable?  generally, your computer (at
least for ibm clones) is dte and the modem is dce.  what do your modem
lights look like?  do you get dtr?  do the tx/rx lights blink at any
time?

you may need run setserial (usually from some init file) to adjust the
speed and various other settings.

also, enable debug in /etc/ppp/options.  give chat the -v option.
look in /var/log/messages for signs of life (run less +F
/var/log/messages in a spare terminal).

Quote:> It seems like linux can't find my modem.  How do I fix this.

hope this helps.

--
johan kullstam

 
 
 

1. Linux Col 2.2 and Multiport PCCOM 8 board

PROBLEM:

I hope you'll send me some informations about caldera openlinux 2.2 system.
I can't to assign each door to tty create when I install a multiport PCCOM 8
board, when I use the
setserial /dev/ttyS4 irq 5 port 0x0280 autoconfig the program send me this
message: /dev/ttyS4: no such device, although the devices tty from 4 to 11
are created with makedev command.
Do I need to recompile kernel?
Why doesn't getty command in caldera openlinux 2.2 run correctly with
terminals?
Why do terminals run if I replace it with another getty (getty 2.0.7j)?

I wait for your fast answer.

Thank you.

2. E-MAIL LEGALITY

3. USR 56k Int Voice/Faxmodem and COL 2.2

4. Free OpenServer Install Problem (Strange)

5. Lost var dirs with COL 2.2

6. mmap failure

7. SB 16 in COL 2.2

8. Shutting down Apache on Win98

9. ssh1 & ssh2 won't build under COL 2.2

10. where I can find libcrypt.a in COL 2.2

11. JDK1.2.2 vs JDK1.1.7 on COL 2.3 -- some comments

12. COL 2.2 IBM CCA Ethernet adapter problem

13. partioning for COL 2.2.