1.2.9 w/ 1.2.8 elf patch

1.2.9 w/ 1.2.8 elf patch

Post by Chris Orig » Sat, 03 Jun 1995 04:00:00



Got the following (using the 1.2.8 elf patch from hj) with an 1.2.8 source
tree patched up to 1.2.9:

make[1]: Entering directory `/usr/src/linux/arch/i386/boot'
make[1]: Nothing to be done for `dep'.
make[1]: Leaving directory `/usr/src/linux/arch/i386/boot'
touch include/linux/version.h
for i in init/*.c;do echo -n "init/";gcc -D__KERNEL__ -I/usr/src/linux/include -E -D__ELF__ -M $i;done > .tmpdepend
set -e; for i in kernel drivers mm fs net ipc lib arch/i386/kernel arch/i386/mm; do make -C $i dep; done
make[1]: Entering directory `/usr/src/linux/kernel'
gcc -D__KERNEL__ -I/usr/src/linux/include -E -D__ELF__ -M *.c > .depend
In file included from ksyms.c:23:
/usr/src/linux/include/linux/interrupt.h:48: arguments given to macro `start_bh_atomic'
/usr/src/linux/include/linux/interrupt.h:53: arguments given to macro `end_bh_atomic'
In file included from sched.c:25:
/usr/src/linux/include/linux/interrupt.h:48: arguments given to macro `start_bh_atomic'
/usr/src/linux/include/linux/interrupt.h:53: arguments given to macro `end_bh_atomic'
In file included from softirq.c:16:
/usr/src/linux/include/linux/interrupt.h:48: arguments given to macro `start_bh_atomic'
/usr/src/linux/include/linux/interrupt.h:53: arguments given to macro `end_bh_atomic'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/usr/src/linux/kernel'
make: *** [dep] Error 2

Just FYI.

Chris

 
 
 

1.2.9 w/ 1.2.8 elf patch

Post by Caleb Epste » Sat, 03 Jun 1995 04:00:00


| Got the following (using the 1.2.8 elf patch from hj) with an 1.2.8 source
| tree patched up to 1.2.9:

  [ errors related to start_bh_atomic/end_bh_atomic snipped ]

        Whenever you patch your kernel you should check for rejected
hunks (find . -name '*.rej').  There was one for the header file
include/asm-i386/processor.h.  The end result is that you must remove
the definitions of these macros (start_bh_atomic, end_bh_atomic) in
that header file to get 1.2.9 to compile.

--


 
 
 

1. compiling 1.2.13 after applying io.h patch and elf patch

Hello
        I am still having problems.  I'm trying to recompile the dang
thing in order to enable IPX and then NCPFS.  I applied the elf patch
with the proper and same syntax as the io.h patch and I'm getting the
messages below.  Any ideas?  This is going to drive me to drink. Of
course this might be a better way to approach it :^).

---                                                     ---
"Very troubleshootery." - P.A.Miller in 'Year of the Comet'
0-                                                    ISFMS


2. Device drivers for video capture boards?

3. linux-1.2.13 needs 1.2.9.elf patch?

4. apache mod_rewrite / [P] option

5. Compiling ircii-2.8.2 in ELF. Patch needed?

6. Short period of depression in New Zealand

7. NEED: patch to emacs 19.28 to compile under ELF libs.

8. XFree86 and Gnome

9. ELF and io patches for 1.2.13?

10. patch to 1.2.13 to compile under ELF?

11. help w/gdb-4.14 and hj's elf patch

12. I wanna patch ELF files....

13. XFree86 3.1 ELF Patches