KDE 1.1 doesn't compile with glibc 2.1

KDE 1.1 doesn't compile with glibc 2.1

Post by T. J. Domsall » Mon, 22 Feb 1999 04:00:00



Hi!

Since I installed glibc 2.1 I cannot configure and make KDE 1.1 anymore.
I did it before with glibc 2.0.7 and it worked fine. Now I get the message
cross compiling=yes (from the c++ compilier, egcs 1.1.1) and "don't know
how to make 32 bit long integer".

SuSE 6.0, glibc 2.1, libstdc++ 2.8.1.1 /w glibc 2.1 patch installed, gcc
2.9.*
and egcs 1.1.1.

I need advice. Thanks in advance.

T. J.
--
T. J. D O M S A L L A_________________________________

____________________________http://www.domsalla.de/tj/

 
 
 

KDE 1.1 doesn't compile with glibc 2.1

Post by John and Lucy Hayward-Warburto » Wed, 24 Feb 1999 04:00:00



Quote:> Since I installed glibc 2.1 I cannot configure and make KDE 1.1 anymore.
> SuSE 6.0, glibc 2.1, libstdc++ 2.8.1.1 /w glibc 2.1 patch installed, gcc

Hmm... didn't your egcs-1.1.1 come with libstdc++.so.2.9.0 ? I don't
know if that's what's stopping your compile, though.

--
John Hayward-Warburton

http://i.am/broadcasting

 
 
 

KDE 1.1 doesn't compile with glibc 2.1

Post by Thomas Esse » Wed, 24 Feb 1999 04:00:00



: I did it before with glibc 2.0.7 and it worked fine. Now I get the message
: cross compiling=yes (from the c++ compilier, egcs 1.1.1) and "don't know

Normally, this just means that you compiler cannot compile+run an simple
test program. That it is not KDE's fault. You have somehow managed to
*up your system.

Thomas

--
Thomas Esser                http://www.veryComputer.com/~te/
University of Hannover, Germany
Informatics Institute (Databases and Information Systems Group)

 
 
 

KDE 1.1 doesn't compile with glibc 2.1

Post by Thorsten J. Domsall » Thu, 25 Feb 1999 04:00:00


John and Lucy Hayward-Warburton schrieb:

Quote:> Hmm... didn't your egcs-1.1.1 come with libstdc++.so.2.9.0 ? I don't
> know if that's what's stopping your compile, though.

It didn't make it before installing libstdc++ 2.8* either. It's the
glibc 2.1, which seems to make problems with c++. I have to wait for
the egcs 1.1.2.

T. J.

--
T. J. D O M S A L L A_________________________________


_____________________________http://www.domsalla.de/tj

 
 
 

KDE 1.1 doesn't compile with glibc 2.1

Post by Thomas T. Veldhous » Thu, 25 Feb 1999 04:00:00


Just try recompiling egcs-1.1.1.  That is what is REQUIRED for glibc-2.1
(until the political guru's change it to force the inferior gcc-2.8.1 or
something).

>John and Lucy Hayward-Warburton schrieb:
>> Hmm... didn't your egcs-1.1.1 come with libstdc++.so.2.9.0 ? I don't
>> know if that's what's stopping your compile, though.

>It didn't make it before installing libstdc++ 2.8* either. It's the
>glibc 2.1, which seems to make problems with c++. I have to wait for
>the egcs 1.1.2.

>T. J.

>--
>T. J. D O M S A L L A_________________________________


>_____________________________http://www.domsalla.de/tj

 
 
 

1. .kdelnk file (KDE 1.*) doesn't work in KDE 2.1

Using KDE 2.1 installed from source on a Red Hat 6.0 machine.

I've migrated my old kde 1.* .kdelnk application files to my
.kde2/share/applnk directory, and most work fine (either from the
K-start menu, or when dragged onto kicker and started from there).
The exception is my file for Word Perfect 8, which never launches the
command.

The file is set to execute `/opt/wp8/wpbin/xwp', which is the path to
the executable.  Issuing this command from a terminal, or from a `run
command' window (alt-f2) works, as does making a short cut on the
desktop (dragging the icon for this file onto the desktop and
selecting `link').

Here are the contents of wp8.kdelnk file:

[Desktop Entry]
BinaryPattern=
Comment[C]=Word processor
Exec=/opt/wp8/wpbin/xwp
Icon=wp
MimeType=
MiniIcon=
Name[C]=Word Perfect
Path=
Protocols=
SwallowExec=
SwallowTitle=
Terminal=false
TerminalOptions=
Type=Application
X-KDE-SubstituteUID=false
X-KDE-Username=

Anyone know what's up?

--

University of Cambridge, Zoology Department, Downing Street, CAMBRIDGE CB2 3EJ

2. aRts volume extremely low

3. Downgrading from kde 2.1 to 1.1 on RH 7.1

4. Doesn't linux support Cyrix DX2/80?

5. Fixed: Debian 2.1 and KDE 1.1

6. change mac addr

7. KDE 1.1 and Debian 2.1 (and no religion)

8. AIX-4.1.4 maxlogins problem !!!

9. can't compile kde 2.1, what's the problem ?

10. RH60 + KDE-1.1.1: can't compile krecord.....

11. KDE 2.1-beta1 doesn't save desktop settings

12. KDE 1.1 won't compile on Linux

13. Can't compile KDE 1.1