pppd & pppoe & dsl & 2.4.1

pppd & pppoe & dsl & 2.4.1

Post by Harmon Seave » Fri, 23 Feb 2001 23:53:50



      Got 2.4.1 working pretty well, trying to get my dsl modem working
(Ameritech) , and compiled pppoe (along with packet sockets and experimental
drivers) into my kernel (not a module) and got the latest pppd from mostrow,
along with the tarred version of pppoe from Raging Penguin, still no joy.
      I get messages in my logs that pppd was not compiled into my kernel and is
not available as a module -- but all the ppp options were in there except for
multilink so I can't figure out what the problem is. I would think that the
pppd install would put the modules where they belong, but possibly not????

--
Harmon Seaver, MLIS     Systems Librarian
Arrowhead Library System        *ia, MN

 
 
 

pppd & pppoe & dsl & 2.4.1

Post by Daryl Fonseca-Ho » Sat, 24 Feb 2001 08:44:49


On Thu, 22 Feb 2001 14:53:50 GMT, Harmon Seaver


>      Got 2.4.1 working pretty well, trying to get my dsl modem working
>(Ameritech) , and compiled pppoe (along with packet sockets and experimental
>drivers) into my kernel (not a module) and got the latest pppd from mostrow,
>along with the tarred version of pppoe from Raging Penguin, still no joy.
>      I get messages in my logs that pppd was not compiled into my kernel and is
>not available as a module -- but all the ppp options were in there except for
>multilink so I can't figure out what the problem is. I would think that the
>pppd install would put the modules where they belong, but possibly not????

>--
>Harmon Seaver, MLIS Systems Librarian
>Arrowhead Library System    *ia, MN


Did you upgrade your pppd to 2.4.0? That's the minimum required for kernel
2.4.x.

Also, since you compiled the pppoe support into the kernel, you should see in
/var/log/dmesg after boot:

        Registered PPPoX v0.5
        Registered PPPoE v0.6.5

My pppd 2.4.0 options are:

plugin /usr/lib/pppd/plugins/pppoe.so
name mylogonname
persist
maxfail 0
mtu 1492
mru 1492
noipdefault
noauth
defaultroute
usepeerdns
noaccomp
noccp
nobsdcomp
nodeflate
nopcomp
novj
novjccomp

lcp-echo-interval 20
lcp-echo-failure 3

HTH,
Wyatt

 
 
 

1. pppd & pppoe & dsl & 2.4.1

      Got 2.4.1 working pretty well, trying to get my dsl modem working
(Ameritech) , and compiled pppoe (along with packet sockets and experimental
drivers) into my kernel (not a module) and got the latest pppd from mostrow,
along with the tarred version of pppoe from Raging Penguin, still no joy.
      I get message in my logs that pppd was not compiled into my kernel and is
not available as a module -- but all the ppp options were in there except for
multiline so I can't figure out what the problem is. I would think that the
pppd install would put the modules where they belong, but possibly not????    

2. Which video cards work best?

3. ppp && PPPoE && ADSL && net && buffer(s)

4. can I use linux kernel drivers with FBSD linux compat?

5. &&&&----Looking for a unix shell------&&&&&

6. xterm -l -lf options not in SCO

7. 没有人用中文吗?

8. Linux on /dev/hda1 && Win95 on /dev/hda3

9. &&&&&& SUGGESTION ??? &&&&&&&&

10. Hercules &&&&&& SVGA ?

11. PERL && mod_perl && FreeBSD && Apache

12. &&&&&& NEEED HELP COMPAQ AND XXXXXXXXXXX

13. pppoe & static ips & sbc business dsl